封面

慈氏学九种译著
韩镜清 译藏为汉
中国佛教文化研究所编
中华佛典宝库制作电子书 2006年4月25日


目录


编辑说明、译者简介、内容提要

    编辑说明

    在《佛教文化丛书编辑说明》即本丛书编辑总说明中提到：“有特殊内容的另行分类，如《法相唯识学丛刊》中，因译作者所译慈氏学比一般所称唯识学范围较广、较重原典，故另立慈氏学开发译著一类。”《慈氏学九种译著》为韩镜清先生研究与开发慈氏学的重要译著，韩先生特写了说明，我们附之於後，以显其意向。
    一、《慈氏学九种译著》为韩镜清从《丹珠尔》中选译出来印度佛陀学圣者及诸论师有关慈氏学论著之一部分，先试刊行，均为玄奘法师未得译出者。暂列入《慈氏学译著丛刊》专辑。又慈氏学分三部分：三性学、般若学及唯识学。尤其注重慈氏五颂中汉译所缺之两种。今後将续刊行其他重要典籍。愿与读者共勉，妥善完成玄奘法师未竟之遗业。重新认识佛陀学，使其透明度增强。
    二、标点大体采用新式标点，其中与一般书稿标点或有不同之处有两点：
    其一，为明晰佛典的义理层次，有在一般书稿中不标出的短暂停顿，本书用顿点“、”标出。
    其二，为表达佛典中义理的贴近及连贯，有在一般书稿中用逗点“，”标示的，本书用顿点“、”标出。
    三、本书中偈颂从原文翻译过来，为成颂文形式、颂句中可有标点；颂句尾不一定有标点。
    四、所引经文中括号“()”内的字，系作者参照藏译所增补，所引原经处无有。

    译者简介

    韩镜清先生，一九一二年生，北京市人。一九三六年毕业於北京大学哲学系，一九三七年作研究生一年。先後在私立中国大学哲教系、中国佛教学院、天津南开大学哲教系任教，並学习藏文及对勘藏汉经论，试作译藏为汉工作。又在华北居士林及菩提学会从事研究与编辑工作。一九五一至一九五三年，参加中国科学院西藏科学工作队随军入藏，进行语言调查。一九五六至一九五七年参加民族语言调查工作队，再次去藏调查。一九五三至一九六五年任中央民族学院少数民族语文系藏语教研组副组长、副教授。一九六五至一九七七年任中国社会科学院世界宗教研究所副研究员。一九七七年初退休後至今，专门从事佛教慈氏学之研究与开发。

    内容提要

    时届末法、邪说蜂起。主要将清净法界等流之甘露搀杂我见毒素、使之依旧成为迷信神我或本体我之世间颠倒轮转戏论、远隔於出离、沉沦生死。
    例如真如本是无为法，却令之可以“受熏”，可以“缘起”愚夫恶浊世界；把真如混同於无明、混同阿赖耶识、而不以为怪。破坏佛教以讹传讹、大言不惭自认高於佛说、自我别立所谓“教法”。
    或有将阿赖耶识混同於外道神我、横加损减诽谤；根本不知遍计所执性与依他起性有严格不同。释迦牟尼首先把“我”与五蕴严格分离出来打下出离轮回生死之基业，却被此等凡愚又把五蕴混同於彼等增益之人我。不能空其所本空，却空其所不能空之缘起法、即虚妄分别，彼等不能善取空性、坚执其空无之有见可以证入真如，岂非南辕北辙？
    固然所有二种我执或遍计所执如言说所执之义、均由假立名言符号或虚妄能遍计而起，但这是走向岐途之分岐界线。但若如其构成而确认其缘起之实然亦可走上正轨，例如言说与其所指之依他起事並非一致、各为一依他起事而非有自性者，並没有必然的能诠与所诠关系，乃大家共同暂且承认者。所有符号或信息如果确有所诠、或所指之对象、即是有如其符号所指之定性意义，则从此走向有我之境界。因为此定性意义已超越生灭不停之依他所起诸事以外，不是假立或暂且承认者、事实上並没有真正脱离依靠名言或符号与依他起事之间暂且假立所谓能诠与所诠之关系。却因为假安立关系变成必然结合、认为二者相同。产生莫须有超关系超缘起之自有我体。好像名言或符号是後於它之随属物。
    此种坚执实有能诠与所诠之关系、亦可譬喻为能缘所缘之关系。本来能缘与所缘都是依他起事不能独立单存，却很容易变成各自独立之能取与所取两片单立关系。其实並没有单独各自之主体与客体，都是互相依存之刹那生灭、无有常一不变各守自性者。因此“能取”即成为“人我”，“所取”即成为“法我”。这都是人类主观增益上去之蛇耳！根本没有存在可能之馀地、将真实无我境界都颠倒武断造成有我境界。所以循环往复或轮 回转动完全无有明慧可言、是自造自取。本来並不颠倒却颠倒起来、这是无始以来就如是习以为常。於是与真实全然相背反，以至起惑造业博得异熟苦果。
    能诠与所诠本来不是一个，却以之为二独立体合成一独立体。能缘与所缘本来不是两个，相分与见分只是自体分上之两相关方面、不可分开离异；却认为是两个独立体。即纵任无明在作祟。凡愚却以此为正常合理之事项不容再议。骤然接触佛陀言教这种如实震迷特殊离言学说、是太不习惯，认为反常不值一顾。却很容易使不颠倒言论也按照其习惯去处理、把佛教整个经论也变成彼等所习以为常之体系。也就用自己有我境界同化无我境界，不是认为它是神教，就是把二无我才能显出之真如、当成其自我恶浊世界之缘起根源，或把真如当成以心为本体我、或以物为本体我一样之生灭不住系列，因为逃不出有我境界，必须把它当成是“我”，是独立存在或常一不变之体制，必须把它还原为彼等已经非常习惯之“法我”而後快、不出执空与执有，其实其空执亦是有见之一，比有见影响更为恶劣，均为遍计所执义。
    许多佛教典籍开宗明义都先排除如其名言而执有所诠之遍计所执义、或排除在相分见分以外执有能取或烦恼障、即以人我为主，及执有所取或所知障、即以法我为客是两片世界。如世亲在解释慈氏所著《辨法法性颂》开端即说归敬颂云：“世间如言执义者、无胜知彼入迷途。造此略论说此义。合掌礼敬我上师！”
    所以要读懂《辨法法性论》，必须理解离言法性、或无二空性，及诸法虚妄分别性或唯了别识性、或假安立性才可。又如《辨法法性论》第六颂云：
    “法性之能相谓真如：无有所取及能取，无有所诠、及能诠，无此差别、即真如。”
    “法”之表现即生死有为法、“法性”之表现即涅槃。而“法”则在以上第四颂文说为：
    “似二显现、如言显，虚妄分别法能相。”
    “似二显现”即指相分与见分依他起事，“如言显”即指所诠与能诠依他起事。以“虚妄分别”为其能相、即一切法之能界定。而虚妄分别即指：
    “显现无所有、非实。”
    所谓“虚妄分别”即如其分别如其显现而了无所有，“非实”即“虚妄”或“颠倒”，也即是“迷乱”、“谬执”等。
    为方便理解何以虚妄分别实旨即无分别空性、应引《辨中边论》中首颂：
    “虚妄分别有、於此二都无。此中唯有空(即“唯无二空性”)，於彼亦有此。”
    “分别”、“显现”中本无所取与能取，即本无二我、本无主观与客观两边世界。所以无分别空性即是法性。分别之所以为虚妄即在於二我境界本空，即在於不离二无空性。所以《摄大乘论》说“等觉诸分别、得无分别智”之颂句。
    因此、世亲《确显三自性颂》、总结出唯了别识与般若波罗蜜多之真正关联。三自性学是一切真谛学之根本、是诸法能相学共有之标志，是决了一切佛陀言教所有意趣之锁钥。
    《瑜伽师地论真实义品》提出四真实、及八分别与三事等、都不出以上宏旨，不过更具体化而已。有海云论师作解、更易悟入。
    《瑜伽师地论分别瑜伽品》即是《解深密经慈氏品》，是如何修习止观、对治虚妄、颠倒之门径，由如理思惟可直证空性、有智藏解释引人入胜。
    智月《略显瑜伽师修习义》著墨不多，却将龙友颂文及修观行之要旨豁然提示出来、不可多得，很易遵循。
    陈那不但精於现比二量之学，亦是解明般若及俱舍之论师。《入瑜伽论》提示其修行止观之经验。
    龙树菩萨《能达未达论》巧妙以所依与能依解释蕴与我之关联。内涵为蕴，与框架或皮层为我。内涵亦为幻有，“所显分”都无所有。具体指出我即是“常、遍、一”，或即是“作者、受者”。可与三自性学对照理解、而更使之明确。
    安慧《唯识三十论》能显示十大论师中最重要两大论师之一安慧所说。各自有其解释世亲《唯识三十颂》之特点。安慧解释《大乘五蕴论》殊详，此论有时参考彼释、可是护法解释《大乘五蕴论》可能较略、故玄奘未另译存。安慧还注解过世亲《俱舍论》及《大乘庄严论》，对界定大小乘一切教法有一定明确见解。至於他主张阿赖耶识只有自体分，而见分与相分都空无所有、即是遍计所执性，则此论未详。
    法称《正理滴点论》对因明理论概括性很强，每一环节都有精要看法，尤其在提举例句方面；我们应对每一例句作分析研究。与当今现下所有两方不同意见之诤论有所深入透视，也相应能找出其间之规律性来。不过此论中说三律中之“标志”处应根据内明理论加以透解。其中第一、如何有无所缘可得现前问题。第二、对“自性”与“法我”为空为假之分别问题。应指出其为世间暂时共许之假安立自性与差别。三、为何需要倒果为因之所为？利用世间因明可使世间人易於悟入即以上所列之正法。但应指出这还是虚妄分别，可以以楔出楔，並应强调出世间现量与世间现量之不同。可以对其宗因喻中所以成为过失处与以注意。


辨法法性论

    辨法法性论

    慈氏菩萨造颂
    世亲菩萨作释论
    韩镜清译藏为汉

    叙

    一生补处弥勒(慈氏)菩萨弘扬三时了义言教，造论有多种。首如《瑜伽师地论》为大乘佛法教理渊海，性相赅摄，诠真实义。唐玄奘法师(600－664)历尽艰辛赴印取经，新译百卷全文，开展三性唯识精义、但斯学沉响千馀载。近百年来、国内学术活跃。一八六六年，杨仁山居士(1837－1911)创立金陵刻经处以来，提倡发扬唯识学者，以欧阳竟无居士(1871－1943)主持之南京支那内学院及韩清净居士(1884－1949)主持之北京三时学会同为研究唯识学两大中心，一时学人辈出渐多，众有南欧北韩之称。此外，太虚大师创立闽南佛学院，亦提倡开讲唯识学。
    弥勒菩萨演说瑜伽大论外，西藏所传共有五颂，内地所传有其三，所缺《辨法法性颂》分辨法与法性，阐明生死涅槃妙理。法尊法师(太虚弟子)将此颂译汉文，太虚大师科题，印顺法师演释此论颂有讲记。欧阳渐(竟无)《法相辞典》叙，指点法尊译出《辨法法性颂》不符合玄奘法师所译《辨中边论》虚妄分别非实有亦非全无义，两译对照其言无二，显弥勒学。大启後学大疑大悟。学问细事愈研愈密，翻译艰难，文句委曲、必符原旨。《成唯识论》十大论师各有独见、义海波澜、词锋尖锐、切磋琢磨。但求真理不惜身命，此种精神唯佛法有，且何只亿万斯人。
    一九三九年夏，余与王森田、韩镜清二居士在北京北海菩提学会同学藏文，校勘《瑜伽师地论》，森田又治梵文因明，镜清从欧韩学主治三性唯识。人世沧桑，弹指已五十春秋，当年师友多凋零，可慨也夫！嗟吾人处不停之运，操必化之躯，生寄死归，谁其获免？为人欲不虚来此生，志学当择大者为上，慧命重於生命，正闻贵於躯体，行莫妙於般若，学莫精於唯识，先贤以毕生精力倾注於此，盖有由矣！
    镜清居士远继奘基近承欧韩二公遗志，半世纪来，潜心译业，将弥勒《辨法法性论》造颂，及世亲菩萨释论，同时译藏为汉文，较法尊法师只译颂句，更进一步方便深研。只眼独具，孤征法海，潜德幽光，开诚淑世，实乃千古一大事因缘。余读之，多年疑虑，砉然得解。修十法行书写为首，敬书付印以广流传。依法非人，依智非识，声同气求，德必有邻。当有豪杰奋然崛起，继承奘师未竟伟业，大转法轮弘扬唯识学，利乐诸有情，共登无上觉。
    董绍明
    一九八九年十二月三十日於北京温泉医院
－－－－－－－－－－－－－－－－－－－－－－－－－－－
    辨法法性论

    慈氏菩萨造颂
    世亲菩萨作释论
    韩镜清译藏为汉

    敬礼无胜薄伽梵！
    世间如言执义者、　无胜知彼入迷途。
    造此略论说此义。　合掌礼敬我上师！
    从师听闻得斯传，　斯论句简、义实深。
    尽己所能于每句、　努力分辨作解释。

    1 颂曰：
    知所以已、何当断，　馀者何所当现证，
    因此、彼等能相门，　欲分辨故、造斯论。
    论曰：“知所以已何当断馀者何所当现证”者：谓如其次第约杂染能相法、及清净转依所显法性而说。
    “彼等能相门欲分辨”者：谓简别不同境界为门之义。馀义已解。
    2 颂曰：
    此等一切、二所摄：　谓法及法性所摄。
    论曰：若言“彼等能相门欲分辨”者，且只分辨法及法性、而非其他耶？若尔，则尽在於此耶？非於众多言说之外、分辨此二。若尔，云何世尊所安立蕴处界等？总略言之，此一切为二。何以故耶？由法及法性所摄故。此蕴处界等、总略为此二种：谓法、及法性。言“此等”者：谓所有所说、即此所说所摄之义。又言“一切”者：即彼亦唯此之义。此外者、或即此所摄故，或不复有故。
    3 论曰：如是无差别说己、若说尚不知何者为何所摄、即由生死及涅槃所差别者，是故说颂曰：
    法所显、谓生死。　法性所显示者、谓三乘所证般涅槃。
    论曰：此中“法”者：谓具有杂染能相故，此之生死自性、说为由“法所显”。又另一者、言“法性所显示者谓三乘所证般涅槃”。“般涅槃”者、是三乘所证得故，说为“三乘所证般涅槃”。又既是三乘、又是般涅槃故，说为“三乘所证般涅槃”。此中“法性”者：由具有转依能相故，由此所摄般涅槃者、说为“法性所显”。
    4 论曰：如是生死及般涅槃虽为法及法性所显，尚未说能相故、若说如何为此之能相即此法尚未知者，因此为显示彼之能相故、故说颂曰：
    似二显现、如言显，　虚妄分别法能相。
    论曰：“似二显现如言显”者：谓似二显现、及如言说显现。此中所取能取事、谓显现眼及色等之二。依於此二、如言说显现。即是假立自性及差别所依自体、为虚妄分别。由说此为法之能相故、即无倒无馀说。
    5 论曰：此中“虚妄分别”训释词者：颂曰：
    显现无所有、非实。
    论曰：何以故？此法非实有。“遍”声及“计”声之训释词者、颂曰：
    能遍计者、谓一切　　本无有义，唯分别。
    论曰：虽无有义、而亦显现，彼之自体非圆成实故。唯分别者：谓唯迷乱显现有故。已说法之能相讫。
    6 颂曰：
    法性能相谓真如：　　无有所取、及能取，
    无有所诠、及能诠，　无此差别、即真如。
    论曰：若无有所取及能取之差别，若无有所诠及能诠之差别，即此、为真如。此亦即是法性之能相。无差别性者，如次即离二性故，即离言说性故。若於是处差别非有，即说此为无有差别故。若二或所诠能诠为实有者，如谓此是所取、此是能取；或谓此是所诠、此是能诠者；则差别成为实有。然此本无所有故，即本无差别之真如。由此亦说为法性之能相故、即是无倒无馀显示法性之能相。
    7 论曰：先前所说法之能相者：颂曰：
    由显现无所有故，　迷乱即是杂染因。
    犹如观见幻象等，　亦由不观见实有。
    论曰：若由是故、本非是有而显现者，即由是故、显现无所有。是故当知唯是迷乱。即由是故、亦为杂染之因。由执著於此故，後时三种杂染生起故。云何说显现无所有耶？说言：“犹如观见幻象等”、喻如所作幻象等、珍宝、及谷物等、如所显现不如是有，又即是显现时、如是虚妄分别亦是正当其无所有而显现。复次、实有亦不显现故。说随所谓迷乱转者：谓实有二种无我不显现故、亦是迷乱。如是於世间观见所谓迷乱能相即石垛行相、与人行相、交错有无、及不显现显现故。
    8 论曰：复次、由何义故，不许无所有、及以显现、其任一为无耶？颂曰：
    无所有、及以显现、　二者之中若一无，
    迷乱及以非迷乱、　　杂染、清净、不随转。
    论曰：若唯是无所有、而不成为显现者，由彼无故、不成为迷乱。无所有者、即唯无所有性、不迷乱故。若无迷乱，则不迷乱亦当为无。由以不迷乱为先行故。因此、杂染亦成为无所有。由此具有迷乱因故。由此无所有故、清净亦不成。清净者、具有杂染为先行故。是故此若无者，则不勤奋当解脱故、与现量相违。然若唯成为显现、而不为无所有者，若如是者，亦无所有为无故，不成为迷乱。若彼显现之体性、为圆成实者，则不迷乱故。若无迷乱，如前、所馀亦不得成。是故士夫作用成为无义故、与道理相违。世间於如是别别成就之石垛、及士夫等、亦迷乱而假立名故。如二及如言说显现法之能相、及无此差别法性之能相、已说讫。
    9 论云：若如是者，法、及法性、彼等许为一性，抑计为异性耶？颂曰：
    二者非一性、　亦非别别性。
    由有及无等、　无有差别故。
    论曰：言“二者”者：谓法、及法性等、不许一性及异性。此何以故耶？由有及无、亦有差别、及无差别故。且非不许法及法性。此何以故耶？有及无等有差别故。法性是有、而法是无故。有与无具有差别等、如何成为一性？亦非异性。何以故耶？有及无等、无差别故。云何无差别耶？法性者：唯由无法所显故。无有所取等差别故。法及法性等非是一、亦非别别、已说讫。
    10 论曰：然而如是无异，云何依此等、悟入或善悟入此法耶？颂曰：
    由於有六种、　无上悟入法，
    解说由悟六：　能相、及成就、
    非一非异性、　共依、不共依、
    无所能取现。
    论曰：此中言“能相及成就非一非异性”者：谓於前经略说。此三者当知如经说：谓能相、成就、非一性及非异性。“能相”者：谓二显现、及如言说显现虚妄遍计，即法之能相。“成就”者：谓若从於无所有及显现中任一为无者，则由不许迷乱、不迷乱、杂染、及清净、成过失故。由许此二故有果成就。“非一性非异性者”：谓说有与无、有差别及无差别故。如前本经说。
    11 颂曰：
    若有於此能生死，　即此、为所遍依止。
    器世间如共有性。　有情世间共、非共。
    论曰：此中若有能生死、及若於此生死者，即此、为法之所依。又此如次为能依、及所依自性事、有情界及世间界。此中世间界者、为共有之了别，於一切有情各自相续中、生起显现此之识故。又此另一、为有情界。此又共及非共。
    12 颂曰：
    能为生起及语言、　　　摄受照管、及处罚、
    功德、过失、互增上，　此是有情界所共。
    论曰：诸生起及见解等之语言、利益、损害、功德、过失，为各别相续所有者，更互生起显现此之识时，由增上性互为因故，说为有情界共有。如由言“互为因故”所成就。说“增上”者：即为除遣所缘因。
    13 论曰：
    此云何为不共耶？颂曰：
    所依、及了别、　　业、及与苦、乐、
    死、生及缚、解、　即由不共故。
    论曰：此中“所依”者：谓阿赖耶识。由显现此之诸了别习气依止於此故。“了别”者：谓转识。“业”者：谓善、不善、及无记。其馀如本经当知。
    14 颂曰：
    显现为共有、　为外间所取、
    虽即能取识　　以为其体性、
    然离识无义，　由共有性故。
    此了别亦异，　然非是境界。
    论曰：此中诸所依等、由非是具有身故，及内自所证知故，由非相互各自相续上生起显现此之了别原因、故说为有情界非是共有。身语表业等、虽是彼此生起显现此之了别原因，然何故非语言所摄耶？解云：身语表业，虽为语言所摄，然此非是表业。此中唯由此善性、及不善性、使此成为可了知业性，由此增上、作是显示。如是显现此之了别、亦非彼此生起显现此之了别原因，故身语表业非是共有性。悟入无有所取显现及无有能取显现者、即由此当悟入无有所取显现故，乃约悟入无有所取显现而说云：“显现为共有、为外间所取、虽即能取识以为其体性，然离识无(外)义。由共有性故。”意谓：何以故？由於各自相续上生起显现器了别、唯是能取了别性故。成为能取了别时离显现此之识以外、成为外间成为能取了别者都非是有。“此了别亦异、然非是境界。”若由是故、由是共有器之了别於各自相续上生起显现此之了别，即由是故、各自一方之了别亦各自异、然非成为他境界。因此、义即无有。有情界共有之所取了别亦由此除遣。
    15 颂曰：
    非属共所有　　所取诸识义、
    他心诸等引　　以及非等引，
    此能取了别、　彼此亦非境。
    论曰：另外所有不共所取了别之义、所谓他心及心所有法、如非等引及等引二种能取了别、亦非彼此互为境界。
    16 颂曰：
    於诸非等引心中、　善显现自分别故。
    论曰：此何以故耶？“於诸非等引心中、善显现自分别故”。若由是故、於非等引心中显现自分别之所取了别性成为境界，即由是故、他心等非此之境界。
    17 颂曰：
    於等引定所行境、　善显现彼影像故。
    论曰：另外於等引心中亦显现定所行境界为彼之影像故，随即悟入他心等非是境界。若由是故、於等引了别中亦显现定所行境界为彼之影像了别性，即由是故、彼之境界亦非是他心等。
    18 颂曰：
    因此显现能所取　　　分别为无、善成就，
    无始等起、善成就，　及二不成、善成就。
    论曰：若如是者，由自了别性亦是境界故、除自识外无有成为外间义。由此无故、所取显现无。於成就所取显现无有时、能取显现亦成就无有。由所取无、能取随无故。依此当知由悟入所取显现及能取显现无有、次第成就。此何以故耶？“无始等起善成就”故。若有不知真如、显现本无所有之二颠倒相续者，即是“无始等起”。因此成就无始等起故，由圆满成就故，即无有所取及能取显现二种颠倒、是虚妄不如实故，依此、亦无有所取能取显现。云何依此耶？依“及二不成善成就”故。当知依观见与二取毕竟不成就为相反之识生起等为因，由此、说如是遍知为无上悟入法。已说悟入法讫。
    19 颂曰：
    无上悟入法性门、　　　除此六种别无有：
    能相、遍所依、决择、　能证、及与随忆念、
    彼之体性随现前、　　　如是六种善知晓。
    论曰：若由是故、现在当说悟入法性故，即说言“无上悟入法性门、除此六种别无有”。即由六种解说：谓由悟入能相、遍所依、决择、能证、随忆念、及彼之体性现前转。
    20 论曰：能相者：如前经略说。
    如前义、作颂曰：
    能相：谓所取、能取、　所诠、及能诠差别、
    都无所有之真如、　　　即说为法性能相。
    21 颂曰：
    遍所依：谓一切法、　十二分经教句身。
    论曰：所说“遍所依谓一切法十二分经教句身”中、“一切法”者：谓色等。“十二分”者：谓契经、应颂等。说此二者，谓约杂染及清净所摄而论。
    22 颂曰：
    决择：谓依大乘经、　如理作意思所摄
    一切加行方便道。
    论曰：於所说“决择谓依大乘经如理作意思所摄一切加行方便道”中、“一切”者：谓闻思修所显。由此、於此、决择故。
    23 颂曰：
    触证：谓得正见故、　由见道通达证得
    亲领受真如现前。
    论曰：此中言“触证谓得正见故即由见道通达证得亲领受真如现前”中、“触证”者：谓由见道自内证知真如。又此亦言“证得、亲领受”。证得性、即亲领受者。由说言“证得亲领受”故。又此“亲领受”、当云何安立耶？解曰：依现前道理、为说若能使现前，即此为亲领受故、作此显示。
    24 颂曰：
    随忆念：谓如所触证　　诸菩提分法所摄、
    为清除彼众污垢、　继行一切修习道。
    论曰：由随忆念此诸触证之义故、说言“随忆念谓如所触证(或如所证见)诸菩提分法所摄、为清除彼众污垢、继行一切修习道”。此中由见道无间之修道、说为“随忆念”。由分辨此已证得之道而随念故、能使现前。又此何所为耶？解曰：为清除彼众污垢，即由修习真如故、为断所馀以应当断除为能相之污垢义。
    25 颂曰：
    彼之体性随现前、　依於真如离污垢，
    一切行相显真如、　究竟转依圆成实。
    论曰：随忆念无间为彼之体性随现前故、显示此者：言“彼之体性随现前依於真如离污垢一切行相显真如究竟转依圆成实”中、由修道断离所馀污垢故，真如离污垢时、由究竟道从一切行相上唯显现真如：由远离一切污垢故、成为唯真如体性故，如是唯此为境、即说言“彼之体性随现前”。又此转依即圆满成就、即彼之体性故。见道等位显示於此、圆满成就。无馀永断污垢故。
    26 颂曰：
    当知转依十悟入、　　　除此以外别无有：
    自性、事、补特伽罗、　殊胜、所为、与所依、
    作意、加行、及过失、　功德、十应善了知。
    论曰：於此转依中、云何当悟入？云何於此成为无上悟入？解曰：由十种无上悟入转依。即由十种解说：一、自性。二、事体，三、补特伽罗。四、殊胜。五、所为。六、所依。七、作意。八、加行。九、过失。十、功德。
    27 颂曰：
    自性悟入谓真如　　远离所有污垢时、
    客尘烦恼不显现、　真如得以净显现。
    论曰：此中第一悟入自性者：谓为客尘污垢及真如、不显现及显现、真如离污垢。为客尘污垢不显现、及为真如显现、若真如已成无污垢者，即此、为转依自性。
    28 颂曰：
    事悟入、谓三转依：　共器了别转真如。
    经藏法界转真如。　　不共有情界了别、
    亦转依成为真如。
    论曰：此中言“事悟入谓三转依共器了别转真如经藏法界转真如不共有情界了别亦转依成为真如”中、转依事者：谓三种真如转依、既依彼随行差别，亦依果差别。由显现、教诫、遍示现果不同故。
    29 颂曰：
    补特伽罗悟入者：　第一、二转依真如、
    即诸佛及菩萨有，　最後二乘亦共有。
    论曰：此中但言“补特伽罗悟入者第一二转依真如即诸佛及菩萨有”、而非馀所有。由不共有故。言“最後二乘亦共有”中、由亦是诸佛及诸菩萨所有。由是共有故。
    30 颂曰：
    殊胜悟入者：　　即佛菩萨有。
    土清净殊胜，　　法身、受身胜，
    化身得殊胜。　　依获得示现、
    教诫、及自在、　均极殊胜故。
    论曰：此中言“殊胜悟入者即佛菩萨有土清净殊胜”中、“土清净殊胜”者：谓为诸佛菩萨二所有、而非声闻所有。此中显现具有高下故。言“法身受身胜化身得殊胜依示现教诫及自在均极殊胜故”中、获得示现性殊胜者：当知依一切所知行相得现在前。获得教诫性殊胜者：由宣说多种甚深、广大、希有法门、不可思议故。获得自在性殊胜者：谓获得成办有情事业无碍神通等不可思议功德故。此等如其次第当知依於所得法身、受用身、变化身。
    31 颂曰：
    所为悟入者：　宿愿极殊胜、
    大乘教法中　　所缘极殊胜、
    所有十地中　　加行极殊胜。
    论曰：此中言“所为悟入者宿愿极殊胜大乘教法中所缘极殊胜所有十地中加行极殊胜”中、由三种所为殊胜较之声闻、及独觉、菩萨转依极殊胜故。三种殊胜中、“愿殊胜”者：谓依宿愿殊胜，即依菩提愿。“所缘殊胜”者：谓依大乘教中所缘殊胜，即依缘一切总法、及非总法、与彼之真如。“加行殊胜”者：谓依十地中加行殊胜。为断一切障、修彼能对治勤加行故。
    32 颂曰：
    所依悟入者：　　由六种当知
    无分别智故：　　谓依於所缘、
    依遍断所相、　　依正勤加行、
    能相、功德故、　及遍知智故。
    论曰：此中转依之所依者：即无分别智。由此所依获得转依故。云何悟入此耶？解曰：由六种悟入无分别智。依六种悟入者：一、所缘。二、断所相。三、正加行。四、能相及随赞。五、功德。六、遍智。
    33 颂曰：
    所缘悟入者：　谓由於四种：
    首为大乘教、　及於彼胜解、
    及於彼决择、　圆满备资粮。
    论曰：此中言“所缘悟入者谓由於四种”者：即由无间解说故。一、大乘教法。二、於彼胜解。三、於彼决择。四、圆满资粮。此无分别智所缘者：谓大乘教法、於彼胜解、决择、圆满资粮。若缺任一，无分别智不生起故。因此、即显示一切所缘悟入。
    34 颂曰：
    断所相悟入：　　　当知由四种：
    谓所对治分、　　　及能对治分、
    真如、及一切　　　　证知达法所相
    粗、中、细、以及　　长时所随逐，
    无不俱断尽。　　　　正显由异门。
    论曰：此中说言：“断所相悟入当知由四种”：一、所对治分。二、能对治分。三、真如。四、断尽证知法所相。此中“断所对治分所相”者：谓依断贪等所相。“断能对治分所相”者：谓依断不可爱等所相。“断真如所相”者：谓依亦断“此是真如”勤策想。“断尽证知法所相”者：谓依断由於诸地修习故获得证知法所相。谓即说乃如是、及由此依次粗、中、细、及长时随逐。此中“所对治分所相”者：由是粗重因故，易了知故，为粗。由是彼之能对治故，“能对治所相”、为中。“真如所相”者、为细。由是此外一切之能对治故。由“证知法所相”是修果故，当知是“长时随逐”。
    35 颂曰：
    正加行悟入、　亦依四种知：
    谓可得加行、　不可得加行、
    可得不可得、　不可得可得。
    论曰：此中正加行悟入者：有四种：一、“由可得加行故”。谓依唯识可得加行。二、“由不可得加行故”者：谓依无义可得。三、“由可得不可得加行故”者：谓依若无义者唯识亦不可得，由无所了别义、能了别不可得故。四、“由不可得可得加行故”者：谓依由二不可得故、无二可得。
    36 颂曰：
    能相之悟入、　当知由三种：
    安住法性故。　谓无有二法、
    且离言说故。
    论曰：此中“能相悟入”者：谓由三种：一、依“安住法性”者：谓安住无二法、及无言说之能相故。
    37 颂曰：
    由无显现故：　　谓无二种法、
    如言说、自在、　境界、了别识、
    器世间显现、　　一切无有故。
    论曰：二、依六无显现者：一、二法。二、如所言说。三、根。四、境界。五、识。六、器世间。如是六种均无显现故。若於是处二显现、如所言说显现、根显现、境界显现、识显现及器世间显现、成无所有，即此、为无分别智。
    38 颂曰：
    即由此等故，　　谓远离分别、
    无见、及不住、　无显现、以及
    无有了别识、　　无有依事等、
    即如经所说　　　无分别智之
    六种相、今此　　当分明显示。
    论曰：若如是者，当显示何者耶？解曰：若如是者，由此显示：一、远离分别。二、无见。三、不住。四、无显现。五、无了别识。六、无依。如是六种无分别智、如经所说。此中於所取及能取事中、无有能所二分别故，说为“远离分别”。由言说不能显示故，说为“无见”。不住眼根等故，说为“不住”。由非是境界故，说为“无显现”。由无色等境界显现故。由非了别故，说为“无有了别识”。由非是所依事故、说为“无依”。
    39 颂曰：
    总由显现故，　如於虚空轮、
    观见一切法；　亦如幻化等
    观见诸行故。
    论曰：三、由显现故，一切法等同虚空显现故。由一切具有彼之境界所相都断绝故。由一切行如幻化等显现故。又由此知为虚妄显现故。言“等”者：当知谓如阳焰、梦境等。
    40 颂曰：
    功德悟入者：　当知由四种：
    法身圆证得、　无上乐住得、
    教授自在得、　教诫自在得。
    论曰：此中“功德悟入者：当知由四种”。“法身圆证得”者：谓由转依故。由“无上乐住得”者：谓断有漏乐、及毕竟转成彼之体性故。由“教授自在得”故者：谓由如所有、尽所有所应知、皆通达故。由“教诫自在得”故者：谓由悟入如所应显示众多法门故。由是证得四种功德之因故，说此智四种功德。
    41 颂曰：
    遍智悟入者：　　当知由四种：
    遍知对治故、　　遍知行相故、
    遍知差别故、　　及遍知业故。
    对治遍知者：　　谓无分别智
    能对治五种　　　不实自性执：
    法、补特伽罗、　转变、及不同、
    以及损减执。
    论曰：此中依遍智悟入者：谓依四种：一、遍知能对治。二、遍知能相。三、遍知差别。四、遍知业。
此中“遍知能对治”者：谓无分别智能对治五种无所有执故：一、法。二、补特伽罗。三、转变。四、不同。五、损减。本无所有故。能对治无所有执者：谓即无分别智。即如是所谓智、说为“能对治遍智”。五种无所有执者：一、无所有之法执。二、无所有之补特伽罗执。即执为胜义。三、无所有转变执者：谓诸法生灭执。四、无所有不同执者：谓执法与法性各各别别故。五、无所有损减性执者：谓法及补特伽罗等假有、亦损减故。
    42 颂曰：
    行相遍知：谓断离　　五种、为其自能相：
    无有作意、实超越、　寂静、及与自性义、
    异计度等之行相。
    论曰：此中行相遍知者：谓由断离五种行相为其自能相：一、无作意。二、实超越。三、寂静。四、自性义。五、能显露。
且此无分别智由无作意分别故成无分别自性、不应道理。若不作意分别是无分别者，则婴儿愚夫等智、亦成无分别。何以故？彼等亦於彼分位时、不作分别故。以实超越分别为自性、亦不应理。若以实超越为自性者，则修入第二静虑等等引住者、亦当成此。由於无寻伺时无分别故。以寂静分别为自性者、亦不应理。若由寂静分别而不分别者，则因於此诸沉睡、麻醉、昏厥者、亦当成此。何以故？彼等於彼分位时、不作分别故。然唯由本性为无分别者，则色等境、亦当成为无分别。何以故？彼等亦由无动作故、不作分别。又能显露无分别行相即是此者、亦不应理。若如作意谓如是为无分别、如是即无分别者，则此智非为生起。分别並言说无分别之作意、亦以分别为行相故。是故当知此智从以此五行相为自能相中解脱。
    43 颂曰：
    遍知殊胜者：　由五行相胜：　无有分别性、
    非是端隅性、　无有依住性、　毕竟、性无上。
    论曰：此中“遍知殊胜”者：谓由五种殊胜：一、无有分别性。二、非是端隅(或一偏)性。三、无有依住性。四、毕竟性。五、无上性。
此智由五种殊胜、较之声闻独觉、为最超越故。此中诸声闻、独觉、由分别涅槃与生死之功德与过患故，彼之智体亦具有分别。又是端隅性。唯缘於四圣谛之共能相故。亦是有依住性。由依住涅槃故。亦非毕竟性。由入无馀依涅槃断灭故。如《筏喻经》所说。亦是有上。有佛智为上故。
与彼等相违反、由五种殊胜佛及诸菩萨智最超越。由无分别故，不分别涅槃与生死、功德与过患故。非端隅性者：谓如一切所知自能相、及共能相、能为境界故。无有依住性者：谓不取涅槃、不捨舍生死故。毕竟性者：谓法身常故，般无馀依涅槃时、亦相续不断故。无上性者：谓较此更无最超越故。
    44 颂曰：
    业遍智谓由五业：　一切分别能远离，
    无上安乐能施与，　烦恼所知二障断，
    由此後得智悟入　　一切所知诸种类，
    一切佛土遍严净、　遍成熟一切有情、
    能付一切行相智。　如是五业最殊胜。
    论曰：此中言“业遍知”者：一、一切分别能远离。二、能成办无上安乐。三、能远离烦恼障及所知障。四、由此後得智能悟入一切所知行相。五、能严净佛土、能成熟有情、能付与一切行相智。
此中、谓由此智能作五业：一、能使一切分别现行远离。由杜绝等起故。二、能成办无上安乐。由通达所知如所有、尽所有故，成办一切最超越无倒、毕竟安乐故。三、能证得烦恼障及所知障远离。由正断绝具有习气随眠故。四、由无分别後得具有自能相境界智、亦能悟入一切所知种类。五、遍严净佛土，遍成熟有情，亦能付与一切行相智。
    45 颂曰：
    作意悟入谓如说：　　欲证菩萨无分别
    智体、应如是作意：　由具有无始时来
    不知真如诸无明　　　虚妄分别一切种
    为不实二显现因、　　亦是异所依相续。
    此中虽具有因果，　　然均是不实、非有。
    由如是幻显现故、　　彼之法性无显现。
    依彼显现本无有、　　亦即法性显现有。
    若如是如理思惟、　　证菩萨无分别智。(如理二字或作胜解亦可)
    依如是无体可得、　　能证知唯识可得，
    依证知唯识可得、　　证一切义不可得。
    依一切义不可得、　　证唯识亦不可得。
    依唯识亦不可得、　　证无二差别可得。
    所有二均不可得、　　即是无分别智体。
    由无境界、无可得　　诸所相不可得故、
    即此所表示性故。
    论曰：此中“作意悟入”者：谓欲悟入无分别智菩萨依何作意思惟今次第显示：言“虚妄分别一切种”者：谓阿赖耶识所摄。言“为本无(或不实)二显现因”者：谓由执著二法习气所摄持故。言“亦是异所依相续”者：当知即是转识。言“不知真如诸无明”者：谓依具有无始时来无明习气。由是颠倒无明因故。言“虽显现果具有因、然均是不实非有”者：谓此虚妄分别虽恒显现为识，然唯非实有。
复次、言“由如是幻显现故彼之法性无显现”者：即真如不显现。言“依彼显现无所有亦即法性显现有”者：谓此由彼无所有所显故。言“若如是如理思惟证菩萨无分别智”者：即是加行道所摄。言“如是无体可得”者：谓虚妄分别虽显现，而无所有可得等。言“能证知唯识可得”者：谓由唯识显现二故。言“依证知唯识可得证一切义不可得”者：谓由识体显现义故、外义无所有故。言“依唯识亦不可得”者：谓依所取及能取不可得。言“证无二差别可得”者：谓由无二性、此二无差别故。此二所取及能取自性不可得、即此体为二，当知即是无差别可得；差别者谓若有二、则可知故。此中言“所有二均不可得”者：谓所取能取不可得。言“即是无分别智体”者：谓显示所说。如是欲悟入无分别智菩萨、如是作意思惟，如是作意思惟、亦即悟入无分别智。如是如前所说、即能显示此。言“无境界”者：为除遣如眼等是具有境界。虽无可得，亦有具有境界故。言“无可得”者：显示色等境界非是可得故。此者、由“诸行相不可得”所显故。连同悟入智行相已说讫。
    46 颂曰：
    加行悟入由四种：　　胜解行地乃由於
    胜解加行得入故，　　即为顺决择分位。
    初地、内证加行故，　即此为触证分位。
    由於修习勤加行、　　入於前六未净地，
    亦入三种遍净地，　　即此、为随念分位。
    最後加行入佛地、　　任运成就诸佛事。
    相续不断无终故。　　即此、为彼之体性
    随起现行之分位。
    论曰：今若问菩萨云何加行者，即显示当获证得此智之加行。此加行悟入亦由四种：一、由胜解加行故、入於胜解行地。此者、即前所说顺决择分位。二、由善通达加行故、入於初地。此即由证见道善通达法界故。此者、亦即前所说触证分位。三、言“由於修习勤加行入於前六未净地”者：即第二地等。由未遍净性、亦遍行於所相故。言“亦入三种遍净地”者：谓第八地等。由遍净性、亦不遍行於所相故。由此之能对治道、任运自然转故。此者、亦即前所说随念分位。四、“最後加行入佛地任运成就诸佛事”、相续不断故。依此获得无间相续不断佛事、说言“最後加行”。此者、即前所说彼之体性随起现行分位。彼之体性随起现行分位、亦由成为此智之自性故，与转依之智体、成一味故。
    47 颂曰：
    过失悟入者：　谓无容转依
    有四种过失：　以无有所依
    烦恼不转失。　以无有所依、
    道得转起失。　以无有所依、
    安立数取趣　　说般涅槃失。
    以无有所依、　安立三菩提
    说有差别失。
    论曰：此中“过失悟入”者：谓无有转依、有四种过失：一、无有烦恼不转起之所依过失。若无转依者，即由无转依故、诸烦恼後不再生失于所依。云何为依住法性之转起？因此、如烦恼转起之所依说彼亦须所依者，谓无有所依烦恼不转起过失。如是有漏识具有所依而转起，如是、彼之能对治法亦须具有所依；因此、道之转起若无所依，即成过失。又喻如於生死补特伽罗说言生死、即假立诸蕴，如是於般涅槃补特伽罗亦须有假立所依事。且不许即是原心。与所对治为二之生与灭、同一时故。两相违者、不许同一依故。如冷与暖触、不许同一依。由般无馀依涅槃时、无有假立事故。因此、如蕴假立般涅槃补特伽罗之所依事说须无有者，即成般涅槃补特伽罗无有假立所依之事之过失。三种菩提差别无有假立事之过失、即为第四。
    48 颂曰：
    依彼等相反、　说有转依体
    功德事悟入、　当知有四种。
    即此等四德，　如转依悟入
    当知为十种。
    论曰：由如是故、无有所依事之转依为有。若此外、转依为有者，则与彼相反、当知为四种功德。若如是者，此转依悟入当知为十种。
    49 颂曰：
    无所有之法显现、　喻如幻事及梦等。
    论曰：如虚妄分别显现亦非是有、已说讫。然於此当说能信受此之喻事。喻此本无所有而显现者：即幻事、梦境等。喻如幻事及梦境等虽可得、然非是有，如是诸法显现、亦唯是无。言“等”者：谓等取傍生爱、寻香城等，亦当知焰阳、回响、水月等。
    50 颂曰：
    转依之譬喻：　虚空、金、水等。
    论曰：如由十种悟入转依为无上、已说讫。此中若於转依时、由成为异故，云何不成为转依之有变异法？是故虽既是转依，如非具有变异之法、如是说喻云：“转依之譬喻虚空金水等”。喻如虚空唯由自性本然清净，除暂时与雾气等连属外、纯不属彼；而非依远离彼故、为清净。由说非不净成为清净故。虽非生起清净性，然由远离不可得之因故、唯是可得。由极清净可得故，亦非当许虚空为有变异法。如是金亦唯住纯良性；由映夺暂时污垢故、唯彼不可得，而依远离彼故、为可得。由可得故、亦非已生。如是水唯住澄湛性；水中由连杂土质故、此唯不可得，而远离土质故、为可得。依可得故，由此相续转依之水质中未出现故、亦非已生。由澄湛性可得故，亦非许水质具有变异性。如是於转依时、此自性本然光洁清净亦非前所无有。然都由暂时客尘障显现故、而未显现。如不清净、非纯良、不澄湛性。依远离彼故、即显现。若於是处、法性具有变异故，依显现变异故，即犹未出现、亦非未生。由彼实无故，法性及由此所显转依为常。此中由金及水喻、非观待质地，唯显示功德为同法。而由虚空喻、则显示一切。由言“等”故、其馀相类行相亦可例知。如衣等远离污垢故、而得住清洁性等。

    〔迦什弥尔班祇达磨诃札那(大士夫)及译师罗丹协若(具觉慧)译梵为藏〕


确显三自性颂

    确显三自性颂

    世亲论师造
    大班祇达静祥
    及校译师国天降译梵为藏
    韩镜清译藏为汉

        小序

    何者为无，如何为无，何者为有，如何为有，乃世间哲学上至关重要之问题。佛陀学发展到一定成熟阶段出现了三自性学说，比龙树(Nā-gārjuna,第二三世纪时人)所说“因缘所生法，我说即是空，亦为是假名，亦是中道义”更为明确彻底，在历史上的代表人物为慈氏(Maitreya)无著(Asaga)世亲(Vasbandhu)等。代表的经论是《解深密经》、《入楞伽经》、《大乘密严经》以及《瑜伽师地论》、《大乘庄严经论》、《摄大乘论》、《辨中边论》、《辨法法性论》、《佛性论》等。时间只稍后於龙树及提婆(Āryadeva),可能是第三世纪。
    只说俗有真无，容易造成遍计所执性(人我与法我绝对无性)与依他起性(因缘假有或相依有性)混淆不清，於是对圆成实性(二无我所显真实)的认识也有出入，差之毫厘谬以千里，可参考真谛(Paramārtha,或亲依Kulanātha)所译《佛性论》卷一《破大乘见品》。言之话长，兹不多赘。
    无著《摄大乘论》是三自性学说重要典籍之一。世亲、无性(As-vabhāva)均有释论。可能世亲释《摄大乘论》后，写《唯识三十颂》前，写此《确显自三性颂》，只有三十八颂，亦未及作解释。今从藏译本转译为汉文，并采集截取《瑜伽师地论》、《摄大乘论》世亲本人等著作，勉力切合颂文原意，以作注释，为理解之方便。颂文亦有些新义，足资研寻，不能尽罄其旨。《西藏大藏经》中另有一个译本，名为《入三自性成就论》(见北京版Dbu-ma Tsa 317B1_319A5　Rang-bsin gsum/lanjug-pahisgrub-pa)，题为龙树所造，並多出四颂，共四十二颂，其馀文义基本相同，此或龙树后人为发扬本师之学有采於无著等之论而广其说耶？

        确显三自性颂

  1 遍计所执、依他起、　及圆成实自性等，
    确定安立三自性、 许为甚深之所知。
  2 由依缘力始转起、 唯是所遍计事体，
    故能显现为依他、 似所显现遍计执。
  3 此能显现如所现、 恒常均是无所有，
    如是不复变易故、 即是圆成实自性。
  4 诸所显现、遍计执， 如所显现此二者、
    於此彼本无所有， 即此、为彼无二法。
  5 若於此无、遍计执， 并彼如义遍计执，
    如是极为无有故、 心者说为能遍计。
  6 由因事体、果事体、 此心许为二行相：
    所谓阿赖耶识、与 所谓七行相转识。
  7 第一由积集杂染 种子习气故、名心。
    第二於种种品类、 由善转起即言说。
  8 由此诸虚妄分别、 及以异熟、并如是
    另外显现我执之 差别故、许三行相。
  9 第一异熟为体性， 此者即是根本识。
    其他者为转起识。 所观、能见，分别转。
  10由有与无、二与一、 及杂染与清净等、
    由诸能相所显故， 此自性等许甚深。
  11若诸所取为实有， 即此、极为无所有。
    因此遍计所执性、 许为有与无能相。
  12实有错乱为自性、 如其显现无所有。
    因此依他起自性、 许为有与无能相。
  13若由是故无有二， 即无有二为实有。
    因此、圆成实自性 许为有与无能相。
  14遍计执义二行相 有与无为同一性。
    因此愚夫遍计执、 许二与一为体性。
  15显现之分既为二， 唯是错乱同一体。
    所谓依他之自性、 许二与一为体性。
  16以二自性为体性、 由无二成同一故，
    圆成实自体性亦 许二与一为体性。
  17遍计所执、依他起、 为所知、烦恼能相。
    即许圆成实自性、 为清净法之能相。
  18非谛实二之体性、 以无事体为真如。
    故除言遍计所执 以外、无异圆成实。
  19以无有二为自体。 由二本无为性故。
    当知除圆成实外、 无别遍计执能相。
  20如其显现为非我、 由如是为无自性，
    除言依他起性外、 非有差异圆成实。
  21由不如实二自性、 如其显现无事体，
    亦除圆成实以外、 无别依他起能相。
  22当说观待於言说 差别、自性之次第，
    及说如於此悟入 力故、为证知次第。
  23遍计所执言说体、 言说假安立体性、
    亦许以遍断言说 为另外之自体性。
  24先前以悟入二者 无我故、悟入依他。
    由二非是实有等。 唯是此中标志故。
  25此后以二无事体 为自性、悟入圆成，
    如是即此、於尔时、 亦说为有与无等。
  26此诸三自性等者， 以二无得为能相。
    极无、及与如是无、 此无事体为自性。
  27由以咒力作幻事、 於是显似为象身，
    许为唯行相显现， 象身普遍非是有。
  28遍计执性同象身， 依他起如彼行相。
    此中象事体绝无、 如此许为圆成实。
  29依根本心二、显似 非如实为我遍计、
    由二极无所有故、 此者唯是行相有。
  30根本识如同咒语， 真如许为树木块，
    分别许如象行相、 二者犹如象自身。
  31义之即此了别时、 遍知及以遍断离。
    如其次第能获得、 俱时能了三能相。
  32能遍知无有可得， 许能断离诸显现。
    由无有二可得故、 所证得亦即现前。
  33由象身无可得故、 彼之行相当销失。
    树木块体当可得、 如其如於幻化中。
  34如是二不可得时、 显现为二当销失。
    若销失则此圆成、 当证知二无事体。
  35所对治、慧能自在， 如其义无慧能见。
    随逐此三慧对治、 能任运获得解脱。
  36唯於心中为可得， 所知之义不可得；
    所知之义不可得、 故心亦无有可得。
  37由二无有可得故、 当能缘得於法界。
    由缘得於法界故、 当能得圆满究竟。
  38由能得圆满究竟、 由获得具有三身
    无上菩提体性已、 善成就自他利益。

    颂意根源

   1 遍计所执、依他起、及圆成实自性等，
     确定安立三自性、 许为甚深之所知。
    【颂意根源】：《瑜伽师地论》卷七十四第二页第三行云：“复次、由此三种自性一切不了义经诸隐密义，皆应决了。”如此下文及《解深密经》等广说。
    《摄大乘论》卷二第十三页第四行云：“二、(能)相秘密者：谓於是处说诸法(能)相、显三自性。”(汉译“能相”只作“相”，今依藏译加“能”字。)
    《摄大乘论世亲释》卷五第十三页第四行解云：“谓於宣说诸法(能)相中说三自性。”
    《摄大乘论》卷二第十三页第十行云：“若有欲造大乘法释，略由三(能)相应造其释：一者、由说缘起。二者、由说从缘所生法(能)相。三者、由说语义。”
    《佛性论》卷二第三页第五行云：“四、体(能)相者：有二：一、通。二、别。通者：由此三性通能成就一切诸馀真谛。或二、三、四、七谛等法，故诸真谛不出三性，是以三性为诸真谛通体。”(第二别体当分见於后。)
    《佛性论》卷二第一页第十七行云：“复次‘三性所摄’者：所谓三无性及三自性。三无性者：一、无(所)相性。二、无生性。三、无真性。此三性摄如来性尽。何以故？以此三性通为体故。”

   2 由依缘力始转起、　唯是所遍计事体，
     故能显现为依他、　似所显现遍计执。
    【颂意根源】：《摄大乘论》卷二第一页第六行云：“此中何者依他起(能)相？谓阿赖耶识为种子虚妄分别所摄诸(了别)识。此复云何？谓身、身者、受者(了别)识，彼所受(了别)识，彼能受(了别)识，世(了别)识，数(了别)识，言说(了别)识，自他差别(了别)识，善趣恶趣死生(了别)识。此中若身、身者、受者识，彼所受识，彼能受识，世(了别)识，数(了别)识，处(了别)识，言说(了别)识，此由名言熏习种子。若自他差别识，此由我见熏习种子。若善趣恶趣死生(了别)识，此由有支熏习种子。由此诸(了别)识一切界、趣、生、(“生”汉译作“杂染”今依藏译改)所摄、依他起(能)相之(汉译原无“之”字)虚妄分别皆得显示(“示”汉译原作“现”)此诸(了别)识之唯(了别)识性皆是虚妄分别所摄(以上十九字依藏译有所改动。)非是实有，是无所有(藏译无此四字)非真实(藏译作“错乱”二字)义显现所依。如是名为依他起(能)相。
    此中何者遍计所执(能)相？谓於无义唯有(了别)识中似义显现。”(汉译不分辨别识与了别识，都以一“识”字表之，今依藏译特以“了别识”与“识”〔指不包括所缘之辨别识〕区别开来，一般说“唯识”，均指“唯了别识”。请特别注意。)
    《摄大乘论世亲释》卷四第二页第十八行解论云：“‘於无义’者：谓无所取、如实无我。‘唯有(了别)识中’者：谓无实义似义(了别)识中、如唯似我显现(了别)识中。‘似义显现’者：似所取义相貌(应作“所相”二字)显现，如实无我、似我显现。”

   3 此能显现如所现、　恒常均是无所有，
     如是不复变易故、　即是圆成实自性。
    【颂意根源】：《摄大乘论无性释》卷四第三页第四行解论云：“‘谓於彼彼依他起(能)相由似义(能)相永无有性’者：谓於缘起心及心法所现影中由横计(所)相永无所显真如实性，此即名为圆成实(能)相。”

   4 诸所显现、遍计执，　如所显现此二者、
     於此彼本无所有，　即此、为彼无二法。
    【颂意根源】：《摄大乘论无性释》卷四第三页第四行解二分显现云：“‘如此诸(了别)识皆虚妄分别所摄’者：如前所说身等诸(了别)识所取能取(藏译有“事体”一词)虚妄分别安立为性。‘唯(了别)识为性’者：由邪分别(藏译作“邪遍计”。)二分显现。善等法中虽无邪执，缘起力故、二分显现、亦唯是(了别)识。(“善等法中”以下文，藏译原本无。)‘是无所有非真实义显现所依’者：所取色等名‘无所有’。能取识等、名‘非真实’。此二皆是遍计所执。并名为义。(“能取识等”以下文、藏译原本无。)虚妄分别所摄诸(了别)识是此二种显现因缘(藏译作“显明之因”。)故名‘所依’。”

   5 若於此无、遍计执，　并彼如义遍计执，
     如是极为无有故、　心者说为能遍计。
    【颂意根源】：《摄大乘论》卷二第六页第十行云：“当知意识是能遍计。有分别故。所以者何？由此意识用自名言熏习为种子及一切(了别)识名言熏习为种子，是故意识无边行相分别而转。普於一切分别计度故，名能遍计。”

  6 由因事体、果事体、　此心许为二行相：
    所谓阿赖耶识、与　所谓七行相转识。
    【颂意根源】：《摄大乘论》卷一第七页第十行云：“此中安立阿赖耶识因(能)相者：谓如是一切种子阿赖耶识於一切时兴彼一切杂染品类诸法现前为因。此中安立阿赖耶识果(能)相者：谓即依彼杂染品法无始时来所有熏习、阿赖耶识相续而生。”

   7 第一由积集杂染　　种子习气故、名心。
     第二於种种品类、　由善转起即言说。
    【颂意根源】：《摄大乘论》卷一第五页第七行云：“心体第三若离阿赖耶识，无别可得。是故成就阿赖耶识以为心体。由此为种子、意及识转。何因缘故亦说名心？由种种法熏习种子所积集故。”
    《摄大乘论》卷一第八页第五行云：“复次阿赖耶识与彼杂染诸法同时更互为因、云何可见？譬如明灯焰炷生烧、同时更互。又如芦束互相依持、同时不倒。应观此中更互为因道理亦尔。如阿赖耶识为杂染诸法因，杂染诸法亦为阿赖耶识因，唯就如是安立因缘，所馀因缘不可得故。”
    《摄大乘论无性释》卷三第二十页第四行解论文云：“‘名言熏习差别’者：谓我、法、用、名言多故。(藏译作“谓诸明记我、法、用、假安立言说。”)有人、天、等我，眼、色等法，去、来等用(“用”即“所作”藏译缺“来”。)熏习差别。由此我法用影显现、诸(了别)识生起功能差别。”

   8 由此诸虚妄分别、　及以异熟、并如是
     另外显现我执之　　差别故、许三行相。
    【颂意根源】：《摄大乘论》卷一第十六页第十九行说阿赖耶识差别中之三种云：“此中三种者、谓三种熏习差别故：一、名言熏习差别。(无性解释此差别已如前引。)二、我见熏习差别。(无性释云：“谓四烦恼所染污意萨迦耶见力故，於阿赖耶识中有能执我熏习差别。”)三、有支熏习差别。(无性解释此文云：“谓福、非福、不动行增上力故，於天等诸趣中、有无明等乃至老死熏习差别。”)”《摄大乘论》卷二第十三页第十一行云：“此中说缘起者：如说‘言熏习所生诸法，此从彼。异熟、与转识、更互为缘生。’”

  9 第一异熟为体性，　此者即是根本识。
    其他者为转起识。　所观、能见，分别转。
    【颂意根源】：《摄大乘论》卷一第十页第七行云：“复次，其馀转识普於一切自体诸趣应知说名能受用者。如《中边分别论》中说伽陀曰：‘一则名缘识，第二名受者，此中能受用、分别、推心法。’如是二识更互为缘。”《摄大乘论无性释》卷二第十八页第四行解论文云：“‘能受用’者：谓受蕴。‘能分别’者：谓想蕴。‘能推’者：谓行蕴，思能推心於彼彼转。最胜故说。如是三蕴皆能助心受用境界，故名‘心法’。”

  10 由有与无、二与一、　及杂染与清净等、
     由诸能相所显故，　此自性等许甚深。
    【颂意根源】：《摄大乘论世亲释》卷四第十五页第十二行解三自性以异门而成中云：“‘毕竟不如是有故’者：所遍计上遍计所执毕竟无故，即此自性成圆成实。”
    《摄大乘论无性释》卷四第二十三页第十一行云：“‘如所遍计毕竟不如是有’者：於依他起如所显现毕竟无故。如是即说三种自性不全成异、亦非不异。观待异故。”
    《佛性论》卷二第五页第二行云：“问曰：若依他起为圣智所摄者，云何说依他性缘分别性得成？答曰：依他起有二种：一、染浊依他。二、清净依他。清净依他缘如如得成故。”
    《摄大乘论》卷二第十三页第十五行云：“复次、彼转识(能)相法有相(“相”、藏译为“rgyu-mthan”即“原由”或“根据”义。“rgyu-mthan-dang-can”、他处汉译作“相分”。)有见(藏译为“Lta-ba-dang-can”。他处汉译作“见分”。)(之了别)识为自性。又彼以依处为(能)相，遍计所执为(能)相，法性为(能)相。由此显示三自性(能)相。如说：从有相(相即原由)、有见、应知彼三(能)相。”
    《摄大乘论世亲释》卷五第十四页第十七行解以上论文云：“谓彼诸(了别)识有相(相即原由)、有见、(即相分与见分。)以为其体。又彼(能)相有其三种。”

  11 若诸所取为实有，　即此、极为无所有。
     因此遍计所执性、　许为有与无能相。
    【颂意根源】：《佛性论》卷二第三页第八行云：“二、别体者：(三性“通成就一切诸馀真谛”已如第一颂註间引讫。)於三性中、各有实义。何者实义？一者、分别性体恒无所有，而此义於分别性中非不为实。何以故？名言无倒故。”

  12 实有错乱为自性、　如其显现无所有。
     因此依他起自性、　许为有与无能相。
    【颂意根源】：《佛性论》卷二第三页第十行云：“(“诸真谛不出三性”中之别体)二者、依他性体有而不实。由乱识根、境，故是有。以非真如、故不实。何以故？因缘义无倒故。是以对分别性、故名为有。对后真性、故非实有。是名有不真实。”

  13 若由是故无有二，　　即无有二为实有。
     因此、圆成实自性　　许为有与无能相。
    【颂意根源】：《佛性论》卷二第三页第十三行云：“三者、真实性体、有无皆真。如如之体非有非无故。”

  14 遍计执义二行相　　有与无为同一性。
     因此愚夫遍计执、　许二与一为体性。
    【颂意根源】：《佛性论》卷二第三页第十四行云：“问曰：是三性实(能)(原无“能”)相云何？答曰：分别性实(能)相者：人法增益、及损减。由解此性故、此执不生，是分别(能)相。人法者：是分别所作。若依真谛、观此人法为有，名增益执。若依俗谛、观此人法(假安有名言)是无，是损减执。若通达此分别性，则增益损减二执不生。是名分别实性(能)相。”

  15 显现之分既为二，　唯是错乱同一体。
     所谓依他之自性、　许二与一为体性。
     【颂意根源】：《佛性论》卷二第三页第十九行云：“能执所执增益、及损减。由解此性故、故此执不生，是名依他性(能)相。此能执所执、若见真为有，则是增益、名为常见。若见俗定无，则是损减、名为断见。若通此二性，则(原无。)断常二执並不得生、是名依他实性(能)相。唯有似尘识(即“了别识”。)故，则无能、所。无能所故，无增益执。由有似尘识故，无损减执。”

  16 以二自性为体性、　由无二成同一故，
     圆成实自体性亦　　许二与一为体性。
     【颂意根源】：《佛性论》卷二第四页第五行云：“复次、真实性(能)相者：有无及增益、损减、由解此性故，执不得生。所以者何？若执空(性)为有，名增益谤。若执空(性)为无，名损减谤。若通达此性，则二执不生、是名真实性(能)相。”

  17 遍计所执、依他起、　为所知、烦恼能相。
     即许圆成实自性、　为清净法之能相。
     【颂意根源】：《瑜伽师地论》卷七十四第七页第三行云：“问：此三自性几自非染能令他染？答：一。问：几唯自染？答：一。问：几自清净能令他清净？答：一。如染、当知苦亦尔。”

  18 非谛实二之体性、　以无事体为真如。
     故除言遍计所执　　以外、无异圆成实。
     【颂意根源】：《佛性论》卷二第一页第十九行解三无性云：“无(所)相性者：一切诸法但名言所显、自性无相貌(真谛玄奘均将所相译为相貌)故，名无(所)相性。无生性者：一切诸法由因缘生故，不由自能生。自他並不成就故，名无生性。无真性者：一切诸法离真(所)相故、无更别有实性可得故，名无真实性。”

  19 以无有二为自体。　由二本无为性故。
     当知除圆成实外、　无别遍计执能相。
     【颂意根源】：《摄大乘论》卷二第十页第十九行云：“世尊依何密意於《梵问经》中说如来不得生死、不得涅槃？於依他起自性中、依遍计所执自性及圆成实自性、生死涅槃无差别密意。何以故？即此依他起自性、由遍计所执分成生死，由圆成实分成涅槃故。”

  20 如其显现为非我、　由如是为无自性，
     除言依他起性外、　非有差异圆成实。
     【颂意根源】：《摄大乘论》卷二第七页第六行云：“由何异门即此(依他起)自性成圆成实？如所遍计毕竟不如是有故。”

  21 由不如实二自性、　如其显现无事体，
     亦除圆成实以外、　无别依他起能相。
     【颂意根源】：《摄大乘论世亲释》卷五第十页第十四行解论文伽陀意云：“说一切法无自性意今当显示。‘自然无’者：由一切法无离众缘自然有性，是名一种无自性意。‘自体无’者：由法灭已，不复更生，故无自性。此复一种无自性意。‘自性不坚住’者：由法才生一刹那后、无力能住，故无自性。如是诸法无自性理与声闻共。‘如执取不有故许无自性’者：此无自性不共声闻。以如愚夫所取遍计所执自性、不如是有。由此意故、依大乘理说一切法皆无自性。‘由无性故’者：由一切法无自性故，无生灭等皆得成就。所以者何？由无自性、故无有生。由无生故、亦无有灭。无生灭故、本来寂静。本寂静故、自性涅槃。‘后后所依止故’者：是后后因此而得有义。”

  22 当说观待於言说　　差别、自性之次第，
     及说如於此悟入　　力故、为证知次第。
     【颂意根源】：《瑜伽师地论》卷七十四第十四页第十九行云：“复次，云何当知色等想事、色等施设、是假名有，非实物(或译为“实质”。)有？谓诸名言熏习之想所建立识(指“辨别识”。)缘色等想事、计为色等性。此性非实物有，非胜义有。是故如此色等想法非真实有，唯是遍计所执自性；当知假有。若遣名言熏习之想所建立识，如其色等想事、缘离言说性；当知此性是实物(可译为“实质”。)有，是胜义有。此中道理、言论成立、如《菩萨地》(卷三十六第十八页第六行)应知。若诸名言熏习之想所建立识缘遍计所执自性为境。即说此性非内、非外、非二中间、少有可得，非已生、非当生、非正生，非已灭、非当灭、非正灭，本来寂静、自性涅槃。何以故？此唯假(安立)有、非胜义有故。若离名言诸法自性、当知此性(由)凡夫所生邪执为缘已生、当生、正生、已灭、当灭、正灭；若未永断、未遍知，便成杂染。若已永断，已遍知，乃成清净。”

  23 遍计所执言说体、　言说假安立体性、
     亦许以遍断言说　　为另外之自体性。
     【颂意根源】：《瑜伽师地论》卷三十六第十七页第十行云：“云何复名善取空者？谓由於此、彼无所有，即由彼故、正观为空。复由於此、馀实是有，即由馀故、如实知有。如是名为悟入空性、如实无倒。谓於如前所说一切色等想事(上)所说色等假说性法、都无所有。是故於此色等想事、由彼色等假说性法都无所有，是故於此色等想事、由彼色等假说性法说之为空。於此一切色等想事、何者为馀？谓即色等假说所依。如是二种皆如实知，谓於此中实有唯(想)事。於唯(想)事中亦唯有假(安立)。不於实无起增益执，不於实有起损减执，不增、不减，不取、不捨，如实了知如实真如离言自性；如是名为善取空者。於空法性能以正慧妙善通达。如是随顺证成道理应知诸法离言自性。”

  24 先前以悟入二者　　无我故、悟入依他。
     由二非是实有等。　唯是此中标志故。
     【颂意根源】：《佛性论》卷二第六页第八行云：“问曰：是真实性者，为可立净？为立不净？答曰：不可得说定净不净。若定净者，则一切众生不劳修行自得解脱故。若定不净者，一切众生修道，即无果报！
    若定净者，则无凡夫法！若定不净者，则无圣人法！何以故？净不净品皆以如为本故。若其定净，不即无明。若其不净，不即般若。此两处如性不异故。此真如非净非不净。欲显真如异眼等诸根、异禅定心等故。异眼等诸根者：诸根既不被染，亦应得同如理清净。而不然者、以有漏为因故。从本不净。真如不尔。在於佛地本性清净、无有从本是不净义。故异诸根。异定心等者：定体本性自净可得同真，而为四惑所蔽(原误作“瞰”。)故、转成不净。真如之理本来清净、则不如是；虽在无明谷中，终不为彼所污。”《摄大乘论》卷二第一页第六行云：“此中何者依他起(能)相？谓阿赖耶识为种子虚妄分别所摄诸(了别)识。”
    《摄大乘论》卷二第四页第四行云：“复次、云何安立如是诸(了别)识成唯(了别)识性？略由三(行)相：一、由唯此(了别)识无有义故。二、由二性(故者)、有相(分)有见(分)二(了别)识别故。三、由种种(俱时生起故者：此)种种行相而生起故。所以者何？此一切(了别)识无有义故，得成唯(了别)识。有相(分有)见(分)故、得成二种。若眼等(了别)识以色等识(藏译无“识”字。)为相(分)、以眼(等)识(了别)识为见(分)，乃至以身识(了别)识为见(分)，若意识以一切眼为最初、法为最后诸(了别)识为相(分)，以意识(了别)识为见(分)。由此意识有分别故，似(藏译作“显现”。)一切识而生起故。”

  25 此后以二无事体　为自性、悟入圆成，
     如是即此、於尔时、　亦说为有与无等。
    【颂意根源】：《佛性论》卷二第十四页第四行云：“……三、俱不乐者：谓修行大乘最利根人既不同阐提乐生死有，亦不堕非方便中同外道执，亦不堕方便中如二乘人。是故此人具行生死涅槃平等之道、住无住处。虽行生死，而不染。虽行涅槃，而非净。但为大悲故、不捨生死。为般若故、不捨涅槃。不离涅槃者：异声闻执永住无为。不捨生死者：异一阐提乐於生死。若乐著生死者，名一阐提。佛法内人堕定位者、亦同阐提。如是二人堕在邪定聚中。若乐灭生死有者，是人堕非方便中、则在不定聚。及俱不乐前二者、修平等道，是人在正定聚中。”

  26 此诸三自性等者，　以二无得为能相。
     极无、及与如是无、　此无事体为自性。
     【颂意根源】：《瑜伽师地论》卷七十四第九页第十行云：“法界清净(能)相者：谓此转依已能除遣一切(所)相故，是善清净法界所显。若不尔，此应无常、应可思议！然此转依是常住(行)相、不可思议。复次、此不可思议说名无二。由五(行)相(原作“五种相”。)应当了知：一、由自性故。二、由处故。三、由住故。四、由一性异性故。五、由成所作故。云何由自性故、不可思议？谓或即色、或离色，如是不可思议。或即受、想、行、识，或离受、想、行、识，如是不可思议。或即地界、或离地界，如是不可思议。或即水界、火界、风界，或离水界、火界、风界，如是不可思议。或即眼处、或离眼处，如是不可思议。或即耳、鼻、舌、身、意处，或离耳、鼻、舌、身、意处，如是不可思议。或有、或非有，如是不可思议。云何由处故、不可思议？谓或在欲界、或离欲界，如是不可思议。或在色界、无色界，或离色界、无色界，如是不可思议。或在人中、或离人中，或在天上、或离天上，如是不可思议。或在东方、或离东方，或在南、西、北方、上下方维，或离南、西、北方、上下方维，如是不可思议。云何由住故、不可思议？谓安住如是如是色类乐住、如是不可思议。安住如是如是色类奢摩他住、如是不可思议。安住有心处、如是不可思议。安住无心住、如是不可思议。安住如是色类圣住、如是不可思议。安住如是色类天住、梵住，如是不可思议。云何一性异性不可思议？谓一切佛同安住一无漏界中、为是一性？为是异性？如是不可思议。云何成所作故、不可思议？谓如是如是如来同界、同智、势力勇猛、住无漏界，依此转依能作一切有情义利，如是不可思议。此复二因缘故、当知不可思议：谓离言说义故、及过语言道故、不可思议。又出世间故、无有世间能为譬喻，是故不可思议。”
    《摄大乘论》卷二第十三页第十九行云：“复次、云何应释彼(能)相？谓遍计所执(能)相於依他起(能)相中、实无所有，圆成实(能)相於中实有。由此二种非有及有、非得及得、未见已见真实者同时。谓於此依他起自性中无遍计所执故，有圆成实。故於此转时、若得彼，即不得此；若得此，即不得彼；如说：依他、所执无，成实於中有。故得及不得、其中二平等。”
    《摄大乘论世亲释》卷五第十五页第二行解此论文后半云：“遍计所执及圆成实、名为‘二种’。如是二种、第一非有，第二是有。未见真者得遍计所执，不得圆成实。已见真者即此刹那得圆成实，不得遍计所执。於伽陀中、即显此义。谓‘依他、所执无’等。(原伽陀云：“依他、所执无，成实於中有。故得、及不得、其中二平等。”)‘平等’者：谓同一刹那。‘其中’者：谓依他起中。‘二’者：谓未见真者、及已见真者。‘故’者：是由此因义。谓於依他起中、由遍计所执无故，及由圆成实有故。又诸愚夫颠倒执故、如是见转。若诸圣者，由正见故、如是见转。”
    《摄大乘论》卷二第一页第十五行云：“此中何者遍计所执(能)相？谓於无义唯有(了别)识中似义显现。(藏译作“显现为义性”。)此中何者圆成实(能)相？谓即於彼依他起(能)相、由似义(能)相(藏译作“义之能相”。)永无有性。”

  27 由以咒力作幻事、　於是显似为象身，
     许为唯行相显现，　象身普遍非是有。
     【颂意根源】：《佛性论》卷一第十四页第七行云：“诸法空故、自性不可得。如见幻事。幻物者、证量所见，不如实有。诸法亦尔，不如所见而有所见。由体不实、故不有。由证量故、不无。由体无故、空义得成。以证量故、假有不失。”

  28 遍计执性同象身，　　依他起如彼行相。
     此中象事体绝无、　　如此许为圆成实。
   29 依根本心二、显似　　非如实为我遍计、
     由二极无所有故、　　此者唯是行相有。
     【颂意根源】：《摄大乘论世亲释》卷四第十七页第七行解释十种分别中前三分别云：“‘根本分别’者：谓阿赖耶识是诸分别根本。自体亦是分别。‘缘(所)相分别’者：谓色等(了别)识为所缘相分所起分别。‘显(所)相分别’者：谓并其所依所有眼识等之(了别)识显现似彼所缘境相分所起分别，有所分别、或能分别，故名分别。”
    《摄大乘论》卷二第八页第八行说十种分别第九分别云：“九、执著分别。谓不如理作意类萨迦耶见为本六十二见趣相应分别。”

  30 根本识如同咒语，　真如许为树木块，
     分别许如象行相、　二者犹如象自身。
     【颂意根源】：《摄大乘论》卷二第十页第九行云：“云何实无有义而成所行境界？为除此疑、说幻事喻。”
    《摄大乘论世亲释》卷五第二页第六行解释“由名前觉无”二颂中云：“‘如幻等’者：譬如幻象实无所有、而现可得。应知此中义亦如是。”卷五第五页第九行又云：“若实无义，云何成境？为治此疑，说幻事喻。显依他起譬如幻象、虽无实义，而成境已、义亦如是。”
    《摄大乘论》卷二第十一页第十六行云：“世尊有处说一切法常，有处说一切法无常，有处说一切法非常非无常，依何密意作如是说？谓依他起自性、由圆成实性分是常，由遍计所执性分是无常，由彼二分非常非无常。依此密意、作如是说。如常、无常、无二，如是苦乐无二、净不净无二、空不空无二、我无我无二、寂静不寂静无二、有自性无自性无二、生不生无二、灭不灭无二、本来寂静非本来寂静无二、自性涅槃非自性涅槃无二、生死涅槃无二、亦尔。如是等差别、一切诸佛密意语言由三自性应随决了如前说常无常等门。”
    《摄大乘论》卷二第十二页第十一行颂云：“自然，自体无，自性不坚住。(藏译则可作为“自及体性无，不住自事体。”)如执取(即“所执”。)不有、故许无自性。由无性故成后后所依止。无生灭、本寂、自性般涅槃。”

  31 义之即此了别时、　遍知及以遍断离。
     如其次第能获得、　俱时能了三能相。
     【颂意根源】：《摄大乘论世亲释》卷五第二页第十九行云：“若依他起如所可得、不如是有，既尔，何不一切一切皆无所有？此著无者，圆成实性亦无所有。何以故？有谤杂染、清净过故。杂染、清净、既现可得，故此二性俱非不有。若执为无，则拨现有杂染、清净、言无所有。”

  32 能遍知无有可得，　许能断离诸显现。
     由无有二可得故、　所证得亦即现前。
     【颂意根源】：《摄大乘论》卷二第十三页第十五行云：“复次、彼转识(能)相法有相有见(了别)识为自性。又彼以依处为(能)相，遍计所执为能相，法性为(能)相。由此显示三自性之(能)相。如说‘从有相有见、应知彼三(能)相。’”
    《摄大乘论世亲释》卷五第十四页第十七行云：“‘彼转识(能)相法有相有见(了别)识为自性’者：谓彼(了别)识有相有见以为其体。又即彼(能)相有其三种。‘依处为(能)相’者：谓依他起(能)相。由此所说三种自性显示彼(能)相。”

  33 由象身无可得故、　彼之行相当销失，
     树木块体当可得、　如其如於幻化中。
     【颂意根源】：《摄大乘论》卷二第四页第十二行已引颂文云：“唯此、二、种种，观者意能入。由悟入唯心、彼亦能伏离。”
    《摄大乘论世亲释》卷四第八页第二行解此颂文云：“於伽陀中能悟入‘(了别)识’者：悟入所取义永无所有故。能悟入‘二’者：悟入此(了别)识有相(相即原由)、见故。能悟入‘种种’者：悟入此(了别)识似种种(所)相而生起故。‘观(行)者意’者：诸瑜伽师所有意趣。问：於何悟入？答：‘由悟入唯心，彼亦能伏离。’若能悟入唯有其心、都无有义，是则彼亦能伏离。既无所取义，何有能取心？说入二性及入种种、皆为成立入唯(了别)识因。馀义相似。”

  34 如是二不可得时、　显现为二当销失。
     若销失则此圆成、　当证知二无事体。
     【颂意根源】：《摄大乘论》卷二第六页第四行云：“若圆成实自性是遍计所执永无有(之能)相，云何成圆成实？何因缘故、名圆成实？由无变异性故、名圆成实。又由清净所缘性故，一切善法最胜性故，由最胜义故，(汉译无“故”字。)名圆成实。”
    《摄大乘论世亲释》卷四第十三页第五行解云：“‘由无变异性故’者：谓无虚诳性。如不虚诳性。”

  35 所对治、慧能自在，　如其义无慧能见。
     随逐此三慧对治、　能任运获得解脱。
     【颂意根源】：《佛性论》卷二第九页第十五行说如来藏有五种中第四云：“四者、出世藏。真实是其藏义。世有三失：一者、对治可灭尽，故名为世。此法则无对治、故名出世。二、不静住，故名为世。由虚妄心、果报、念念灭不住故。此法不尔，故名出世。三、由有倒见故，心在世间、则恒倒见。如人在三界、心中决不得见苦法忍等。以其虚妄、故名为世。此法能出世间，故名真实为出世藏。”
    《摄大乘论》卷二第二十页第二行云：“如是菩萨悟入唯(了别)识性故、悟入所知(能)相，悟入此故，入极喜地、善达法界、生如来家、得一切有情平等心性、得一切菩萨平等心性、得一切佛平等心性。此即名为菩萨见道。”
  36 唯於心中为可得，　所知之义不可得；
     所知之义不可得、　故心亦无有可得。
     【颂意根源】：《摄大乘论》卷二第二十一页第十九行云：“复有《教授》(即指《慧度教授》)二颂、分别瑜伽论(“论”字疑衍)说：‘菩萨於(藏译作“由”字。)定位：观影唯是心。(藏译作“意”字。)义想即灭除，审观唯自想。如是住内心、知所取非有。次能取亦无、后触无所得。’”

  37 由二无有可得故、　当能缘得於法界。
     由缘得於法界故、　当能得圆满究竟。
     【颂意根源】：《摄大乘论》卷二第二十二页第一行云：“复有别五现观伽陀、如《大乘经庄严论》说：‘福德智慧二资粮、菩萨善备无边际；於法思量善决已、(藏译作“故”字。)了义行相唯是言。决知诸义唯是言，即住似彼唯心性、便能现证於法界。故二能相悉蠲除、慧证离心无别有，由此即证心非有。具慧了达二皆无，安住二无法界中。具慧无分别智力周遍平等顺证行，灭依榛梗过失聚、如大良药销众毒；佛说妙法善成立安慧於根法界中、知念行相唯分别，平稳疾归德海岸。’”

  38 由能得圆满究竟、　由获得具有三身
     无上菩提体性已、　善成就自他利益。
     【颂意根源】：《摄大乘论》卷三第十四页第二行云：“彼果智殊胜云何可见？谓由三种佛身应知彼果智殊胜：一、由自性身。二、由受用身。三、由变化身。此中自性身者：谓诸如来法身。一切法自在转所依止故。受用身者：谓依法身、种种诸佛众会所显，遍清净佛土、大乘法乐为所受用故。变化身者；亦依法身。从睹史多天宫现没、受生、踰城出家、往外道所、修诸苦行、证大菩提、转大法轮，入大涅槃故。”
    《摄大乘论》卷三第十八页第三行云：“诸有情利、乐、所作不过时，所作常无虚，无忘失、归礼！昼夜常六返、观一切世间，与大悲相应；利乐意、归礼！”

    注：颂意根源中所引《瑜伽师地论》、《摄大乘论》、《摄大乘论世亲释》、《摄大乘论无性释》、《佛性论》等均为金陵刻经处版本。


能达未达论

    能达未达论

    龙树论师作
    班祇达阿难陀
    及译师称自在慧译梵为藏
    韩镜清译藏为汉

    敬礼儒童像曼殊室利！

    敬礼无过失　　　功德海文殊！
    即此、未通达，　悲心写能达。
    此中有四：他难、遮破、通达彼、法真实性。
    他难者何？答曰：有我。此复为五：常、遍、一、作者、受者。
    又此中遮破者：此我为何？且蕴非是我。由具生灭法故。又蕴非与我异。如离瓶油脂、不可得有异故。如瓶中水、或瓶中油脂、亦是所依与能依。如果与皮、亦非蕴之内质、亦非蕴中凝聚者。由蕴是多性故。如天嗣有牛、亦非有蕴。
    此後、他难作是说言：若无我者，尔时布施等业与果相属、则无意义。云何牛死时，角、尾、及蹄等、尚成就耶？答言：请听差别喻：犹如所说、於月光下、辨绳为蛇而起恐惧。如是若於尔时、举灯照看，即於是时、知此是绳、而非是蛇。即可除遣增益执性，数取趣乃无我所摄。彼复难言：且绳非无！答言：此非是绳，而是两股。股亦无有。由是极微聚集故。极微亦非是有。乃由方分不同所显。如说法本无我云：
    方分不同所显时、　　极微中亦见差别。
    若处有分了知之，　　即此极微如何有？
    若尔，抑依此为无？　诸事非是实有者、
    无事当是孰所有？　　何由知是有无有？
    此中难言：生、住、灭、云何当知耶？答言：何者非无说为可有？谓生。若住灭为无、许是生者，尔时、兔角等何理能遣？
    难言：抑令其为有耶？质言：若生灭为无者，何故为住耶？
    难言：抑灭亦如是耶？质言：此亦非理。如何若处无有生灭，此处、即成为灭耶？
    难言：抑当顿时出现耶？答言：非是。更互相违故。如明与暗。
    难言：由说识者作如是言：即识为有。答言：若识为有者，尔时、请显示其自体：抑体为一？或体为多耶？且体为多者，则由众多境界差异、则不同故。无一性时、多性亦无。彼识一性既不可得，则任何义都不应有。或自、或他、或俱、或无因生、都不许故。
    复又难言：若此一切都无有者，何者为有耶？答言：犹如旋火轮、变化、梦境、幻事、及水月、雾气、及空谷回声、阳焰、及与云相同。此中所显分都无，所增加分毫无所有。如实性中、如实见，如实正见得解脱。此中一切不可得，无可得者亦除遣。觉慧可得既无已、无有可得应出现。

    註　　释
    ①《能达未达论》、即《能明辨二无我论》。


唯识三十论

    唯识三十论

    安慧菩萨造
    韩镜清译藏为汉

    卷第一
    敬礼儒童相妙吉祥菩萨！

    今造此唯识三十论者、为令於补特伽罗无我及法无我未知与邪解者无倒了知此二无我故。此中为显示补特伽罗及法无我、或为断离烦恼障及所知障故。所以者何？如是贪著等一切烦恼、依我见生故。若能了知补特伽罗无我，即能对治萨迦耶见故。彼若断离者，一切烦恼随断。若证入法无我，即能对治所知障故、所知障随断。此烦恼障及所知障已断离者、为得解脱及一切智故。以一切烦恼能障得解脱故、是故彼等若断，则得解脱。所知障者：谓於一切所知、能障智转起，即不染污无明。彼若断离者，遍於所知一切行相、转起无染著无 罣碍智、是故当证得一切智。复有谬执法及补特伽罗不善如实了知唯识者，为令了知法及补特伽罗无我、渐次悟入唯识及果故、今造此论。复次、或执所知如识实有、或执内识如所知世俗为有、胜义俱无，为遮如是二行相边论、今造斯论。
    颂曰：
    “由假说我、法、　有种种相转，”
    论曰：颂中应补言辞、谓“於世间、及诸论中”。
    颂曰：
    “彼依识所变。”
    论曰：即随所应当说“假说我法”言。由彼能假说我及法故，名为“假说我法”。又谓彼能假立我、及假立法。言“种种(行)相”者：谓无量行相：如我、命者、生者、意生、及儒童等、名“假说我”。如诸蕴、诸处、诸界、色、受、想、行、识等、名“假说法”。如是二种假说、即“识所变”性。云何说诸我、或法、非依实有而假建立耶？以诸法、及我、离识所变以外无所有故。云何名“变”？即诸转变。即於因刹那灭之同时、与因刹那不同果之体获得，名之为“变”。此中若我等分别习气遍增长，及色等分别习气遍增长，则阿赖耶识显现我等分别、及显现色等分别生起。此中显现我等、及显现法等、亦由本无有外我及外法而此分别转似外境以为因故，无始时来假说我等及假说色等法而转。喻如眩翳见毛轮等。言“假说”者：谓於此处本无有彼，即於此处、假说为彼。喻如以牛称彼愚人。若如是者於识之自体、及此外、本无诸我与法故，诸我、与法、即是遍计所执性。由於胜义非实有故，彼一边论执彼所知如识实有、不当应许。又“假说”者：离彼所依不得有故。若依於此、生起假说我与法、决定应许为有事体。是故由此所许、当知彼识亦如所知为世俗有，胜义俱无、道理相违。以世俗亦应无有故。若无所依，世俗不应得成。因此二种行相一边论者俱不应理故，论师说言应捨！若尔，一切所知是遍计所执性故、应说无有事体！由识是缘起故，许说实有。内识缘起者、由“变”声可知。云何应知无有外义、即唯识体生起义之行相耶？以外义即由能生起显现自身识故、许是识所缘缘，而非唯许能作因。由当与等无间缘等无差别故。五识身者、但缘和合。由似彼之行相故。和合者：唯是诸微分聚积，非离彼而有。若分析彼诸微分时，和合之行相识、定不起故。是故虽无外义，内识亦起。和合之行相以极微和合为体者、由诸极微非彼行相故。非和合位、与不合时、体相有异故。因此和合位如不合时、一切极微为彼所缘，不应道理。有执一一极微不相资位、非根能知，而展转相资位、根方能取！彼执不然。由相资位与不相资位自体无别，故彼为根所取、或根不知、亦应一致！若诸极微展转相资方为识境者，则瓶墙等差别行相不应於识现起。以诸极微非彼之行相故。识则异显现、境则异行相、有大过失，不应道理！又诸极微有此、彼、及中间诸部分故，犹如柱等、胜义非有。此若不许，则极微当无东、南、西、北等方分不同。是故极微亦当如识无有质碍、不住方所。若尔，外义无故、即唯识体义之行相生起。应许如同梦中诸识。又诸受等过去及未来者、非能生起彼之行相识。以是已灭及未生故。彼现在者、亦非能生现在识。於正生时、识等无有故。若已生起时、识亦已生起彼之行相故。以都无有少作用故。意识亦唯无所缘而得生起。有作是难：“若我及法不可得者，则假说亦不应有！”“假说”者：必依三种而成。苟任无其一，则不得成：谓真事、似此馀境、及此二共法。喻如有真事为火，似事为婆罗门婴，及此二共法为赤及猛利故。於婆罗门婴假说为火。此中於婆罗门婴假说为火者、或依类假说，或依实物假说。然此二种假说、俱不得成。此中且说共法赤、或猛利、非属火类。若无共法，於婆罗门婴依类假说、不应道理。成大过失故。若谓此类虽不具彼二法，然无此类、则猛性赤性即不生起。故於婆罗门婴依类假说；则虽无有类，於婆罗门婴猛性赤性亦现见故。若谓彼无、此亦不生起，亦不应道理！彼无、此亦不生起者：谓於假说中无有。以婆罗门婴亦应如火。有其类故。是故於婆罗门婴依类假说、不应道理。又依实物假说、理亦不成。以无共同法故。即彼火德猛利、或赤、非此婆罗门婴所有。所以者何？彼此相异故。其差别乃与自所依相属故。若无火德，於婆罗门婴假说为火、不应道理。若谓人德火德两相似故、可说为类者，则应由相似故、於婆罗门婴猛利德及与赤德假说彼火所有猛利德及与赤德。而以德相似故、於婆罗门婴假说为火，不应道理。以火名与德相似事不相应故。是故依实假说、亦不应理。又真事亦无。以彼自性越过一切智及言诠境界故。了彼本身智、及诠表彼之言说、唯以德为方便而转起，不触彼及自性。若不尔者，德将无义。若离智及言诠以外，其馀了知真事自性方便、不可得故。於主体自性境界中无有智及言诠故，当知真事亦无所有。如是与声不相应处、智及言诠亦无所有。如是由无能诠及所诠故，无有真事。复次、此诸一切唯是假有，非是实有。所谓假有者：即由如是道理转起：谓於是处、曾无有此。一切声亦於主体中实无、唯由假有性转起。由如是故，唯无实有。此中若谓无我与法故、不应假说，如是所说、理不成立。
    既能变识体有差别，今尚未知。为显差别、故说颂曰：
    “此能变唯三：”
    论曰：若於是处假立为我、及假立为法、即此亦由因事及果事故而有差异。此中因能变者：谓於阿赖耶识中所增长异熟、及等流习气。果能变者：谓由先业所感圆满而异熟之习气获得生起已、於诸馀众同分中引生阿赖耶识。并由等流习气得生起已、从阿赖耶识生起转识、及染污意。此中由善不善转识於阿赖耶识中能生起异熟习气及等流习气。由无记转识、及染污意、生起等流习气。所说能变三种、今尚未知，为显彼差别、故说颂曰：
    “谓异熟、思量、　及了别境识。”
    论曰：如是三种能变者：所谓异熟、所谓思量、及所谓了别境识。此中由善不善业习气成熟增上力故、随能引生所感果体者，名为“异熟”。染污意者：谓恒审思量为我之体性故、名为“思量”。由能各别显现色等境界故、六行相眼识等名为能“了别境”。
    以未说彼自性、今犹未知，为如次显明彼自性、故说颂曰：
    “初阿赖耶识，　异熟，一切种，”
    论曰：言“此中”者：(按汉译未标“此中”二字。)即指无间所说三种能变。言“阿赖耶”者：即称阿赖耶识。如是识体、即是异熟。由彼是一切杂染品法种子所依故，名为“阿赖耶”。所谓“阿赖耶”及“所依”者、乃属异名。复次一切法於此识中果事转起、并相应故，或此识於一切法中因事转起、并相应故，名为“阿赖耶”。以能识别、故名为“识”。一切界、趣、生及种姓、是善不善业异熟果故，名为“异熟”。是一切法种子所依体故，名为“一切种”。若离转识外、别有阿赖耶识者，为了解故、亦须说彼所缘及行相。以识无有所缘、及无行相、不应道理故。虽不许彼无有所缘、及无行相，然彼所缘、及以行相、不可分辨。何以故？谓阿赖耶识生起内执受了别、及行相不可分辨外器了别二种。此中内执受者：谓执著遍计所执自性习气、及具有所依根之色和名。以彼之所缘极微细故。颂曰：
    “不可知执受、处了，”
    论曰：若於是处、有不可分辨执受及不可分辨处了别故，即此阿赖耶识、说为“不可知执受”及“不可知处了”。此中“执受”者：谓能执受。此所执受、复分我等分别习气及色等分别习气。由於彼中有此故，阿赖耶识能执受我等分别及色等分别为果性故。是故说名执受我等分别及色等分别习气。谓於此识不能了知如是领受行相、谓“此者即此也”，是故说名“不可知执受”。再者执受所依、故名“执受”。所依者：即身。此具有所依根之色和名。执受彼故、即名为能趣。谓与彼同安危故、名为“执受”。此中於欲界及色界、执受二种。由远离色贪著故，於无色界不感生色异熟故、唯执受四名。然而此时色居习气位，非异熟位。於此执受中、不能了知谓“即此也”如是行相，说名“不可知”。“处了别”者：谓器世间安 佈了别。此由所缘、及行相、不分明转故，说名“不可知”。然识所缘、及行相、如何不分明耶？谓此如同诸馀说识者、於灭尽定等位。於灭等时、亦不能证知无有能了别体。以与理教二相违故。
    此中既说阿赖耶是识故、而能了别定与诸心所法相应故，应说一切心所法中、几相应耶？又如是心所有法是常相应？抑非常耶？是故颂曰：
    “常与触、作意、　受、想、思、相应，”
    论曰：言“常”者：谓尽其阿赖耶识所有边际、恒时与五遍行心所有法相应：即“触、作意、受、想、及思”。“触”者：谓尝受。此中“触”者：谓三和合已、能分辨根变异。以受之所依为业。根、境、识三、名三。彼三因事果事同时依住，名为三和合。由此有故，即於此同时能分辨与随顺生起乐等受根上变异、成为领受与此相同乐等境界之行相，名之为触。根亦由其差别、为乐苦等因性，如是即名根上变异。此触由与根上变异相同故，名根上所有触、或由根上之触所触、故名为“触”。是故虽以分辨境界变异为体性，然亦说为分辨根上变异。此以受所依为业。如经说云：“以领纳乐所有触为依故，乐受生起。”乃至广说。“作意”者：谓发动心。能令发动、故名发动。谓於所缘境中由此能令心现起趣向。此以具有於所缘境能持心为业。持心者：谓即唯於此所缘境中、数数引心专注。此业唯约於心相续所缘境界决定作意、具有差别增上力故说，而此非依一一刹那心。以此唯於各自刹那心起其业用，而非於馀刹那故。“受”者：谓领纳为性。由能现前之境界差别、此复成三行相：谓以能令爽适、能令焦恼、及能令远离此二行相为各自体性故。即乐、苦、及非苦非乐。便作是思：由此能领受一切善不善业异熟果故，名为领受。此中乐领受者：谓诸善业异熟果。苦领受者：谓诸不善异熟果。非苦非乐领受者：谓善不善二业异熟果。此中唯说阿赖耶识体是善不善业异熟。谓依胜义，与此识相应捨性、实是善不善业异熟果。乐与苦者、乃依善不善业异熟所生起故，假安立“异熟”名。此中乐领受者：谓此生时、不欲远离，於此灭时、生复遇欲。苦领受者：谓此生时、即欲远离，於此灭时、不欲复遇。非苦非乐领受者：谓若此生、若此灭时、二欲不起。“想”者：谓於境能取所相。境者：谓所缘。所相者：谓彼之差别。即以安立青黄等所缘为因。取所相者：如分别谓此是青、而非是黄。“思”者谓能令心造作、令意奔动，犹如由磁石之增上力令铁奔动，如是由有此故、於所缘境令心奔动。
    受者有三行相：一者、乐受。二者、苦受。三者、非苦非乐受。法有四行相：一者、善法。二者、不善法。三者、有覆无记法。四者、无覆无记法。此中由於阿赖耶识总说受故、於三种受中尚不知是何受，如是於四法中亦犹未识是善、是不善、是有覆无记、是无覆无记，是故颂曰：
    “唯捨受，　是无覆无记、”
    论曰：言“此中”者：(按汉译未标“此中”二字。)由正值说阿赖耶识时分故、今即直指为“此”。谓於此阿赖耶识中、唯是捨受，而既非乐、亦非是苦。以此二所缘、及行相、俱分明故。言“是无覆无记”者：亦直斥阿赖耶识。此中说“无覆”者：为简别有覆无记故说。“无记”者：为简别善、不善故。非是意地一切客尘随惑所覆蔽故，名为“无覆”。以变异而成熟故，又非善不善可记别故，是异熟体、亦是无记。颂曰：
    “触等亦如是，”
    论曰：如已说阿赖耶识一向异熟，所缘、行相、不分明，常与触等相应，唯捨受、及无覆无记，如是触等亦是一向异熟，所缘、行相、不分明，与除自身外馀四及阿赖耶识常相应。又除此触等以外亦唯捨受及无覆无记、均如阿赖耶识，即诸与异熟相应、而非为变异成熟、与所缘行相不分明相应、即分明所缘及行相亦不可有。如是於馀、当说亦尔。
    阿赖耶识尽生死际、无差异转耶？抑相续转耶？以彼非一向无差异转，而是刹那性故。如是颂曰：
    “恒转如暴流，”
    论曰：言“此”者：(按汉译略“此”字。)即正指阿赖耶识。此中“恒转”者：谓因果相续不断生起。於水聚中、前水後水相续不断流转，名为“暴流”。犹如暴流中漂流草、木、牛粪等，如是阿赖耶识具有福非福及不动业熏习；复挟同触、作意等、尽生死际相续不断相续生起。
    应思如是相续生起何时捨耶？是故颂曰：
    “阿罗汉位捨。”
    论曰：云何说名阿罗汉位耶？谓若具此者、是名阿罗汉果。具何者名为阿罗汉耶？谓得尽智、及无生智故，尔时阿赖耶识中麤重、无馀永断故，即捨阿赖耶识。即於此位、名“阿罗汉”。已说异熟、及其差别。
    今辨所谓思量为我即第二能变、故乃广说“依彼转”。此中如共许彼眼等识以眼等为所依、色等为所缘，如是染污意所依、及所缘、则不共许。然识无有道理不待所依、及与所缘，故今为显染污意所依及所缘故、及为显训释词故、颂曰：
    “次、第二能变，　是识名末那。
    依彼转。缘彼。　思量为性、相。”
    论曰：言“是识名末那”者：谓此名为末那之识、亦依阿赖耶识而转。言“依彼转”中、“彼”声即指阿赖耶识为此识习气所依。是故此识与所依俱转，即相续生起之义。复次若於三界中某地、阿赖耶识此处得异熟者，即此染污意亦即此界此地所有。由此识即依阿赖耶识而转故，颂说“依彼转”言。言“缘彼”者：即唯缘阿赖耶识为境。由与萨迦耶见等相应、而缘阿赖耶识为我及我所故。如何由彼心所生、又即以此心为彼所缘耶？犹如有馀虽不许有此识，然亦有时许依此心、意识得起；复缘此心为境、彼意识转。言“是识名末那”者：谓名为意之识、亦依阿赖耶识而得生起。由此所说颂“是识名末那”言、简别阿赖耶识及馀转识不同。复次、应思云何为彼自性耶？故颂说言“思量为性相”。如是以思量我为自性故，依训释词、说名为“意”。
    若以此亦是识体故、决定与诸心所相应者，此中未知与何心所相应、及几多时相应？是故颂曰：
    “有覆无记摄，　四烦恼常俱：”
    论曰：诸心所有法有二种：一者、烦恼。二者、此馀。为简别此馀故、今说“烦恼”言。六烦恼中、非与一切尽相应故，复说“四”言。言“俱”者：即是相应。烦恼亦有二种：一者、不善。二者、有覆无记。为简别不善、故说“有覆无记”言。此有覆识、不应与不善相应。以“有覆”者由是染污故。“无记”者：由不可记别善及不善性故。言“常”者：谓一切时。即尽此识所有边际、恒与彼等相应。虽已总说，未知差别、今显差别、颂曰：
    “谓我见、我癡、　并我慢、我爱。”
    论曰：於诸取蕴随观为我，名为“我见”。即是萨迦耶见义。“癡”者：谓无知。於我无知，名为我癡。“我慢”者：谓思量我所有境为我。即是计我而起我慢之义。“我爱”者：谓於我贪著，即是喜乐我之义。此中若愚於阿赖耶识自性者，即於阿赖耶识生起我见。由观为我故、令心高举，是名我慢。若有此三，则於思量为我之事体染著不捨、是名我爱。复说颂云：“由无明、我见、我慢、我爱四、令意常染污。思量我为相。能作颠倒因、此意恒染污，善、无记心时、常为我执因。”
    此诸我癡等烦恼、亦如意有九地。此中已总说，但未知为与自地相应、抑为与异地相应、是故颂曰：
     “随所生所繫。”
    论曰：“随所生”者：谓随於是处生起。言“所繫”者：谓随於此界、此地、生起，即与此界此地所有者相应、非与异界异地所有者相应。
    然此识唯与四烦恼相应耶？答：不尔。如是颂曰：
    “及馀触等俱。”
    论曰：即指所谓相应。言“及”声者：谓和集义。言“触等”者：谓触、作意、受、想、思。如是五法者是遍行故，与一切识相应。彼等亦随所生、即与彼处所摄相应，而非与异界异地所摄相应。复次、言“馀”者：为简别根本识相应故。谓根本识相应触等、是无覆无记性，而染污意相应者、如意亦是有覆无记性。
    若此染污意於善、染、及无记位中、无差别生起者，应无捨时！若无捨时，何有解脱？既无解脱，云何不成？实则不成，如是颂曰：
    “阿罗汉、灭定、　出世道、无有。”
    论曰“阿罗汉”者：谓诸烦恼无馀永断故，染污意亦无。此意如有顶修所断烦恼、於得阿罗汉时由无间道断。谓此於阿罗汉位、如馀烦恼亦无。不还果由已离无所有处贪著、得入灭尽定，亦由道力得入灭尽定故、於灭尽定位当亦如道而灭。灭尽定出已、复从阿赖耶识而生。出世间道、亦无。言“出世间”者：为简别世间故。唯於世间道位生起染污意。观见无我者、由能对治我见等故，於出世间道此不能生。由能治及所治二分不俱起故，此意於出世间道中灭。从此出时、复从阿赖耶识而生。如是已释所说“次第二能变”言。亦即总结。
    於第二能变後、当说第三能变，是故颂曰：
    “次、第三能变，　差别有六种：
    了境为性、相。”
    论曰：“第三”者：即“能变识”言为补足语。(按汉本只略去“识”字。)言“差别有六种”者：谓性境有六：一者、色性境。二者、声性境。三者、香性境。四者、味性境。五者、所触性境。六者、法性境。“了境”者：即能取、或分别之义。
    又此六、为善？为不善？抑为无记耶？是故颂曰：
    “善、不善、俱非。”
    论曰：谓是善、是不善、及是俱非。言“俱非”者：亦名无记。谓与无贪无瞋及无癡相应者、名为善性。谓与贪、瞋、及癡相应者、为不善性。谓不与善心所及不善心所相应者、为俱非。即是非善亦非不善之义。此前六识、复与何类心所有法相应耶？与此相应心所有法有几多耶？是故颂曰：
    “此心所遍行、 别境、善、烦恼、
     随烦恼、不定，皆三受相应。”
    论曰：如是所说遍行等、尚未了知，由为善显此故、颂曰：
    “初遍行：触等。”
    论曰：第一说故、名“初”。谓最先说。常与遍行触、作意、受、想、思相应。以触是彼等上首故，说为“触等”。以触、作意等五法、是一切心之随行故，说名为“遍行”。谓彼等於阿赖耶识、染污意、及诸转识、无差别转。依诸决定有差别境增上力、颂曰：
    “次别境：谓欲、胜解、念、定、慧、
    所缘事不同。”
    论曰：由於具有差别能决定，故名为“别”。彼等之境界、唯是具有差别性，而非是一切。此中“欲”者：谓於所意乐事体希欲为性。由於非意乐事体无有欲乐故。即显示各自境界决定性。即所见、所闻等境界可意乐事体、名为所意乐。於此所意乐境界愿见、愿闻等、名“欲”。此以能作精勤所依为业。“胜解”者：谓於所决定事体如其所决定印持为性。言“决定”者：为遮不决定故。於正理、或至教事体、无有犹豫，名为决定。谓若唯以此无常、苦等行相决定为彼事所有，即以如是行相於彼事体其心起解：谓“此如是、非不如是”。如是决定印持。即名为“胜解”。此以不可引夺性为业。谓能珍惜其胜解者、即敌论不能引夺自所立宗。“念”者：谓於串习事体、令心不忘失为性。串习事体者：谓曾经领受。不忘失者：谓为能续取所缘不失坠因。数数忆念能缘彼曾所取事体所有行相、名为明记。唯此明记者、说为明念性。此以具有不散乱为业。谓若於此所缘、有明记者，即不於馀所缘、或馀行相、散乱其心。是故此念以具有不散乱为业。“定”者：谓於所观察事体、令心专注同境为性。所观察事体者：谓所观功德、或过失。令心专注同境者：谓专同一所缘性。若心平等运至者，则能如实善了知故，即是能为智依为业。“慧”者：谓般若。即唯於所观察事体极善简择为性。谓由正理所引、非正理所引以及其他。由能简择故、名为极善简择。谓於诸自能相、共能相、似相杂合一切法中、能如实或颠倒思择。如理者：即是如实。此复有三：谓至教、比量、及现量。由此三种正理所引、是名正理所引。此复三种：一者、闻所生。二者、思所生。三者、修所生。此中以至教为能量而解了者、名闻所生。由思量正理审决所生者、名思所生。依三摩地所生者、名修所生。非正理者：谓非至教、似比量、及邪思惟三摩地。由此非正理所生者、名非正理所引。由生得智、及世间语言智者、既非由正理所引，亦非由非正理所引。此具有以断疑为业。断疑者：谓由慧极善简择诸法得决定故。如是五法者、更互成为别异而起。若如是者，则於是处胜解、即於此处、馀定不生。当说一切亦复如是。已说别境。
    於别境後、次当说善，是故颂曰：
    “善：谓信、惭、愧、　无贪等三根、
     勤、安、不放逸、　　行捨、及不害。”
    论曰：言“如是十一法”者、是此中省文补足语。此中“信”者：谓於业果、诸谛、及稀有珍宝之为实有、具德、有能、深忍可、心澄净、希欲、为性。此信当成为三行相：一者、谓於实有事体具德、或非具德、深信行相。二者、谓於实有事体具德、心澄净行相。三者、谓於实有事体具德、希欲有功能能得能生起之行相。言“心澄净”中、澄净者：谓由与心浑浊不相随顺故。若与此相应者，则烦恼、及随烦恼、秽垢无有故，依此心澄净当成为澄净故，名为澄净。此具有能作乐欲所依为业。“惭”者：谓依自或法之增上力於所作罪羞恥为性。是诸正士所诃责故，能得非爱异熟果故，於诸恶业说以“罪”名。於已作罪、或未作罪、心怯羞恥，是名为惭。此以具有能作止息恶行所依为业。“愧”者：谓依世间增上力、於所作罪羞恥为性。谓此为世间所诃责。若了知自造如是业、亦当为所诃责，由怖畏如是讥毁等故、於罪羞恥。此亦具有能作止息恶行所依为业。“无贪”者：谓贪对治。言“贪”者：谓於诸有、及有具、染著希愿为性。能对治彼者、名为“无贪”。即於诸後有後有之资具无染著、及不趣向。此具有能作不起恶行所依为业。“无瞋”者：谓瞋对治。言“瞋”者：谓於诸有情、及於诸苦与苦所依法、憎恚为性。由此无瞋能对治瞋故，即於诸有情及於诸苦与苦所依法、无有憎恚。此亦具有能作不起恶行所依为业。“无癡”者：谓癡对治。以如其实如是正了知为性。言“癡”者：谓於业果、诸谛、稀有珍宝、无知为性。由此无癡能对治癡故，即於业果、诸谛、稀有珍宝、如实了知为性。此亦具有能作不起恶行所依为业。“精进”者：谓懈怠对治。谓於诸善品勇悍为性，而非於染污品类。由於染污品类勇悍者、即是懈怠故，体即懈怠。此具有能圆满及能成就善品为业。“轻安”者：谓麤重对治、身与心堪任、调畅、为性。言麤重者：谓诸身与心无堪任性、及一切杂染品法种子。此若无者，有轻安故。此中身堪任者：谓随自身应作、轻而易举所生。心堪任者：谓以於如实作意已转起清新爽逸之心为因、成为其馀心所有法。由若与此相应者，则於所缘心无 罣碍转；故名为心堪任。由身殊胜所触喜悦所摄持时、当知名为身轻安。由经说言“若意喜悦，则身当轻安”。由此依彼增上力能转所依故，此具有能无馀除遣烦恼障为业。言“不放逸俱”者：(按汉译“俱”字无，而直说“行捨”。)谓由与不放逸相俱故，说“不放逸俱”。此所“俱”又为何？谓是“行捨”。此何以故耶？由一律是善性故。此中适说一切善数故，非如信等、不现前说故，除此更无别善数故，即知此所俱者、乃说“行捨”。此中“不放逸”者：谓放逸对治。即无贪乃至精进、名不放逸。若依无贪等能断离诸不善法、并亦能修习彼之能对治诸善法，即此诸无贪等、名为不放逸。因此即是放逸之能对治性。由放逸者与此相违故。此具有能圆满一切世出世间福德为业。“行捨”者：谓心平等性、心正直性、及心任运性。由此三句显示行捨初、中、後位。此中惛沉及掉举者、说名心不平等。由无此故，说为最初心平等性。从是以後无有造作、不须励力，随其所应由等至心平等引转，说名心正直性。於此位中、由修未久故，时有忧虞惛沉掉举生起。此後由修习胜进故，彼所对治分已远隔故，无复忧虞。於诸一切能对治惛沉掉举因、无须奋勉任运而住故，说名心无功用住性。此具有能作不容烦恼及随烦恼生起所依为业。“不害”者：谓害对治。不由杀缚等损恼有情故，名为不害。即於有情悲愍为性。由免除福德受损故，名为悲愍。言福德者：谓即安乐。此即保持安乐之义。由有悲愍者於他苦时、亦苦随转故。此具有不损恼为业。已说十一善。
    次後由显示烦恼、是故依彼等为增上，颂曰：
    “烦恼：谓贪、瞋、　癡、慢、疑、恶见。”
    论曰：贪著及瞋恚及愚癡者、颂说“贪、瞋、癡”。此中“贪著”者：谓於能有、及受用、耽著希愿为性。此具有能遍生起诸苦为业。苦者：此中即说五取蕴。由五取蕴乃依欲爱、色爱、及无色爱增上力、所引生故。是故今说贪著能遍生起众苦为业。“瞋恚”者：谓於诸有情损恼为性。即於诸有情心粗暴性。若由此所伏蔽，则於诸有情思作杀缚等损害事业。此具有能作不住於触、及恶行所依、为业。触者：谓安乐。与彼俱住、名住於触。不安於触、名为不住於触。即与苦俱之义。若有损恼心，则遍生起忧故、即心中焦恼。由随顺心转变故，身亦焦恼。谓於彼一切威仪中、当具有诸苦及具有匮乏而住。由具有背逆心者、与诸恶行邻近住故，今说瞋恚具有能作不住於触、及恶行所依、为业。“愚癡”者：谓於恶趣与善趣、涅槃、与能得彼因、以及彼等诸因与果无倒相连属无知为性。此具有能作杂染生起所依为业。此中杂染有三行相：一者、烦恼为体。二者、业为体。三者、生为体。彼生起者：谓前前杂染为因、能得後後杂染自体。能作生起所依者：谓若愚癡者，则依邪智、疑惑、及贪著等烦恼、後有之业及诸生等生起、而非由不愚。“慢”者：谓一切所说我慢、均依萨迦耶见生起。此以令心高举为能相。即於诸蕴增益为我及我所之事体、谓“此是我，此是我所”。如是由彼彼差别令自高举、凌慢於他。此具有能作不敬及苦生所依为业。不敬者：谓轻蔑诸师长、及诸有德补特伽罗，具无身语礼敬。苦生者：此中即谓後有生起。此於高举心自性、虽无差别、然由高举心生因差异、故分七行相：即所说慢、过慢等。若方於他种姓、多闻、财宝等劣者，谓己种姓、多闻、财宝等为胜、令心高举，或方於他种性等相同者，谓己为等、令心高举、是名为慢。过慢者：谓方於他种姓、多闻、财宝等相同者，谓己施捨、尸罗、及技艺等为胜；或方於他种姓、财宝、明智等、为胜者，谓己多闻、财宝等相同；是名过慢。若方於他种姓、多闻、及财宝等胜者，亦谓己种姓、多闻、及财宝等、为胜、令心高举；是名慢过慢。我慢者：谓於本无我及我所五取蕴中、执著我我所故，令心高举。是名为我慢。增上慢者：谓於未得增上殊胜所证法中计己已得、令心高举，是名为增上慢。卑慢者：谓方於他种姓、明智等、多胜，谓己种姓、明智等、少劣、令心高举；是名为卑慢。邪慢者：即具有非德、谓己具有功德，令心高举；是名为邪慢。非德者：谓恶戒律等。若诸有此非德等者，彼即名为具有非德。因此由彼计己具有功德故、虽无布施、戒律等，然亦自许具有彼功德。是故由无事体故，说名为邪慢。“疑”者：谓於业果、诸谛、稀有珍宝中、心犹豫为性。谓疑为有、抑为无、起种种异慧，名为犹豫。此离慧外、别有自性。言“恶见”者：虽是通称，然由属於烦恼故、唯是五种烦恼体性。即唯指萨迦耶见等见，而非世间如实见、及无漏见。此恶见等、虽於染污为性及寻求推度之道理中无有差别，但由所缘及行相之差别故，更互差异。此中萨迦耶见者：谓於诸五取蕴中、即观见我及我所为性。边执见者：谓於五取蕴中先执为我及我所、复即观见彼为断为常。邪见者：谓由此见或损减因，或损减果，或损减能作，或败坏实有事体。此於一切见中、为邪恶故，说名邪见。见取(见取为胜)者：谓即於此一切五取蕴观见为最上、为殊胜、为最要、为第一。戒禁取(戒律及禁忌取为胜)者：谓即於诸五取蕴观见为清净、解脱、及已出离。已说六烦恼。

    卷第二

    次後为解说所标诸随烦恼故、颂曰：
    “随烦恼：谓忿、　　　恨、覆、恼、嫉、悭、
     诳、谄、与害、憍、　无惭、及无愧、
     掉举、与惛沉、　　　不信、並懈怠、
     放逸、及失念、　　　散乱、不正知。
     不定：谓悔、眠、　　寻、伺，二各二。”
    论曰：此中“忿”者：谓依现前能妨害事、令心憎恚为性。由此亦以憎恚为性故、虽非与瞋差异，然此依瞋分位差别假立故、即是属於瞋一分。谓依现前妨害事、於有情非有情境界心遍憎恚。此具有能作强加处治等所依为业。即是假安立为忿。“恨”者：谓结怨为性。即於忿後、念彼於我曾作此害。如是结怨体性、蕴积不捨相续生起，是名为恨。此具有不能忍耐所依为业。不能忍耐者：即是永不忘怀能妨害事、欲作报复之义。此亦如忿、乃依瞋恚分位差别假安立故，当知即是假有。“覆”者：谓於自所作罪、隐藏为性。若除遣乐欲、瞋恚、怖畏等，唯为饶益彼而进言故、若及时显示言“汝现为此”，则由属癡一分、隐避自罪，是名为覆。覆者：即属愚癡一分。以隐避为行相故。此具有能作追悔、及不住於触所依为业。此即法尔彼若隐避自罪时，必起追悔故。若起追悔，则决定与忧相应；故不住於触。“恼”者：谓发粗恶言、陵犯为性。粗恶言者：谓以能刺恼为快，故名陵犯 。此之事体即陵犯性。如同受到粗恶言所刺恼故，为陵犯性。此以忿和恨为先行以憎恚心为自性故，亦即属瞋恚一分、非是实有。此具有能生起言语恶行为业、及不住於触为业。以与具有此等之补特伽罗难为友故。“嫉”者：谓於他荣盛、心忌不平为性。谓由耽羡获得、恭敬故，见他利养、恭敬、种姓、尸罗、多闻等功德差别己、由属於瞋恚一分不能忍耐心忌不平，是名为嫉。由於自所依遍骚动不平故，名为妒忌。由与忧相应故、及以此为先故、不住於触，即说此具有能生起忧及不住於触为业。“悭”者：谓与布施相违、心遍悭持为性。由於任何恩与怨均欲以此供养及饶益故，谓即以诸所摄受事体法和财宝、以及智者本身、能作施与，是为布施。若据有此者，施而无有布故、即与此相违。由耽著利养、恭敬故，贪著之一分、於资生众具令心悭持悋惜、唯不欲捨；是名为悭。此具有能於诸资生众具无有厭足所依为业。於诸资生众具无厭足者、当知由此悭故，於诸非所需用亦遍蓄积。“诳”者：谓为欺他、即诈现不实之义为性。谓由耽著利养恭敬故、由欲欺他意乐故、虽住於别异尸罗等义中，然而诈现为馀。此乃由贪著愚癡和合、诈现不实功德故，即合此二假立名诳。亦如忿等、是假安立性，非是实有。此具有能作邪命所依为业。“谄”者：谓掩盖自过方便所摄、心弯曲为性。掩盖自过方便者：谓能使他心愚蒙无知，又此能使头绪紊乱、假 讬於馀、真假不辨。是故谄覆二者差异：彼则径覆不露、非由方便。此由耽著利养、恭敬故，由贪著愚癡二、为覆自过能使他心愚蒙故。即合此二假安立名为谄。此具有能障碍如实教授为业。如实教授者：谓若得此，能如理作意。然彼能为此障。“害”者：谓於诸有情损恼为性。即以刺、杀、捆、缚、捶、打、威吓等种种手段损恼有情。由此以损害心、以刺杀捆缚等损恼诸有情、能令生起苦和忧故，名为损恼有情。此属於瞋恚一分。谓於诸有情无有悲愍、心怀粗暴、而能损恼有情为业者、是名为害。“憍”者：谓於自荣盛深生染著、醉傲心恃为性。谓种姓、无病、年少、力壮、色丽、自在、明敏、聪叡等、成为优胜，名自荣盛。醉傲者：谓殊胜喜悦，即由此殊胜喜悦令心无自在转故，此等依彼增上、当为所持。是故说名心恃。此具有能作一切烦恼及随烦恼所依为业。“无惭”者：谓不由所作罪、於自羞恥为性。即虽当正知彼业应非己分，然不以此所作罪而随自羞恥、是名无惭。即是惭所对治分。“无愧”者：谓不以所作罪於他羞恥为性。即虽如是了知今已若作、与世间及论典适相违反，然犹不以造此罪恶而随他羞恥、是名无愧。即是愧所对治分。此二具有能作一切烦恼及随烦恼助伴为业。谓於以贪著瞋恚愚癡为其行相一切恶行、随其所应假立为其生起之因。由贪著瞋恚二不俱起故，此二、无自相续。“掉举”者：谓心不寂静为性。寂静者：即是止。与此相违者、为不寂静。此即随顺贪著追忆往昔嬉笑、欢谑、戏纵等故，以此为因、心不寂静。谓具有能障奢摩他为业。“惛沉”者：谓心无堪能、蒙昧为性。即蒙昧之事体、说名蒙昧为性。若与此相应者，则令心愚钝、成蒙昧性；无有力能了达所缘。此具有能作一切烦恼及随烦恼助伴为业。由於愚癡一分假安立故，即属於愚癡一分、无别有法。“不信”者：谓於业果、诸谛及稀有珍宝、均不致信，即是信所对治。信者：则於诸实有、具德、及功能、深忍、净信及希欲为性。如其次第不信与此相反。於诸实有、具德、功能，无深忍、无净信、无希欲。具有能作懈怠所依为业。由此不信者於诸加行无有乐欲故，说具有能作懈怠所依为业。“懈怠”者：谓於善等不勇悍为性。即是精进所对治分。由愚癡一分、依於睡眠、倚、卧诸乐，於身语意善业、心不勇悍。此具有能障善品加行为业。“放逸”者：谓由贪著、瞋恚、愚癡、及懈怠等故，於贪著、瞋恚、愚癡等、心不防护，及不修习能对治彼所有善法为性。即於贪著、瞋恚、愚癡、及懈怠、假安立放逸。此具有能作增恶、损善所依、为业。“失念”者：谓染污念为性。言染污者：谓与烦恼相应。此具有能作散乱所依为业。“散乱”者：谓属於贪著、瞋恚、愚癡一分，心流荡为性。由此能令心种种散乱故，名为散乱。谓由贪著、瞋恚、愚癡、令心远离三摩地所缘，向外流散。即於此三、随其所应假安立为散乱。此具有能障远离贪著为业。“不正知”者：谓与烦恼相应慧为性。即由此慧於往还等中、不能正知身语心行而转。由不知当作及不当作故。具有能作毁犯所依为业。“恶作”者：谓心变悔为性。由作斥责故、心生追悔。此之事体、说名恶作。此以恶已作为境、心不喜悦。由是说心所分际故、说名恶作。此具有能障心安住为业。“睡眠”者：谓转起无自在、心极昧略为性。转起者：谓於所缘境转起。又依此生起心无自在，即为睡眠。复次即依此生起不能执持身、心无自在，是为睡眠。心极昧略者：谓不以眼等根为门而转起故。由此依愚癡一分假安立故，即是假说愚癡一分。此具有能徒失当作事业所依为业。“寻”者：谓寻求之意言、思慧差别、为性。寻求者：即分别谓“此为何”如是行相转起。意言者：谓意中言说。即与言说相同。言说者：谓能诠显於义。言思慧差别中、思者：谓能令心动作为性。慧者：谓能辨别功德、过失、为行相。或时由依彼增上力令心转起故，依此心及思假立为寻。或时依慧及心假立。如次即是不推度位、及推度位。复次、唯依思及慧二假立为寻。以由依彼增上力令心如是转起故。此寻、即是心麤。言麤者：即是粗略。由唯寻求事体为行相故。此道理、於伺当知亦尔。“伺”者：亦以思慧差别为性。即此伺察之意言、於先前已明了事体中、伺察谓“此原即是此”故。是故说为心细。此二俱具有能作安住於触及不安住於触所依为业。此二由安立行相为麤及细故、而有差别。言“二各二”(或二种二)者：谓二二种中各有二。如是彼等即恶作、及睡眠、二种，与寻、伺、二种。此二二种四法、又分为二：一者、染污。二者、非染污。此中由未作不善、已作诸善故，如是不善追悔心、是名染污恶作。若由未作诸善、已作不善故，心生恶作。是为非染污。若睡眠由染污心所感引，或与染污心相应，即是染污。若由非染污心所感引，或与非染污心相应，即是非染污。贪爱、恚恨、及害等寻求、是染污性。出离等寻求、是非染污性。如是伺察损害他人方便，是染污性。伺察饶益他人方便，是非染污性。此中若诸染污恶作、睡眠、寻、伺，即唯烦恼。非另外有。此中如缘色声等六种识、随其所应与遍行、别境、善、烦恼、随烦恼、一切心所有法相应；如是於乐、苦、非苦非乐、三种受中、亦与三受相应。谓由喜忧捨所依色等、此生起故。又与善、不善、无记、一切相应。阿赖耶识唯与五遍行相应、非馀。此中唯是捨受相应。唯是无覆无记性。染污意与五遍行、及我癡等四烦恼、恒时相应。此中亦唯捨受相应。唯是有覆无记性。
    於此当作是思：如何眼等五识虽同时与所缘缘遇合，即从阿赖耶识唯一生起、而非二、非多耶？抑或如有作是思“非二、或多俱起。由无等无间缘故，唯一识生起。谓由一识、无有力能可作多识等无间缘？”抑或当说“实无有定：若一得缘遇合，则一生起？如是若二若多、得缘遇合，则二或多生起”耶？是故颂曰：
    “依止根本识、　　五识随缘现
     或俱，或不俱，　如涛波依水。”
    论曰：言“五识”者：谓眼等诸识。彼随行者、谓诸五俱意识。阿赖耶识、由是五识种子依故，由依此生起及执受五趣诸生体故，说名“根本识”。言“随缘”者：谓遇彼彼众缘现前、即有此此决定出现。“现”者：即获得自体。言“或俱或不俱”者：谓俱时、或次第义。言“如涛波依水”者：即喻依阿赖耶识诸转识，或俱时生起、或次第生起。如经说云：“广慧！譬如大暴水流，若有一浪生缘现前，唯一浪转。若二、若三、若多浪生缘现前，有多浪转。然此暴水流自类恒流无断无尽。(中略镜影喻)如是广慧由似暴流阿赖耶识(汉文两种译本均作“阿陀那识”。而此论梵藏文本均作“阿赖耶识”。)为依止、为建立故、若於尔时有一眼识生缘现前，即於此时一眼识转。若於尔时若二、若三、(汉文两种译本、此处无“若二若三”)乃至有五识身生缘现前，即於此时有二、或三、乃至五识身转。(“有二或三”句、同上汉文两种译本均无。)”又此经中复说颂云：“阿陀那识甚深细，一切种子如暴流。我於凡愚不开演，恐彼分别执为我。”
    如识所缘缘、各各定异，如是等无间缘、则不许尔。以一切识生起可许为一切识等无间缘故。(《成唯识论》卷四云：“是故八识各唯自类为开导依，深契教理。”不取安慧说。)若遇所缘缘现前时，则由此一等无间缘、或二或多识生起、不相违反。若无各各定异等无间缘，则汝说五识同遇所缘缘时，唯一识生起、不许五俱者，有何成立因由耶？是故应许若有所缘时，或五识俱起、或不生起。
    如是今当说意识为与彼诸眼识等俱时生起耶？抑为虽无彼等，亦自生起耶？是故颂曰：
    “意识常现起、　除生无想天、
     及无心二定、　睡眠、与闷绝。”
    论曰：言“常”者：谓一切时分。即是与眼识等相俱时、及非与彼相俱时之义。於一般中约此之特别除遣故说“除生无想天、及无心二定、睡眠、与闷绝”。此中“无想天”者：谓生於无想诸天有情中、诸心心所法灭为体。言“无心二定”者：谓无想定、及灭尽定。此中无想定者：谓由已远离第三静虑贪、未远离以上贪著故，由出离之想为先所有作意故，诸意识及彼相应之心所灭为性。如是即是此中所谓无想定。由此成为灭故、即名为灭。又此即是意识连同彼相应心所之不生起，名灭。谓所依之分位差别。又复此等引定由其心以後、能获得与馀心生起相违反之所依，故名为等引。灭尽定者：谓已远离无所有处贪著，由以止息想为先之作意、意识及染污意连同其相应心所俱灭、为性。此亦如无想等引於所依分位差别假安立。“无心睡眠”者：谓由所依身、由沉重睡眠所制，随所有时一律意识不生起故，说名无心。“无心闷绝”者：谓由所依不平衡故，即由猛击，及风、热、痰不平衡故，与意识生起相违反；依此假安立为无心闷绝。当知除此五位、馀一切时意识现起。如是无想等位、此识灭无。若由此灭、既成为无，此後复生起者；则何故不能作为彼等命终位耶？谓此识即唯从阿赖耶识生起。又由阿赖耶识具有一切识种子故。如是依此识变现假安立我与法中所标三种能变、今已广解为三行相讫。
    此假说我与法、即是诸识转变，离能转变识以外、无别我与法；为成如是所成立宗故、颂曰：
    “是诸识转变　　分别、所分别。
     由此、彼皆无，　故一切唯识。”
    论曰：无间所解说三行相识能变者、即是“分别”。谓以增益之义为其行相三界所有心心所有法、说名“分别”。如《辨中边论》云：“三界心心所、是虚妄分别。”由此阿赖耶识、染污意、转识自体连同彼相应三行相“所分别”，如此等器、我、蕴、界、处、色、声等诸事体、皆无所有故。即此识能变、说名“分别”。以无所缘故。云何得知无有所缘耶？谓若由此之因、及彼和会并亦无有违反者，则此当生起、非馀。“识”者：谓幻化、乾闼婆城、梦境、及眩翳等无有所缘时亦即生起。若识生起、唯依所缘处者，则於幻化等处本无义故、识应不起！是故依彼前灭同一类识、此识生起。以彼虽无，此亦生故、非依外境。若依一义非异，而亦见有诸能分别识、更互相违智体生起。然一者与多体更互相违，不应道理。由是当知以增益为自性故，非有分别所缘境界。由此且破增益边已。欲破损减边故，说言“故一切唯识”。言“故”者：是因此义。谓如是能变体性、唯是分别，都无所分别。由如是故，无有外境、一切唯为了别识(Rnam par riq pa.Vijñapti)。言“一切”者：谓三界、及无为。“唯”声者：即简别除此所馀外境义。(此处为补足颂句音节数、梵本加Ka，藏译加Pa)若一切法但唯是了别识、离此更别无有能作及能作者，则根本识无能摄益、即无能作、应思诸分别云何生起？是故颂曰：
    “由一切种识　　如是如是变，
     以展转力故、　彼彼分别生。”
    论曰：此中由具有生起一切法功能故，名一切种。“识”(Rnam par śes pa·Vijñāna)者：谓阿赖耶识。由或有是识、而非一切种，故说“一切种”言。或有於非是识亦计为一切种，故复说“识”言。复由一语句有失误故，乃显示差别、及差别之所依、此中即无过失。言“如是如是变以展转力故”中、“变”者：即由阿赖耶以前分位变异。言“如是如是”者：即是於彼彼分别以後、获得功能能生起所有分位之义。言“以展转力”者：谓由眼等识长养自果功能故，於转起时、当成为阿赖耶识具有功能差别转变之因。此转变阿赖耶识、亦即成为眼等识之因。如是说名“以展转(增上)力”。若由是故、二俱生起，即由此故、阿赖耶识不待馀缘摄益、彼彼众多行相分别生起。此者即是显示於现在世阿赖耶识如何生起转识。
    若唯了别识者，则今为显示现在世灭已、於未来世如何结生相续；故颂曰：
    “由诸业习气、　二取习气俱，
     前异熟既尽、　复生馀异熟。”
    论曰：“业”者：谓福、非福、及不动思。於阿赖耶识中、能生起功能，是名“业习气”。即由此业能感引未来所依身。“二取”者：谓即所取取、及能取取。此中增上染著实有离识以外、别自实有故、安立之所取者、为所取取。又若诸决定由识能取、谓能了知能识别者，即此为能取取。若诸种子由以前生起之能取取及所取取所熏成，当得生起未来彼同种类之所取取及能取取；是名“二取习气”。此中由业习气差别故，由不同诸趣故，能得生身各异。喻如种子差异、生芽各各别异。“二取习气”者：谓如由其一切业习气自所感引能生所依身时、如是诸能参预，名为能俱起性因。喻如由种生芽时、诸水分等。若如是者，则当显示谓非唯业习气、而且亦由二取习气所摄持故，能生起异熟。是故颂说言“二取习气俱”。言“前异熟既尽复生馀异熟”者：谓由前世中所积集业、於此感引异熟；齐至所引终限所谓尽时、复如其业习气力、如是由彼所具有二取习气故，即从此已受用尽异熟能生起馀新异熟即此阿赖耶识。以离阿赖耶识、无别异熟故。由所说“前异熟既尽”言、遮彼常边。由所说“复生馀异熟”言、遮彼断边。除眼识等外、别有阿赖耶识，即此为一切种。云何应说非是眼识等耶？谓由教及理、故知为有：如佛陀世尊《大乘阿毗达磨经》云：“无始时来界，一切法等依。由此、有诸趣、及涅槃证得。”若无阿赖耶识者，则生死流转、及以还灭、俱不应理。此中“生死流转”者：谓於诸馀众同分中、能结生相续。“还灭”者：谓有馀依、及无馀依涅槃界。此中离彼阿赖耶识，行为缘识、不应道理。若无行为缘识，流转亦无。若不许有阿赖耶识者，则为此结生相续识、作行为缘而生耶？抑为由此等诸行所遍熏六识身、作行为缘而生耶？此中且彼诸行、不许作结生相续识之缘。由彼灭去已久远故。由灭即是无故。无则不能作缘，是故彼行能作结生相续识之缘、不应道理。又结生相续时、亦有名色。若非唯有识者，此中有何道理说行识为之缘而非名色为之缘耶？由如是故、亦应说行为名色缘、非唯为识缘，则何者说为“识缘名色”耶？若说後时为彼之缘者，则此与结生相续时名色自性成为差别，如是即此名色以识为缘而生、而非前时。前时名色以行为缘而生、而非後时。是故以行为缘名色生起，更遍计结生相续识为别支、当何所为？由如是故，结生相续识以行为缘而生、不应道理。又诸行所熏习六识身是以行为缘之识、亦不应理。何以故耶？谓识於己不能生起异熟习气、及等流习气。由己於己能作成相违故。又非无间後生。由於尔时彼尚未生故。未生、即为无故。又非已生。彼於尔时已先灭故。又无心灭尽定等位、依诸行所熏之心所有法不得故、识缘名色亦当无有。由此无故、六处亦当为无。如是乃至生缘老死、亦当非有。是故生死流转不成。由如是故、无明为缘诸行生。由此所熏阿赖耶识、即行缘识。由识为缘、於结生相续时有名色生。於此缘起道理中无过。复次、若无阿赖耶识，生死、还灭、亦不应理。生死因者：谓业、及烦恼。於此二中、烦恼为主要。如是即依烦恼增上力故，业能感生後有、而非其他。如是所感诸有、又由业及烦恼增上力故，当再感生後有、即非其馀。若如是者，则烦恼由是主要故、即唯是生死流转根本。由断彼故，生死亦随还灭、而非其他。若无阿赖耶识，断离彼等、不应道理。云何非理？为於烦恼现行时断离耶？抑为於种子位断离耶？此中若谓烦恼现行时断离者，此唯不许。由现住断离彼之道故。种子位断离、亦不应理。若处为烦恼种子安住，即於彼诸处由能对治能断离者、则尔时除能对治外、都不许有任何其他故。若许即此能对治心、具有烦恼种子者，既由彼具有烦恼种子而又能成彼对治、不应道理。诸未断离烦恼种子之生死者、则不得还灭。由如是故、决定无疑由此相异诸识俱生烦恼及随烦恼、於阿赖耶识中当长养各自种子故，即应许为熏发习气。若诸习气随其种力获得转起者，则即此心体获得因性差别故、即能生起彼烦恼及随烦恼诸种子摄藏在阿赖耶识中；由与彼俱时生起之能对治烦恼道、即能除遣。由如是故，於此所依中、以一切烦恼不复生起故，即是证得有馀依涅槃界。先业所感引寿命尔时既已灭讫、而与他世不复结生相续故、即是证得无馀依涅槃界。虽尚有业，然诸烦恼已尽断离。由无俱有因故、无有力能引生後有。如是若有阿赖耶识，得有生死流转、及以还灭、而非其馀可尔。由离眼等识外、决定当有阿赖耶识故。即此具有一切法种子、决定当许非眼等识。馀广分别、当知如《大乘五蕴论广释》中说。
    若一切唯有了别识者，云何不违契经耶？如《解深密经》、《楞伽经》、《密严经》等说有三自性：一者、遍计所执自性。二者、依他起自性。三者、圆成实自性。应知即於唯了别识、安立三性无违。云何尔耶？是故颂曰：
    “由彼彼遍计、　遍计种种物。
     此遍计所执、　自性无所有。”
    论曰：为依所遍计内外诸事体种种差别、显示无数分别故，颂说“由彼彼遍计”言。言“遍计种种物”者：谓内外诸事体最後乃至佛陀法。由如是故，唯此事体为遍计所执自性。此中说其成立因者：谓“无所有”。如所遍计之境界事体、如是即此自性无所有故，说“无所有”。由如是故，此事体唯是遍计所执自性、非以依诸因与缘为其自性。所以者何？於同一事体或无有事体中、观见有更互不同众多分别转起。便谓同一事体或无有事体成为众多更互不同自性，不应理故。由如是故，此诸一切唯是分别性。以彼诸义是遍计所执自性故。如契经说云：“善现！如诸异生愚夫执著、如是诸法非有。”
    於遍计所执後、当说依他起自性，是故颂曰：
    “依他起自性、　分别缘所生。”
    论曰：言“分别”者：此中即是显示依他起自性。言“缘所生”者：即显示所说依他起之生起因。此中“分别”者：谓善、不善、无记、种种差别三界一切心心所法。如《辨中边论》云：“三界心心所、是虚妄分别。”由其他因与缘增上力故、名为“依他”。即使能生起之义、应说依 讬除自以外所馀因缘而当生起。
    已说他依起性，云何圆成实性耶？是故颂曰：
    “圆成实於彼、　常远离前性。”
    论曰：由不变异故、为“圆成实”。言“於彼”者：谓於依他起性。言“前性”者：谓遍计所执性。即於此分别中、遍计执为所取及能取之事体。所以者何？谓如其本无所取与能取、而唯由遍计横自执著故，说名遍计所执。即此依他起性上恒常於一切时毕竟远离彼所取与能取，是名圆成实性。颂曰：
    “故此与依他　　非异、非不异。”
    论曰：言“故此”者：谓即此依他起性、毕竟与遍计所执自性远离，为圆成实。此远离性、即是法性。法性与法若异、若不异，俱不应理。以圆成实是依他起之法性故。是故应知依他起与圆成实非异、非不异。若圆成实与依他起异者，若尔，则依他起不当由遍计所执故空。若不异者，若尔，则圆成实应不成为清净所缘。如是由依他起乃以杂染为体性故，如是依他起性当不成为以杂染为体性。由与圆成实不异故。如同圆成实性。颂曰：
    “如无常等性。”
    论曰：此中所谓“非异非不异”者、应是补足语。喻如无常性、苦性、及无我性、与无常等行、非异，亦非不异。若诸行与无常性异者，若尔，诸行当不成为无常。若不异者，诸行灭已、当即成无。如无常性，苦等、亦当如是准说。
    若於依他起性中、无有所取及能取者，云何能取彼耶？若不能取，云何知是有耶？是故颂曰：
    “非不见此、彼。”
    论曰：言“不见此”者：谓圆成实性自性。言“非见彼”者：谓依他起自性。於此圆成实性未观见者、即是未通达或未现证。以由无分别出世间智当能观见故。於依他起性、非馀智能取。由是後得清净世间与出世间智所行境界故。是故不见圆成实、则不见依他起。以非不由出世间智後所得智观见故。如《入无分别总持经》说“由後得智观一切法同於幻事、阳 焰、梦境、影像、光影、谷响、水月、变化法。”法者：此中即许说一切依他起性所摄。圆成实者、犹如虚空，谓智同一味。如云：“由无分别智观一切法同於虚空轮。”由观一切依他起法、唯是真如性故。
    问：若依他起为有实质者，云何经说一切法无有自性、无生、无灭耶？
    答：不违经言。如是颂曰：
    “即依此三性、　立彼三无性。
     故佛密意说　　一切法无性。”
    论曰：为显唯有三性、无有第四故，即标其数。谓由如其各自能相、实成为如是有，故名“自性”。三行相无自性者：谓能相无自性、生起无自性、及胜义无自性。“一切法”者：谓以遍计所执、依他起、及圆成实、为其体性。今者为显依何三自性其自性即为无有、颂曰：
    “初、即(能)相无性。　次、无自然性。
     後、由远离前　　　　　所执我法性。
     此诸法胜义、　　　　　亦即是真如。”
    论曰：言“初”者：谓遍计所执自性。此即能相无自性。彼者由能相是所执故。如说色之能相者、是有变坏，受之能相者、是领纳等。此等由无自性故，如空中华、无有自体。言“次”者：谓依他起自性。此即犹如幻化。由依他众缘而生起故，无有自身事体。如是如所显现、此中亦曾无如是生起，是故说为生起无自性。言“此诸法胜义亦即是真如”中、“胜”者：即是出世间智。由无上故。此所有义、即名胜义。复次即犹如虚空周遍一切、一味、无秽垢、无变异法、圆成实性，说名胜义。所以者何？谓圆成实自性、是依他起之性体，一切法之胜义。由是彼之法性故。即此圆成实自性、名胜义无自性。由圆成实以无事体为自性故。
    问：唯说胜义为此圆成实性名耶？答：不尔，亦即是真如。“亦”声者：谓非唯说真如声，亦当如所说一切法界等异名。颂曰：
    “常如其性故。”
    论曰：此真如者：谓於异生、有学、及无学位中、遍一切时常如其实无变易故，名为“真如”。
    应思此唯识性(即指唯是了别识性)、亦如真如即是圆成实性耶？为别有唯了别识性耶？是故颂曰：
    “即唯识实性。”
    论曰：所以者何？由能通达最极清净相故。即说颂云：
    “尔时观唯此，　故心住於名。
    由住於名故、　了别断所缘。
    仗此修习因、　触证无得界。
    遍解脱诸障，　获得胜自在。”
    由此“即唯(了别)识实性”句、即显示现观。
    若彼一切唯是了别识者，应思何由生起如是思惟谓眼、耳、鼻、舌、身、取於色、声、香、味、触耶？是故颂曰：
    “乃至未起(分辨)识　　求住唯(了别)识性、
     於二取随眠　　　　　　犹未能伏灭。”
    论曰：又如前颂有云：“由诸业习气、　二取习气俱，　前异熟既尽、　复生馀异熟。”当说二取云何断、及未断、故今广说言“乃至未起(分辨)识(应作“识乃至未起”。)求住唯(了别)识性”。谓此分辨识乃至不住於心之法性、即所说“唯(了别)识性”中，即是分辨识但行於所取与能取所缘。“二取”者：谓所取取、及能取取。彼之“随眠”者：谓未来二取取生起故、即於彼等之阿赖耶识中所熏植之种子。乃至修观行者(即瑜伽行师)於无二之能相唯了别识性、尚未起心求住，即如许时、未能违反二取取随眠。即是未能断离之义。此中显示若未能断离外所缘者，则内所缘亦未能断离。是故今说彼作是思谓“我由眼等能取色等”。
    今者如是当说由诸义远离、唯心可得故，抑即住於心之法性耶？答：不尔。是故颂曰：
    “现前立少物、　谓是唯(了别)识性，
     以有所得故、　非实住唯(了别)识。”
    论曰：复次、为除遣具有增上慢者唯由听闻便计执谓我已安住清净唯了别识性故，今说“现前立少物谓是唯(了别)识性”等。言“谓是唯(了别)识性”者：谓远离於义，谓无有外义。“有所得”者：即是能作为能取与能作为所相之义。言“现前”者：谓当下呈现。言“立”者：谓如所听闻、如是意能安立。由瑜伽行师之所缘行相众多故，今说任取少物谓如骨锁、青瘀、烂坏、虫侵、肿胀等。言“非实住唯(了别)识”者：谓尚未断离识之所缘故。
    何时断识能取、得善住心之法性耶？是故颂曰：
    “若时於所缘、　智都无所得，
     尔时住唯识、　离二取相故。”
    论曰：谓若时无论缘虑教法、缘虑教授、最後乃至缘虑色声等，由智都不缘虑离心以外者、即无观见、无能取、且无有执著、而如其实而如是观见於义、非如生盲者。尔时即识之能取亦断离、而安住於自心之法性。即於此中出其成立因、说言“离二取(能)相故”。若有所取，亦有能取。若无所取，则亦非有能取，若无所取，则亦当知无有能取、而非只是无有所取。若如是者，由於所缘虑及能缘虑无分别故、平等出世间智生起。即能断离所取能取执著之随眠，心亦当安住於自心之法性。
    若心如是已安住於唯了别识性、尔时当何所说？故颂曰：
    “无得、不思议、　是出世间智。
     捨二麤重故、　　便证得转依。
     此即无漏界，　　不思议、善、常、
     安乐，解脱身　　大牟尼名法。”
    论曰：由此二颂显示依止修观行者之证见道、已悟入唯了别识性、节节升进差别故，得果法圆满。此中由既无能取之心、并且所取之义亦不可得故，说言“无得、不思议”。由不染习世间、亦不集起世间、无有分别、及翻越世间故，说言“是出世间智”。於此智後显示转依故，说言“便证得转依”。“依”者：此中即是一切种子阿赖耶识。“转依”者：谓若转捨麤重异熟、及二障习气事体者，则转得堪任、法身、及无二智之事体故。此转依法、复由断何而得耶？是故说言“捨二麤重故”。言“二”者：谓烦恼障麤重、及所知障麤重。“麤重”者：谓所依无堪任性。又此即是烦恼障及所知障种子。此转依若由断声闻等所有麤重而得者，今说名“解脱身”。若由断菩萨所有麤重、而得者，今说“大牟尼名法”。由断二种障差别故，显示有二转依、及无上转依。如有颂云：
    “阿陀那识体、　　当知二障(之能)相。
     惑种、一切种、　此说二缚二。”
    言“二”者：谓声闻、及菩萨。缚於前者、即是烦恼种子。缚於後者、即是二障种子。由摧毁此二、当能获得一切智体。言“此即无漏界”者：谓即此转依自性、说名无漏界。由无麤重故。由远离一切漏故、名为无漏。由是圣法因故、名之为界。“界”声者、此中即是因义。“不思议”者：以非寻思境界故。自内证知故。无有比喻故。“善”者：谓以是清净所缘。以安乐、及无漏法、为自性故。“常”(即是稳定)者：谓由恒常及不尽故。“安乐”者：由是常性故。若彼无常，此即是苦。转依是常，是故安乐。由断烦恼障故，诸声闻得解脱身。今此转依之能相、即名“大牟尼”法身。所以者何？由修习诸地及波罗蜜多、断除烦恼及所知二障、圆满成就转依故，即说“大牟尼”法身名。又由既不捨生死、又不为生死所染污，於一切法获得自在故。即说为菩萨法身。言“大牟尼”者：谓具有最胜威力故，即佛世尊名“大牟尼”。


瑜伽师地论本地分菩萨地真实义品释

    瑜伽师地论本地分菩萨地真实义品释
    海云论师造
    韩镜清译藏为汉

    云何真实义？谓略有二种：一者、依如所有性、诸法真实性。二者、依尽所有性、诸法一切性。如是诸法真实性、一切性、应知总名真实义。
    应说已学自利利他菩萨、若能学习真实义者，当得无染，故於彼後显示真实义品学处。无染亦有二种：一者、由无烦恼故得无染。二者、离分别无染。应说二种无染即是了知真实，是故今说“云何真实义”。彼事自体、即唯实性、称彼实性之义、名“真实义”。即智所行境界、或所缘境性。略说真实有其二种：一者、如辨别谓诸事真实、或诸法自性、唯此无他。二者、如辨别其数、谓凡此一切即是诸事无馀实性，或谓诸法唯如是量。是故今说“依如所有性”等。此中“如”者：谓无颠倒。此具实有体性、名“如所有”。“如所有性”者：谓体具所如实有。即彼自体、说名如所有性。言“依”者：谓依此故、当安立第一种无倒真实义，是故说言“诸法真实性”。此真实性、或无倒性、即诸事如实性。言“尽所有性”等、当知亦如前说。言“一切性”者、谓更无馀，即是遍义。言“应知总名真实义”者：即是略义。
    此真实义品类差别、复有四种：一者、世间极成真实。二者、道理极成真实。三者、烦恼障净智所行真实。四者、所知障净智所行真实。
    此中真实义有二种：以能生起二种二智故。一者、世间无迷乱智。二者、本法或内法无颠倒智。此二即依世俗智及胜义智而说。世俗智所摄无迷乱智亦有二种：一者、言说随转假立言说世间平庸智。二者、与正理观察随转之正理所成就者相应殊胜世间智。此中本法或内法真实无迷乱智亦有二种：一者、成为染污无明能对治分之明行相智。二者、成为不染污无明能对治分之无 罣碍智。此依胜义谛说。是故今说“此真实义品类差别复有四种”。此中於诸世间共极成立、名“世间极成”。由计诸世间法无诤究竟故，愚夫乃至智者一切世间众、於彼诸事同觉慧转，及由共极成增上力故，见无差别。是故说名“世间极成”。“道理”者：谓三种所极成量。“极成”者：谓各自亲知、或通达义。如是名为“道理极成”。由烦恼即障故、名“烦恼障”。以能障自能治分智生起故。此中能解脱此障所有智、名烦恼障净智。即谓远离无明、慧得解脱义故。若得解脱，即此、名之为“净”。此智所缘境性、名为“所行”。如是名为第三种真实义。由所知即障故、名“所知障”。即此所知与障和合，谓除佛智以外、均能隐伏一切馀智而转。能净彼智名“所知障净智”。即於一切所知无著无 罣碍智、成为此智所行境界、名为第四真实。若如是者，当知此中本法所有智亦如世间智有平庸及殊胜差别故、分为二种。
    云何世间极成真实？谓一切世间於彼彼事随顺假立、世俗串习、悟入觉慧所见同性：谓地唯是地、非是火等。如地，如是水、火、风、色、声、香、味、触、饮、食、衣、乘、诸庄严具、资产什物、 涂香、华鬘、歌舞、伎乐、种种光明、男女承事、田园、邸店、宅舍等事、当知亦尔。苦唯是苦，非是乐等。乐唯是乐，非是苦等。以要言之：此即如此、非不如此，是即如是、非不如是，决定胜解所行境事、一切世间从其本际展转传来想自分别共所成立，不由思惟、筹量、观察、然後方取，是名世间极成真实。
    如是且依总安立门略标四真实义已、为广分别及解说故，今说“云何世间极成真实”等。此中言“一切”者：谓由愚夫乃至智者一切善名言者。言“於彼彼事”者：谓总略说有四种事：一者、大种事。二者、所造事。三者、集彼事。四者、非二事。为显同见因故、今说“随顺假立世俗串习”言、即由随顺假立串习、及随顺世俗串习、生起悟入觉慧义。由於彼彼事中一切世间无有诤故，远离诤论所见同故，有同觉慧及同智生起。即此诸事、说名真实。此中假立者：谓确构所想。即由此名能表如是如是诸事。“世俗”者：谓言说。即假立已、如如随想所起如是如是能起言说之略辞也。“串习”者：谓由诸世间生生展转相续相传无量修习故，与具有以所诠与能诠为能相之声相属不离。即假说言此事定唯此想。由随顺此而悟入者、谓若随逐假立串习及世俗串习，得依此门悟入极善悟入时、则所见皆同。以随彼觉慧悟入而生起故。即於彼事同胜解义。依如是事聚、当分别三种：一者、大种事。二者、所造事。三者、彼二事。谓依十种资身什具、及所摄受事说。言“诸庄严具资产什物”中、是现前享用故、名为受用。即共同施设庄严具等义。依所极成心心所聚复说苦乐等句。无为法者、虽亦唯能诠，然非是可言说事故、且显诸有为法。为显由决定分判“此即如此非不如此”时、能起共同识知故，则由於决定“是即如是非不如是”事中、起共同胜解。或於所决定行相起增上胜解故。云何名为增上胜解？谓於所决定事中、说如是坚持者，即决定显示其行相。为显此真实是世间极成故、说言“从其本际展转传来”等。展转传来者：即由假立及串习之义。言“自分别共所成立”者：谓彼士夫於彼方所由宿昔分别增上力故、今极善成立。此中有作馀释：言“展转传来”者：谓为显明即前所说随顺假立而行义故。即是所言“依自分别共所成立”。言“不由思惟筹量观察”等者：谓简道理极成。即谓虽非由以量为门能取，然由从其本际展转相续传来想自分别增上力、而能取故。
    云何道理极成真实？谓诸智者有道理义。诸聪叡者、诸黠慧者、能寻思者、能伺察者、住寻伺地者、具自辩才者、居异生位者、随观察行者。依止现比及至教量极善思择决定智所行所知事、由证成道理所建立所施设义，是名道理极成真实。
    由於世间许是聪叡者故、名为“诸聪叡者”。“道理义”者：即无颠倒义。由具有於慧善巧故、说名“诸智者有道理义”。亦即具有世间正见。由此所说、遮彼随顺外道邪论诸 聪叡者。以彼等聪叡者善巧颠倒慧非道理义故。由善巧善能成立其他道理义故、说名“诸黠慧者”。为显彼诸虽离教证、亦不越於道理者故，说言“能寻思者”等。由二因缘、说名能寻思者：一者、由计度故能破於他。或具有由自能成立而行。是故说名具有寻思。二者、虽长时流散，然能寻思者不越其境界。谓虽安住寻思境界，然非证、亦非教。是故复说此等为堕诸寻思之地。言“辩才者”中、亦说为堕诸寻思地者耶？谓显彼有三种故：由宿昔修习寻思、并已悟入，是故说名“具自辩才者”。由未具有无漏证智、是故说名“居异生位者”。由非依教为门而生、纯依寻思而起，是故说名“随观察行者”。如是当知：由一句标。由二句释。由第三句标。由二句释。复由三句释上释。复次、彼诸所有智皆依道理为门而生，非依虚妄分别为门。为显道理即是三种能量故、今於论中依三种自所诠智说现、比义、及所信乐义。复依自相、共相、及殊胜相、而说。“极善思择”者：谓依比量门、及无过失教门而生。“决定”者：谓依现量而生。谓依所见标志、及根所对境、说比及现名。复次、“极善思择”者：谓依道理为门而生故。“决定”者：谓不可引夺故。复次、由是无知及颠倒智能对治分故、说言“极善思择”。由是疑智能对治分故、说言“决定”。如是能解脱无知颠倒智、及疑智故、当说名为世间正智。由彼三事所有道理於他极善成立，说言“由道理所建立”。由具比相道理故，说言“所建立”。由具教相故，说言“所施设”。又或此二为同一义。
    云何烦恼障净智所行真实？谓一切声闻独觉若无漏智、若能引无漏智、若无漏後得世间智所行境界，是名烦恼障净智所行真实。由缘此为境、从烦恼障智得清净，於当来世、无障碍住，是故说名烦恼障净智所行真实。此复云何？谓四圣谛：一、苦圣谛。二、集圣谛。三、灭圣谛。四、道圣谛。即於如是四圣谛义极善思择、证入现观。入现观已、如实智生。此谛现观声闻、独觉、能观唯有诸蕴可得，除诸蕴外、我不可得。数习缘生诸行生灭相应慧故，数习异蕴补特伽罗无性见故，发生如是圣谛现观。
    论说“一切”者：为善显示由二种劣中胜品类所分三种声闻、及三种独觉、所证同故。由一切烦恼先行、为无明故。若无明能对治分已生起时，彼诸烦恼亦当断除。如是为显明智所行境事、即是烦恼障净智所行故，明智亦当安立三种：一者、由能观察事故。二者、由能现观事故。三者、由能安立事故。最胜者：谓出世间智。由於诸事如实极善思择故，说名明智。如馀经言：由善了知、极善了知、说名明智。何者为所了知耶？谓色、色集、色灭、及色趣灭道。由此即是说缘四圣谛为境。即为解此上所缘故、论说“若无漏智”等。由是彼智资粮故，及於彼智随顺观察故，此闻所成智等、亦说为明智。是故说言若能引无漏智等。後得清净世间智、由依彼智为因所生故，亦说为明智。是故说言“若无漏後得世间智”等中、依能得彼及彼後得，说名世间。由当说为此智所行及为所缘境者、是故即所知及境界义。由此义故，烦恼障净智所行三种所知、亦说名明智。因此、论中为显此因故，说言“由缘此为境”等。言“从烦恼障智得清净”者：为显自性解脱之解脱智故。言“於当来世无障碍住”者：为显相续解脱故。复次若无漏智、及能得无漏智者、为从烦恼障而得清净。若无漏後得世间智者、为无障碍住。今者为显真实事故、说言“谓四圣谛”等。由四谛智是生死能对治分故。由缘此事为境、能断烦恼。以经说“正见能解脱”句。故又如馀经说云：“由於四圣谛未见、未证、未了达故，汝等长夜於生死中流转奔驰。”极善思择者：谓於能引无漏智、观察谛法位。“证入现观”者：谓无漏智现观位。“入现观己”者：谓於无漏後得智安立谛法位。复次此智於彼诸事、由何等行相？如何生起？并由何次第耶？为显彼智行相、及次第故，说言“此谛现观”等。由於实有、则缘实有行相、智得生起。由於非有、则缘非有行相、智得生起。是故说言“能观唯有诸蕴可得”等中、谓由此言显示补特伽罗无我证智行相生起。为显次第故，说言“数习缘生诸行生灭相应慧故数习异蕴补特伽罗无性见故发生如是圣谛现观”。即是数习空见、及无我见义。
    云何所知障净智所行真实？谓於所知、能碍智故，名所知障。从所知障得解脱智所行境界、当知是名所知障净智所行真实。此复云何？谓诸菩萨诸佛世尊入法无我、入已善净、於一切法离言自性假说自性平等平等无分别智所行境界。如是境界、为最第一真如、无上所知边际、齐此一切正法思择皆悉退还、不能越度。
    言“谓於所知能碍智故”者：谓於所知能碍智转。随智为障、当知即是不染污无知。谓声闻等所有。异生、则具染污及不染污二种。又有立言：由所知体即是障故、名所知障。谓即所知体若如是住者，由唯佛陀智以外诸所馀智增重而转。此说非实！所知障者乃依不染污无知、安立此名故。此中所知由前增重其所知力所引生故，即此亦非染污性故，说名所知障。是故一切所知中非染污者、皆名所知障！以於此中碍智不生故。然此所知非有力能引生智所治分！由如是故、说言“从所知障得解脱”。复次、此即真实。以所知自性即是圆成实性故。是故由智能令开显。因当说言由智分明显现所知境故。言“谓诸菩萨”等中、即诸菩萨悟入法无我智是有学道所显。诸佛世尊已善入法无我智是最胜修习、已至究竟、圆满、清净。为显此智行相故、说言“於一切法离言自性”。此中“一切法”者：谓於一切超越所有语言境界中、远离任运分别戏论智所知境，当知如是名为“离言”。为显此智解脱所取能取分别故、说言“假说自性”等。如彼所知事、此假说自性亦是无分别性。以自性非是分别所行故。以当说言非分别、亦非无分别故。如是此智由远离一切分别行相而无分别故、当说与所知事平等。由此智故、此所知境即真实性。又此依安立之差别故、当说二种：一者、染污。二者、非染污。此中由是客尘随烦恼性故、名为染污。由成为是言说所依及所因故、说名为能相。随诸因缘所取能取行相转，由如是所摄故、名为依他起性。当说随诸缘力如是如是现起故。乃至说此现起诸法未捨言说。复次、即此体性由远离分别故，最极清净、不待因缘、法尔自体性安住性、是圆满、成就、是故说名圆成实性。由是不转变自性故、名为真如。是故说言“如是境界为最第一真如无上”。谓如水界、精金、虚空、诸清净性故，说名“最第一”。或是最胜智所行性故、名为“最第一”。谓齐至所知边际故、名为“无上”。因此为显所知边际性故、说言“一切正法思择皆悉退还”。在此之外、更无所思择法故。“退还”者：谓由此智所作已究竟故、唯当转还。“不能越度”者：即越度於此、无别可入之义。
    又安立此真实义能相、当知即是无二所显。所言二者：谓有、非有(即事体与无事体)。此中有者：谓所安立假说自性。如是世间长时所执、亦是世间一切分别戏论根本。或谓为色、受、想、行、识。或谓眼、耳、鼻、舌、身、意。或复谓为地、水、火、风。或谓色、声、香、味、法、法。或谓为善、不善、无记。或谓生、灭。或谓缘生。或谓过去、未来、现在。或谓有为、或谓无为。或谓此世、或谓他世。或谓日、月。或复谓为所见、所闻、所觉、所知、所求、所得、意随寻、伺。最後乃至或谓涅槃。如是等类、是诸世间共了诸法假说自性。是名为有。言非有者：谓即诸色假说自性、乃至涅槃假说自性。无事(体)，无(所)相(性)。假说所依一切都无，假立言说依彼转者、皆无所有，是名非有。先所说有、今说非有。有及非有二俱远离、法(能)相所摄真实性事，是名无二。由无二故、说名中道。远离二边、亦名无上。佛世尊智於此真实已善清净，诸菩萨智於此真实学道所显。
    如是已显智所行境，为显真实义相安立故、说言“又安立此真实义能相”等。言“无二所显”者：谓解脱於二、捨离二边故、即是中道所摄。犹如幻事、阳焰、影像、谷响、不能说有及说非有，即不能安立此二义。若如是故说为无二所显。又若如是愚夫假立此幻象等自性无有。虽於此中解脱於有，然非一切都无。以木石等物是有体故。如是阳 焰等一切、随其所应亦当知。若如是者，诸有是愚夫所假立自性。由解脱此故、名远离於有。由是唯事体所显故、由是圣智所行境性圆成实故、名远离於非有。若如是者，即得远离增益、损减、二边。若如是者，即是开显中道。复次二义者、谓有及非有。以依安立中道而说故。言“有者谓假说自性”者：当说即是彼立言说、或语言、或言诠。言“所安立”者：即是所宣示、或所说。谓自性、及差别等。由如是故，即当显说如彼愚夫言句所说、心之所计、如是如是均非实有。言“长时所执”者：即由执著所执取义。若如是故，即当说言如彼愚夫所执取者、如是都非是有。言“一切分别戏论根本”中、“一切分别”者：当知即是八种解说行相。依常等言说观察计度、或分别所有言说、名为“戏论”。以彼等为依、或以彼为行处、即成为根本。是故当说此有、即以想及分别为依。复次“一切分别”者：略说即是所取能取二种分别。由此为根本故、生死流转名为“戏论”。彼诸行处、说名“根本”。此中由依自性说故、说言“或谓为色”、乃至於“识”。由依能取分别说故，说言“或谓眼”、乃至於“意”。由依所取分别说故，说言“或复谓为地”、乃至於“触”。即所依色、及能依色、总合说为所取性。由依差别分别说故，说言“或谓为善”、乃至“或谓无为”。由依现见法、及後法分别说故，说言“或谓此世”等。由依昼夜、分别说故，说言“或谓日月”。由依言说、分别说故，说言“所见”等。由依慧所观察说故，说言“所求所得”等。言“最後”者：谓灭尽一切戏论所得涅槃。又若如是者，为显具愚夫慧所摄一切以分别为性故，说言“如是等类是诸世间共了诸法假说自性”、即由想及假说而安立义。言“诸世间”者：谓即显示诸愚士夫所假立性。“无事”者：谓於五事中拨无第一，说名无事故。由如是故，即除遣名分别事。由於三性中遮无依他起故，名为“无相”，是故说言“假说所依一切都无”。由遮假说所依事及言句所依事故，说言“一切都无”、及“皆无所有”。既说一切唯是假立、一切唯是言说，彼等亦谤言说为无。若如是者，应得唯有无所相无所依之假。然如是假、世间不许，论亦不说。略说彼法当立三种：谓由聚集、因缘、及分位、有差别故，假法亦有差别。若依彼等聚集相应是即有所相。如是色等一切假法、亦应是有。此若无者，不应说假。且若尔者，所持“诸事都无”言论、应得成立！以但依言论说彼为无故。言法能相所摄者：即谓由一切法无我所显故之义。若如是者，此事即名“无二”。由离二故即名“中道”。为显离二性故说言“远离二边”。谓计如前所说初种行相、是实有者，名第一边。谓计唯事亦无所有者，名第二边。由远离如是二边故，即名“远离二边”。由具有无色无见等殊胜，故名为“无上”。复次、当说即此真实是诸佛世尊及诸菩萨所有境界故，以佛菩萨於一切所知决择自在故，已齐至所知边际故，或已入趣、或励力求趣所知边际故，佛世尊智、名为“已善清净”。已得究竟地边相应故。诸菩萨智即十地中能善差别有学地增上戒等三学所摄故。言“於此真实”者：即於上说无二真实中，如是当说佛世尊智最极清净最极圆满，诸菩萨智未极清净未极圆满。
    又即此慧、是诸菩萨能得无上正等菩提广大方便。何以故？以诸菩萨处於生死彼彼生中、修空胜解，善能成熟一切佛法、及诸有情。又能如实了知生死，不於生死以无常等行深心厌离。若诸菩萨不能如实了知生死，则不能於贪瞋癡等一切烦恼深心棄捨。不能棄捨诸烦恼故，便杂染心受诸生死。由杂染心受生死故，不能成熟一切佛法、及诸有情。若诸菩萨於其生死以无常等行深心厌离，是则速疾入般涅槃。彼若速疾入般涅槃，尚不能成熟一切佛法及诸有情、況能证无上正等菩提！又诸菩萨由习如是空胜解故、即於涅槃不深怖畏，亦於涅槃不多愿乐。若诸菩萨深怖涅槃，即便於彼涅槃资粮不能圆满。由於涅槃深怖畏故、不见涅槃胜利功德。由不见故、便於涅槃远离一切清净胜解。若诸菩萨於其涅槃多住愿乐，是则速疾入般涅槃。彼若速疾入般涅槃，则便不能成熟佛法及诸有情。当知此中若不如实了知生死，即杂染心流转生死。若於生死深心厌离，即便速疾入般涅槃。若於涅槃深心怖畏，即於能证涅槃资粮不能圆满。若於涅槃多住愿乐，即便速疾入般涅槃、是诸菩萨於证无上正等菩提无大方便。若能如实了知生死，即无染心流转生死。若於生死不以无常等行深心厌离，即不速疾入般涅槃。若於涅槃不深怖畏，即能圆满涅槃资粮。虽於涅槃见有微妙胜利功德，而不深愿速证涅槃。是诸菩萨於证无上正等菩提有大方便、是大方便依止最胜空性胜解。是故菩萨修习学道所摄最胜空性胜解、名为能证如来妙智广大方便。
    言“又即此慧”至“广大方便”者：以是非方便能对治分故，於此非方便中、亦有四种与能得无上正等菩提相违。彼等由我见及贪爱故，欣乐生死、怖畏涅槃。或由观见生死过失故，则永求速疾远离贪爱，修习涅槃。由见涅槃最寂静故，专此趣向。由是此等能对治分故、名为“广大方便”。为诸菩萨能得菩提方便性者、由慧及悲二更互随顺转故，谓由慧能见生死过失、及涅槃寂静。既若如是者，复由悲力不捨生死、不证涅槃。复次、即是无住涅槃分位。谓诸菩萨由如是慧安住无住涅槃，非如流转生死有情住於生死、亦非如声闻等入般涅槃。因此虽由生死大苦遍所恼乱，然不棄捨有情义利。亦不现证涅槃。是故此慧同於彼等所有分位而转、名为“广大方便”。若由此慧於成熟有情及诸佛法、能善修习者，则能如实了知生死众苦。如是能善了知苦故，则能如实了知生死。由遍知故、虽已远离贪爱，然不成就涅槃及与解脱。以与加行修习二种成熟恒相应故。若如是者，彼无始时来见生死功德、何故不说？是故说言“若诸菩萨不能如实了知生死”等。由於生死生欣乐故，即为生死过失所染。若由过失所染者，且无力能作诸自利，因此成前所说住生死过。由永断杂染故，彼由诸厌离生死猛利追悔作意，速疾趣般涅槃。如是若入无馀依般涅槃界者，则当说彼於二成熟极自退失。是故说言“尚不能成熟一切佛法”等。言“如是空性胜解”者：即能安住所取能取空性义。彼诸菩萨虽不现证涅槃，然於涅槃不深怖畏。以意乐彼已往趣涅槃故。若不尔者，则不能得成熟此诸佛法及诸有情。是故说言“即便於彼涅槃资粮不能圆满”、谓显彼因。言“深怖畏故”者：谓心生怖畏、则不见胜利。由不见胜利故、则无由见涅槃胜利为先所起最极清净增上胜解。是故即说“於彼涅槃资粮不能圆满”。若於是处见功德故、有造作心，是名为愿。当说即为得此勤力求故。为显所对治者非是方便、而能对治即是方便故，说言“若不如实了知生死”等。为显如是所说法无我所摄四种方便乃依於此故、说言“是大方便依止最胜空性胜解”即所谓“此有故彼有”义。
    又诸菩萨由能深入法无我智於一切法离言自性如实知已、达无少法及少品类可起分别，唯取其事、唯取真如。不作是念此是唯事、是唯真如。但行於义。如是菩萨行胜义故，於一切法平等平等以真如慧如实观察、於一切处具平等见、具平等心、得最胜捨。依止此捨於诸明处一切善巧勤修习时、虽复遭遇一切劬劳一切苦难，而不退转。速疾能令身无劳倦、心无劳倦、於诸善巧速能成办得大念力，不因善巧而自贡高，亦於他所无有 秘吝。於诸善巧心无怯懦有所堪能、所行无碍，具足坚固甲铠加行。是诸菩萨於生死中如如流转、遭大苦难，如是如是於其无上正等菩提堪能增长。如如获得尊贵殊胜。如是如是於诸有情憍慢渐减。如如证得智慧殊胜。如是如是倍於他所难诘、诤讼、諠杂、语论、本惑、随惑、犯禁现行、能数观察深心棄捨。如如功德展转增长。如是如是转覆自善、不求他知、亦不希求利养、恭敬。如是等类菩萨所有众多胜利、是菩提分，随顺菩提皆依彼智。是故一切已得菩提、当得、今得、皆依彼智。除此更无若劣若胜。
    言“能深入”者：谓由此智能究竟十地、即亦由此能断一切分别戏论。言“少法”者：谓从色乃至涅槃。言“及少品类”者：谓自性或差别、或由分别之差异随顺其他所有类。由远离如是分别故，即由此智唯取其言说所依事、谓五事中第一。言“唯真如”者：谓最极清净分位。复次、为解说能观见唯事义故、说言“唯取真如”。於此真如事中、亦不分别唯此真如事。以远离一切分别故。因此断一切戏论行胜义者、得安住无所相。为显当得由如是行所生胜利故、说言“平等平等”等。谓由初地自证遍行真如故，观见真如一味性、及诸法平等性。即於一切法、及一切有情、具平等心故，能得於捨。以无差别及种种差异故。若於此中有差异者，即於此中无平等心。若如是者，由具平等心能得不染污捨。若无烦恼，於诸明处修习善巧、亦无烦恼而能成办。由於成办无烦恼故、虽遭一切苦及一切劬劳，而不退转。若烦恼相应时，当说劬劳能作损害、并与苦俱。若如是者，当圆满所说能至无烦恼心身边际。由此诸言亦显多闻广大。依诸菩萨於自所依能积集故、说言“得大念力”。即谓於正闻所摄一切明处。已精於业、菩萨尽生死际无有忘失。虽具如是多闻广大体性，然亦不自 赞扬、不自贡高。由於一切心平等故、於他乐欲成就殊胜功德故、及具自他平等增上意乐故、於诸他人“无有秘吝”。又於他所能正教示、能正开显、於诸方便善巧由二因缘“心无怯懦”：一者、由无敬重心故，无欲无勤。二者、为自利得故，无有勇悍。由於魔眷属等诱变希欲时、不退转故，及说“所行无碍”故，说言“具足坚固甲铠加行”。言“大苦难”者：谓强烈等行相。复次、此“大苦难”者：谓虽如彼住在生死一切有情为邪行众苦所摄，如是亦为诸苦所触、然於一切有情悲心恒现在前。是故自身不速疾般涅槃、唯为解除一切有情苦故，能勤修作。是故说言“堪能增长”等。言“获得(身)尊贵殊胜”者：谓高上种姓等尊贵。言“憍慢渐减”者：由善知世间故，当说随诸有情、如是如是引发故。言“证得智慧殊胜”者：谓如说无诤是沙门第一法故。从他纠缠、诤讼、或辨难相续中、能自护心能自远离，即不为发作义。又由智为依能净能断一切烦恼故，从诸烦恼能自护心。又由彼力於一切罪行见过失故，能自护心。即由能棄捨故、不成染污义。若由胜利功德倍增长故能得究竟时、则无折服诸生信者所有乐欲，而“转覆自善”。言“他知”者：谓希欲众多士夫知己功德。若当说且非计度应具如是功德而起希求，何況自计成德要令他知！言“众多胜利”者：谓超越一切世间、及诸声闻独觉相续故，具足不共功德胜利。当说由彼诸智增上而生起故。以於其馀智中、无所有故。为显如是功德是菩萨道资粮所摄、於诸菩萨能多饶益故，说言“菩提分”等。为显此智时世殊胜及相续殊胜故、说言“是故一切已得”等。谓显此智堕一切世及一切菩萨相续。由施设言此智若无、尔所有时亦不随得无上正等菩提，是故成立此智是成佛首道。
    又诸菩萨乘御如是无戏论理、获得如是众多胜利：为自成熟诸佛法故、为成熟他三乘法故、修行正行。彼於如是修正行时、於自身财远离贪爱、於诸众生学离贪爱、能捨身财。唯为利益诸众生故。又能防护极善防护由身语等修学律仪。性不乐恶、性极贤善。又能忍他一切侵恼，於行恶者能学堪忍，性薄瞋忿不侵恼他。又能勤修一切明处、令其善巧：为断众生一切疑难、为惠众生诸饶益事、为自摄受一切智因。又能於内安住其心、令心善定，於心安住常勤修学；为净修治四种梵住、为能逰戏五种神通、为能成立利众生事、为欲除遣精勤修学一切善巧所生劳倦。又性黠慧成极真智、为极真智常勤修学；为自当来般涅槃故、修习大乘。又诸菩萨即於如是修正行时、於具功德诸有情所常乐现前供养恭敬。於具过失诸有情所常乐现前发起最胜悲心愍心、随能随力令彼除断所有过失。於己有怨诸有情所常起慈心、随能随力无谄无诳、作彼种种利益安乐，令彼怨者意乐加行所有过失、及怨嫌心、自然除断。於己有恩诸有情所善知恩故、若等若增现前酬报，随能随力如法令其意望满足。虽无力能，彼若求请；即於彼彼所作事业示现殷重精勤营务、终不顿止彼所希求：云何令彼知我无力、非无欲乐。如是等类、当知名为菩萨乘御无戏论理依极真智修正加行。
    今者为显正依此智及由此智力所引不共行故、说言“乘御如是无戏论理”等。言“戏论”者：谓是苦根故，及是所应断故，即是一切虚妄分别。此智是彼戏论能对治分，说名“无戏论理”。“乘御”者：即住此、或依此义。由具足如前所说胜利故、说言“获得如是众多胜利”。言“为自成熟诸佛法故修行正行”者：即修自利义。於自相续能得彼诸佛法、名为自利。然非由为己增上而行。此中诸佛法者：谓力无畏等。彼诸佛法能成熟者：一、彼成熟因殊胜。谓展转相续倍增加行。二、时殊胜。谓能获得具有异时殊胜转变。由修习诸行、及波罗蜜多为门、能成熟佛法故，名为“正行”。言“为成熟他三乘法故”者：谓此三乘因果所摄、说名三乘。成熟三乘者：谓趣入成熟、及解脱分位。谓如有一随能随力依彼界及胜解力故，能令入於三乘。已趣入者、能令成熟，已成熟者、能令解脱。如是即是彼诸菩萨所有正行。能成熟自佛法正行者、此中当知即是修行六波罗蜜多所摄加行。此中依修行施波罗蜜多故，说言“身财”等。言“於自身财远离贪爱”者：谓远离染著。即不顾恋身财义。又不顾身财中、有二种菩萨：一者、由胜解力。二者、由意乐力。此中由胜解力者：谓於胜解行位。以未证真实故。由意乐力者：谓登地菩萨。此中诸登地菩萨者、说为“远离贪爱”。诸胜解行地菩萨者、说为“学离贪爱”。复有异门：谓由寻求及遍摄受之自性空故、名为“远离贪爱”。於彼修习如理作意故、名为“学离贪爱”。复次，於一切有情所尽自身财能学习捨、及远离贪爱，是故说言“能捨身财”等。如有颂云：“於他诸有身不消福、不损，慈心承事汝：可取、任分割”。由解如是颂义故、及为显示正受尸罗所为故、说言“唯为利益诸众生故”等。谓菩萨尸罗有三种：一者、律仪戒。二者、饶益有情戒。三者、摄善法戒。今於此中依受持律仪戒、说言“又能防护”者：谓正受违反律仪故，後随护持、名为“极善防护”。由缘未来法尔所得尸罗为境界故、名为“修学”法尔所得菩萨尸罗。又有二种：一者、於彼彼处所生时、由意乐殊胜故得。二者、由所依殊胜故得。此中意乐殊胜者：谓性不乐恶羞为罪行、及施捨有情具足故。为显如是等义故、说言“性极贤善”。所依殊胜者：当知由具有所说所依殊胜故、得身相续无有力能造作罪业。依忍波罗蜜多故、说言“又能忍他一切”等。“忍”者：谓能耐受。即能耐受侵恼义。此中“侵恼”者：即由恶语、暴声言说路、能生起忧恼义。言“行恶者”者：即由引发非爱触故、能生身苦义。言“能学堪忍”者：谓由审思力及修习力、勤勉求得堪忍力。“性薄瞋忿”者：谓心少忿怒。言“不侵恼他”者：谓不唯由听闻侵恼、及不出不悦耳语、名为“不侵恼他”。由如是故，显示由意乐及加行能起忍已、说言“又能勤修一切明处令其善巧”。谓由具足常时殷重加行故、能断彼诸已修明处数数生起疑难故、即为“善巧”。又於彼诸未修明处由坚固加行能摄受故、即於摄受得其善巧。即由具有能力义。又为自能遍摄受一切善巧因故，勤於一切明处。或於善巧、说言“又能於内安住其心”等。谓於彼彼善业品中、能勤加行心离动摇，说名“於内安住其心”。能正决择於义、名为“令心善定”。如是依非定地中静虑加行显说已、今依定地故，说言“於心安住”。为显能积集自福资粮根本、即诸无量所摄故，说言“为净修治四种梵住”。当说为依具足神通所有威力为门、能成办有情利益乃生起静虑故，说言“为能逰戏五种神通”等。为显若依静虑力修习蕴善巧者、能得身心无劳倦故，说名“为欲除遣精勤修学一切善巧所生劳倦”。依修行慧波罗蜜多故、说言“又性黠慧”等。谓於彼彼生中获得如是生得慧、善能随顺悟入一切明处故，名“性黠慧”。由具足加行所生慧故、名“极真智”。即於如是慧中具足极善修习能至究竟、说言“为极真智常勤修学”。为显由常勤修学如是极真智、渐次能依大慈入般涅槃故，说言“为自当来般涅槃故修习大乘”。大乘涅槃者：即无住涅槃。以尽生死际能成办饶益有情事故。为显令他有情成熟三乘法故、及显於四谛中依四行相为门具足清净意乐与加行故、说言“即於如是修正行时”等。谓於父、母、沙门、婆罗门、及具功德诸供养处、时时成就布施及 赞扬等事、即显诸菩萨勤作慈俱恭敬事业。於彼一切具恶成就能入苦因过失诸有情所、作如是念：虽他有情即於一日夜之苦，亦当令除。即由悲心欲除未来苦果、名为“愍心”。或即悲心异名。依如是加行成满故、说言“随能”等。谓随己力能安置彼於离过失所、以令出不善处安置善处故。如是为显於诸具有过失补特伽罗所、由意乐与加行修正行故。於能作诸菩萨损害不饶益不安乐诸有怨有情所、令生利益安乐故、慈心常起现前，为显由诸加行作彼种种利益安乐故、说言“随能”等。如是於彼能作损害诸有情所、由二因缘能修正行：为显於彼怨者如诸无怨不生嫌恨故、说言“令彼怨者意乐加行所有过失”等。谓於彼怨者深恐昔日为害於人、今念人当为害於己，然实不加损害、令知是自意乐加行过失故。为显由能作诸种种利益安乐加行故，随时所起意乐即能如是加行故，说言“自然除断”。此中於一切所作事业、亦由二因缘能修正行：言“於己有恩”者：谓於昔日曾作饶益诸有情所、由善知彼所作恩益为门，现前酬报。为开解彼善知恩益故、说言“若等若增现前酬报”等。依一切饶益事业所为主旨故、说言“如法令其意望满足”。谓是无罪故、及有力能故、能令满足。由如是故、说言“随能”等。为显虽无力能、然於彼彼事中有随顺彼事意乐及加行故，能令了知己於此事非不欲为、唯无力能。
    以何道理、应知诸法离言自性？谓一切法假立自(能)相：或说为色，或说为受，如前广说乃至涅槃，当知一切唯假建立。非有自性，亦非离彼别有自性、是言所行、是言境界。如是诸法非有自性如言所说、亦非一切都无所有。如是非有、亦非一切都无所有，云何而有？谓离增益实无妄执、及离损减实有妄执，如是而有。即是诸法胜义自性，当知唯是无分别智所行境界。
    如是且显於具功德具过失、有恩有怨诸有情所，由意乐及加行修正行已，今於如前所说诸事体中所立有宗无宗之中道义、令诸未成立得以成立故。问言：“由何道理”？答言：由证成道理故、证成未成。谓此於四道理中、许为证成道理。即前所说三能量所摄。即诸法离言自性。即由此因缘能厘清之义。为依道理当显示故、说言“当知一切唯假建立”。谓彼诸事唯是假建立性：即能除遣自性义故、说为唯假建立。由是故说言“非有自性亦非离彼”等。如是假立言说於诸事中、既非有彼之自体性，亦非是离彼别有。唯是虚妄能遍计执性。若如是者，诸法如诸愚夫假立行相、不如是有。除此以外、为显圆成实行相是实有故，说言“亦非一切都无所有”等。如是即显远离二边中道为实有义。若如所说行相非有、亦非非有者，则此行相云何为有耶？为显此故、说言“云何而有”。谓於自能相实无性中取诸所相已、增益邪执，及於已断离非实有者、增益，即此说名“妄执”。由以遍计所执为自性故。遍计所执自性、亦说异名为颠倒所取等。言“妄执”者：明说执著故。由是言说所依故，及是假安立所依据故。今遮如是为有诸事、一切都无，是即名为“损减”。即此说名妄执、如前应知。如是即依远离增益损减二边所有行相、当说“如是而有”。如斯实有体性、由何能厘清耶？为显此体决定是所知摄故、及由智当得厘清故、说言“唯是无分别”等。谓唯由超越一切世界之最殊胜智为能厘清，而非由所馀。若彼具有如是智者，即由斯人、於此无疑无愚。由彼已现前亲证故、如是当说此唯圣性所行境界。
    若於诸法诸事随起言说、即於彼法彼事有自性者，如是一法一事应有众多自性！何以故？以於一法一事制立众多假说、而诠表故。亦非众多假说诠表决定可得。谓随一假说於彼法彼事有体、有分、有其自性，非馀假说。是故一切假说、若具不具於一切法於一切事皆非有体、有分、有其自性。又如前说色等诸法、若随假说有自性者，要先有事、然後随欲制立假说。先未制立彼假说时、彼法彼事应无自性！若无自性，无事制立假说诠表、不应道理。假说诠表既无所有，彼法彼事随其假说而有自性、不应道理。又若诸色未立假说诠表以前先有色性、後依色性制立假说摄取色者，是则离色假说诠表、於色想法於色想事应起色觉、而实不起。由此因缘、由此道理、当知诸法离言自性。如说其色，如是受等、如前所说乃至涅槃、应知亦尔。
    为显一类执著有之立宗有三种过失故、说言“若於诸法诸事”等。谓约缘起自性实有依他起体性而说、名之为“法”。即约此性清净分位胜义实有圆成实体性而说、名之为“事”。复次圆成实自性、说名为“法”，以能任持自能相故。若五事中相(可译作相分或原因)、即此说名为“事”。由是言说所依故。复次为显此原由是实有性故，说名为“法”。为显此原由以名及分别为所依故、说名为“事”。言“即於彼法彼事有自性”者：谓言说所有自性、由以此决定所计度为自性故，亦即以言说语句为自性义。观待法体、说名为“众”，观待事体、说名为“多”。如是唯於一法得成众多自性者、谓由种种言说故，即时处差别有众多故。即於此一事依时差别增上故、种种众多言说而转。於彼彼士夫众中、依众多训释言词异门差别而转。若有说言由众多为所诠表，则由一能诠表定彼自性、馀均不尔者，由是因缘说言“非馀假说”等。所以者何？如是当说亦非由一假立言说能诠表事体决定可得。谓若随一能诠表事体时、即成为彼之自体，馀则不尔。如是决定、不可得故，由无差别因故，一切皆应得成彼自体、或彼自性！若如是者，即难除遣多自体过。复次、若谓非是馀者，此一亦非。以於因中无差别故。是故说言“是故一切假说”等。若如是者，且有二种分别：一者、由言说体有众多故、事体亦成众多。以一切言说皆是彼自体故。二者、即一能诠亦不成彼自性。由无决定唯以此一为自体故。言“又如前说”等者：亦为显所馀众多过故。言“要先有事”者：谓无始时来世界先起、诸法恒常依住；随後有情世界生起，彼诸有情随所欲乐假立言说而能诠表，如是先有事体生起，随後始能假立语句。若如是者，未假立前、即“未制立彼假说时”、彼事体应不得彼自体。由於尔时未制立假立言说故，一切具有假建立性事体应成无有。由离事体外、无别实有法转起故，应说不许此事先有。然若先时无有事者，则假为制立亦应无有。由是因缘、无有假说为彼自性故。理应安立一切法离言自性。如是应成先无事体过失。为遣如是过失、故有说先时即有如是自性者。为显是宗有馀过失故、说言“又若诸色未立假说诠表以前”等。谓先有色能相、後有假说诠表。若尔，即虽无有、亦生起过。若虽无有、亦当生起者，则应坏彼所诠能诠相属。此若无者，则假说诠表虽未制立，而彼事觉亦应生起。但实非如是生起。由如是故，先有色法自性不应道理。若尔，由具有三过失故、说言“当知诸法离言自性”。如是受等乃至涅槃、当知亦是假说诠表所摄。
    有二种人於佛所说法、毗奈耶、俱为失坏：一者、於色等法於色等事谓有假说自性自相，於实无事起增益执。二者、於假说相处、於假说相依离言自性胜义法性、谓一切种皆无所有，於实有事起损减执。於实无事起增益执妄立法者所有过失、已具如前显了开示。於色等法实无事中起增益执有过失故，於佛所说法、毗奈耶、甚为失坏。於色等法实有唯事起损减执坏诸法者所有过失，由是过失於佛所说法毗奈耶甚为失坏，我今当说：谓若於彼色等诸法实有唯事起损减执，即无真实、亦无虚假。如是二种皆不应理。譬如要有色等诸蕴、方有假立补特伽罗，非无实事、而有假立补特伽罗。如是要有色等诸法实有唯事、方可得有色等诸法假说所表，非无唯事、而有色等假说所表。若唯有假、无有实事，既无依处、假亦无有，是则名为坏诸法者。
    复次第二为分明显示执著非有者宗所有过失故，说言“有二种人”等。言“於佛所说法毗奈耶”者：谓即如来言“法毗奈耶”者：此中由能得正智故、说名为“法”。由能得断离故、说名为“毗奈耶”。若如是者，即明如来教法所成立义、乃智断所显。或道果所显。言“俱为失坏”者：谓当说为外。以具过失、及悟入彼教都无胜利故。由如是故、即说若於实非有事起增益执者，则能败坏。於此教中有二种失：一者 、戒过失。二者、见过失。此中为显彼诸成就具有罪见过失故、说言“有二种人”等。为显彼由假立言说执著自性、即是成就增益见故、说言“於实无事起增益执”。又为显彼正成就损减见者执著非有事故、说言“起损减执”等。若如是者，当说由执著增益见故、及由执著损减见故，如次二种说名“失坏”。为显胜义性因故、说言“离言自性”。谓由超越一切语言境界故、及远离一切戏论故、说名为胜义谛。言“已具如前”者：谓於实无事起增益执宗中、亦当说有一事成多自性等三种过失。言“显了开示”等四句者：当知即是异门、即所谓一切隐秘都无有义。已说如是过失、即指能坏此教过失讫。欲显於实有事起损减执说非有者、由何过失能为失坏故，今说言“我今当说”。言“於色等法实有唯事起损减执”者：谓分明显示彼拨无一切论者、即拨无假立相(即原由)：既拨无此故，由无假立、与世间相违；由拨无诸相(即原由)即与圣教相违。如是为显依损减诸相(即原由)及假立为门、能坏世间及圣教即是失坏一切故，说言“譬如”等。谓於世间、或於诸论、均共见並极成有相(即原由)及有依假。此中为显教故、说言“要有诸蕴”等。谓随顺如是颂义而说，如有颂云：“如是依诸蕴、说以有情言”。言“无实事”者：为显已般涅槃故。如是色等假法所依相(即原由)事、理应为有，不得非有。是故由彼拨无假立之事、及与其相(即原由)、即无依故，假立亦无。由拨无诸相(即原由)及假立故，即得一切无见。
    如有一类闻说难解大乘相应空性相应未极显了密意趣义甚深经典，不能如实解所说义，起不如理虚妄分别，由不巧便所引寻思起如是见、立如是论：一切唯假、是为真实。若作是观、名为正观。彼於虚假所依处所实有唯事、拨为非有，是则一切虚假皆无、何当得有一切唯假是为真实？由此道理彼於真实及以虚假二种俱谤都无所有。由谤真实及虚假故，当知是名最极无者。如是无者、一切有智同梵行者不应共语，不应共住。如是无者、能自败坏，亦坏世间。随彼见者、世尊依彼密意说言：宁如一类起我见者，不如一类恶取空者。何以故？起我见者、唯於所知境界迷惑，不谤一切所知境界、不由此因堕诸恶趣。於他求法求苦解脱、不作虚诳，不作稽留，於法於谛、亦能建立，於诸学处、不生慢缓。恶取空者亦於所知境界迷惑，亦谤一切所知境界，由此因故、堕诸恶趣。於他求法、求苦解脱、能为虚诳，亦作稽留，於法於谛、不能建立，於诸学处极生慢缓。如是损减实有事者於佛所说法、毗奈耶、甚为失坏。
    於声闻乘中、由彼执著亦与显明法之能相诸经所说相违故，执著增益见转；然由已共极成故、此中不说。为显彼执著损减见由不如实解於经义而妄分别故、说言“如有一类”等。言“一类”者：即“中道论者”。“难解”者：谓由不了义所显故。“大乘相应”者：谓菩萨藏所摄性。“甚深”者：谓依法无我而悟入性。由能彰明远离一切愚夫遍计所执所有诸法自性故，说名“空性相应”。为显别有密意义故、说言“未极显了密意趣义”。当知即如“一切法无生、无灭、本来寂静、自性涅槃、如幻等”言说之所显示。彼等由不如实了知经义、如言执义故，依执著、及恶寻思道、而生悟解。即能起如是见：谓真实性唯假说。即明言由见此故、当得究竟大乘。言“不应共语”者：谓由拨无真实性故。言“不应共住”者：谓由拨无假立故。复次二种俱拨者、即无容与彼谈论义。由念如是恶见犹如污垢不宜染著、常应远离故，说言“不应共语”。又有异门由能自败坏故，说言“不应共语”。由能败坏世间故，说言“不应共住”。是故说言“能自败坏”等。为显世间有随入彼见者故、说言“世间随彼见者”。为显经说如是损减有大罪过故、说言“依彼密意”等。又此所言“起我见者”者：谓实无有情，由遍计故、能为增益。由能遮遣一切想事都非实有故、名为恶取之空性见。起我见者、不障生天。以愚自体相续故、是生能随顺诸善法故。然此空见、拨无因果自能相故，能障生天。起我见者於求解脱者趣於解脱，不为虚诳。然此空见，由开显颠倒道故，能为虚诳。补特伽罗起我见者於他有情诸求法者、能建立法。然此空见则执一切事无。起我见者不毁尸罗能於学处极敬重故。然此空见由计一切唯是假故，於诸学处心不敬重、极生 松懈。若如是者，当知於此二见胜及非胜。即由如是行相故，於佛所说法、毗奈耶、甚为失坏。
    云何名为恶取空者？谓有沙门、或婆罗门、由彼故空亦不信受，於此而空亦不信受，如是名为恶取空者。何以故？由彼故空、彼实是无。於此而空、此实是有。由此道理可说为空。若说一切都无所有，何处、何者、何故、名空？亦不应言由此、於此、即说为空。是故名为恶取空者。云何复名善取空者？谓由於此彼无所有、即由彼故，正观为空。复由於此、馀实是有，即由馀故，如实知有。如是名为悟入空性如实无倒。谓於如前所说一切色等想事、所说色等假说性法、都无所有，是故於此色等想事、由彼色等假说性法说之为空。於此一切色等想事、何者为馀？谓即色等假说所依。如是二种、皆如实知：谓於此中实有唯事，於唯事中亦有唯假；不於实无、起增益执，不於实有、起损减执。不增、不减、不取、不捨。如实了知如实真如离言自性，如是、名为善取空者。於空法性能以正慧妙善通达、如是随顺证成道理，应知诸法离言自性。
    非方便取、名为“恶取”。由是极无性故、彼空性即以非有为性，非胜义空性。即为显此故、说言“谓有沙门或婆罗门由彼故空”等。谓由邪计度故。“空”者：即以远离彼有之所有自性、亦不信受，如是一切空性、体即是无。谓於一切当成为非有之空性，言“由彼故空”者：谓应由遍计所执自性故，即由彼损减假说故，即此为无。言“於此而空”者：谓以假为依，即由彼损减虚假事行相故，即损减此为无有。如是此遍计所执及依他起二自性无故，何有空性？一切所说由彼故空及於此而空等皆不应理！有谓今此论言“何处”者、即所谓色等事义，此非应理。谓或有沙门等第一宗所说故。若尔，即当说云唯假亦空。是故论言亦不应言由此於此即说为空。谓不能言由此性故空、即此性而空。所谓空义者、即是远离义。唯假者、亦即说远离彼无所有之空性。是故说此为无有之空性者、名为“恶取”。言“於此”者：即若由如是为因义。言“彼无所有”者：谓遍计所执自性。复次、言“於此”者：谓色等诸事。若如是者，即於色等现前诸事无有愚夫遍计所执事。是故得说色等诸事由彼故空。如是当知观见具有过失诸事实性、即说名为观见胜义空性。即为分别此义故、说言“复由於此馀实是有”等。言“如实”者：谓无颠倒。即是於此而空、正观为有。即说於彼色等事中无有所取能取分别、名为空性。当说於此无染著故、如是分别非实有故。若尔唯有虚妄分别、是彼言说所依处故，是故说言“谓即色等假说所依”。应作是言：於假说中自性本空，即是唯事。以彼自体性非实有故。若尔，即由遍增益性而转。是故 《辨中边颂》云：“虚妄分别有，於此二都无”。如是即能如实了知唯事、及事唯是假。若尔，於实无中起增益智、即是遍计执。於此实有唯事中、亦不起损减执。为说如是异门故、说言不增等。
    复由至教应知诸法离言自性：如佛世尊《转有经》中为显此义而说颂曰：“以彼彼诸名、诠彼彼诸法，此中无有彼、是诸法法性。”云何此类显如是义？谓於色等想法、建立色等法名，即以如是色等法名诠表随说色等想法：或说为色，或说为受，或说为想，广说乃至说为涅槃。於此一切色等想法、色等自性都无所有，亦无有馀色等性法。而於其中色等想法离言义性、真实是有。当知即是胜义自性，亦是法性。
    如是且依道理成立诸法离言自性已、今者更欲依教成立，乃引颂义显示故、说言“以彼彼诸名”等。言“彼彼”者：谓由彼彼言说。言“彼彼诸法”者：谓依他起自性。言“诠彼”者：谓遍计执彼。言“彼”者：谓遍计所执自性。言“此中”者：谓於依他起自性中、空无所有。是故即於此经复说是言“离於能诠外、所诠非别有”。如是诸言即显示遍除遣增益边执、及分明显示二种自性。言“是诸法法性”者：即是常时依他起自性中言说及遍计所执自性永非所有之义。如是诸言、即遍除遣损减边执及分明显示圆成实自性。如是即为颂所摄义。谓若色等诸想法乃由名诠表自性者，彼名非实有故。是故此经复言说“诸法名本无”。谓若於此彼名转者，亦非离此以外别有馀法为彼自体。若尔，诸法由名计度时、由名无体故，即非别异。是故颂言“此中无有彼”。由此即是离言自性、及法尔成就故，说言“胜义自性亦是法性”。
    又佛世尊《义品》中说：“世间诸世俗、牟尼皆不著，无著孰能取？见闻而不爱。”云何此颂显如是义？谓於世间色等想事所有色等种种假说、名诸世俗。如彼假说於此想事有其自性。如是世俗、牟尼不著。何以故？以无增益、损减见故。无有现前颠倒见故。由此道理、名为“不著”。如是无著、谁复“能取”？由无见故、於事不取增益、损减。於所知境能正观察，故名为“见”。听闻所知境界言说，故名为“闻”。依此见闻、贪爱不生，亦不增长，唯於彼缘毕竟断灭、安住上捨、故名“不爱”。
    为显第二声闻相应教故、当知即是依此颂义而说。言“不著”者：谓由见、及爱、取著色等事故。“见”者：谓执著行相。“爱”者：谓由不捨行相。能执取彼事故，名为“取著”。如是二种牟尼能解脱故、名为“不著”。牟尼不执著色等诸事自性、以永断除增益及损减见故，是故说言牟尼皆不著。谓增益及损减二见为依、能生二种爱：一者、有爱。二者、非有爱。如次应说。此中非有爱者：当说以见诸事非有为门而生故，见、爱生起。有爱者：谓由听闻言说为门而生。即染著於其馀。由此二自性无所有故、不可取著。为显假说异名即是世俗故、说言“谓於世间色等想事所有色等种种假说名诸世俗”等。谓於此世俗中不执著有性、即说为“无见”。由是因缘名为“不著”。由无著故、都不能取故，即非有谁取之义。今解“取”者：或说由增益取，或说由损减取。以是能取彼实之时分故。如是由断颠倒见故、名具正见。由彼如实观见此所知境故，说名为“见”。由彼听闻所知境界言说故，说名为“闻”。为显“不生贪爱亦不增长”自性义故、说言“唯於彼缘毕竟断灭安住上捨”。言“不生”者：即是“毕竟断灭”。言“亦不增长”者：即是“安住上捨”。
    又“佛世尊为彼散他迦多衍那作如是说：散他比丘！不依於地而修静虑、不依於水、不依於火、不依於风、不依空处、不依识处、不依无所有处、不依非想非非想处、不依此世他世、不依日月光轮、不依见闻觉知、不依所求、所得、不依意随寻伺、不依一切、而修静虑。云何修习静虑比丘不依於地而修静虑、广说乃至不依一切而修静虑？散他比丘！或有於地、除遣地想，或有於水、除遣水想，广说乃至或於一切、除一切想。如是修习静虑比丘、不依於地而修静虑，广说乃至不依一切而修静虑。如是修习静虑比丘为因陀罗、为伊舍那、为诸世主、并诸天众遥为作礼而 赞颂曰：敬礼吉祥士！敬礼士中尊！我今不知汝依何修静虑？”云何此经显如是义？谓於一切地等想事、诸地等名施设假立，名地等想。即此诸想於彼所有地等想事或起增益、或起损减。若於彼事起能增益有体自性执、名增益想。起能损减唯事胜义执、名损减想。彼於此想、能正除遣，能断能捨，故名除遣。如是等类无量圣言、名为至教。由此如来最胜至教应知诸法离言自性。
    为显第三声闻相应教故、说言“不依於地而修静虑”等。谓有计执诸地是我、或我体即地，当说不如是於地执我及我所、而修静虑。如是水火及风亦尔应说。如是四大种句、即显不依欲界及色界而修静虑。无色界四处者、即由自名显示。欲界者、即於“此世”。色无色界者、即说“他世”。各别说“日月”者、谓虽於他世、亦现见故。言“见”等者、即显不依言说而修静虑。言“所求”等者、即显不依戏论而修静虑。为显不依之因故、说言“或有於地除遣地想”等。“除遣”者：即断离义。为显如是无依而修静虑比丘、为天梵等所应供养故，说言“因陀罗”等。为显依彼地想增益及损减为门故、说言“或起增益”等。“增益”者：即执著言说自性。“损减”者：谓拨无实有胜义真实事。为显除遣义故、说言“能断能捨”，故名“除遣”。
    问：若如是者，何因缘故、於一切法离言自性而起言说？答：若不起言说，则不能为他说一切法离言自性，他亦不能闻如是义。若无有闻，则不能知此一切法离言自性。为欲令他闻知诸法离言自性、是故於此离言自性而起言说。
    如是既善了知一切法离言自性已、由非以言说为自性故、虽依言说自性为门而作显示，然此离言自性、犹本远离言说显示。以超越一切语言所行境界故。若由言说说此自性者，乃是圣智等流教法所摄。以能随顺正智生起故。是故说言“若不起言说则不能为他说一切法离言自性他亦不能闻如是义”。以是自内所证故。“亦不能闻”者：以超越听闻所行境界故。由如是故、智亦不能知。以具有彼之境界智、是随顺教授而生故。若如是者，虽於非实妄起分别、然颇有分别随顺清净。以缘圣智等流为境界故。是故颂云：“虚妄分别虽虚妄，有非虚妄无分别。非分别、非无分别，此说一切所知境 。”此中“虚妄分别”者：谓非随顺解脱。“虽虚妄有非虚妄”者：谓能随顺善辨离言之能相。言“无分别”者：谓真实性、及出世间智。以无有无分别之能相故。“非分别非无分别”者：谓诸圣者所有出世间智、後得清净世间智。以是真实境故、能安立法能相故。
    又诸愚夫由於如是所显真如、不了知故，从是因缘八分别转；能生三事、能起一切有情世间及器世间。云何名为八种分别？一者、自性分别。二者、差别分别。三者、总执分别。四者、我分别。五者、我所分别。六者、爱分别。七者、非爱分别。八者、彼俱相违分别。云何如是八种分别能生三事？谓若自性分别、若差别分别、若总执分别、此三分别能生分别戏论所依分别戏论所缘事。谓色等想事为依缘故、名想言说所摄名想言说所显分别戏论。即於此事分别计度非一众多品类差别。若我分别、若我所分别、此二分别能生一切馀见根本及慢根本萨迦耶见、及能生一切馀慢根本所有我慢。若爱分别、若非爱分别、若彼俱相违分别，如其所应能生贪欲、瞋恚、愚癡。是名八种分别能生如是三事：谓分别戏论所依缘事、见我慢事、贪瞋癡事。当知此中分别戏论所依缘事为所依止、生萨迦耶见及以我慢。萨迦耶见我慢为依、生贪瞋癡。由此三事普能显现一切世间流转品法。
    若能了知如前所说真实性者，则断分别。分别若断，则逆生死流转。由如是故当说诸见真实者、即能得解脱。今者为显若不见真实、则为束缚因故，说言“由於如是所显真如不了知故”等，谓不了知诸法离言之能相。由未能如是见故，由远离真实智诸愚夫不见真实故，名为“从是因缘”。即由如是因义。“八种分别”者：谓依流转果因性、及流转所依因性、而为安立。此中流转果者：谓界、趣、及生所摄色等诸行。此果因者：谓三分别。流转所依者：谓无我见所对治分我见、及以彼为根本所有见，以此为依、贪瞋癡转、此所依因、即有五种分别。若如是者，即依法能相、法差别能相、总摄能相、总摄差别能相、及法差别、而说八种。由能生三事故，即能起一切有情世间、及器世界。若有分别以诸法自性为行相，是名“自性分别”。“差别分别”、亦复如是。若以缘总摄法为行相之分别、名为“总执分别”。於自相续行执著以我我所为行相之分别，是名我我所分别。於三受所依诸法随起以贪著、瞋恚及不思择为行相之分别，是名爱等分别。如是当知依所缘、及行相故、安立一切分别。即诸分别、名为“戏论”。是以计度为自性故。又即戏论所依、说名所缘。当说依彼前生诸业所感色等五蕴、能生起分别：谓如如彼诸分别生现行时、如是如是喜乐戏论、及从此生起戏论。是故三种分别即以戏论所依而能生起。复次为显依此诸事、昔时戏论习气所显分别生现行故，说言“名想言说所摄”等。“名想”者：谓於名起想，即具有以能取名之所相为其体性。由此为先、随起言说，名为“言说”。以经说云随所有想如是能起言说故。解说“名想言说所摄”者：即说“名想言说所显”言。言“分别戏论”者：即於无戏论事中取於色想乃至识想由寻伺生起之义。事体有差别故、说名“非一众多品类”。言“一切馀见根本”者：谓为彼萨迦耶见外、馀边执见等根本。又即此萨迦耶见能增长我慢，由此分别彼得生起。复依於彼而得生起，由此我慢能生慢等。又由此慢能生一切馀慢，是名“根本”。言“如其所应”者：谓於此中或如次应知；或说若处有贪著生起，即於是处、亦有瞋恚生起，如义而生。今当分别三事：第一、依於分别。第二、即见於此等生起我慢。第三、以此为依贪瞋癡转。为显三事更互为依之义故、说言“当知此中分别戏论”等。言“一切世间”者：谓一切器世间、及有情世间。
    云何名为自性分别？谓於一切色等想事、分别色等种种自性所有寻思，如是名为自性分别。云何名为差别分别？谓即於彼色等想事谓此有色、谓此无色，谓此有见、谓此无见，谓此有对、谓此无对，谓此有漏、谓此无漏，谓此有为、谓此无为，谓此是善、谓此不善、谓此无记，谓此过去、谓此未来、谓此现在。由如是等无量品类差别道理、即於自性分别依处分别种种彼差别义，如是名为差别分别。云何名为总执分别？谓即於彼色等想事我、及有情、命者、生者等、假想施设所引分别，於众多法总执为因、分别而转，於舍、军、林、饮、食、衣、乘等假想施设、所引分别，如是名为总执分别。云何名为我我所分别？谓若诸事有漏、有取、长时数习我我所执之所积聚，由宿串习彼邪执故，自见处事为缘、所生虚妄分别，如是、名为我我所分别。云何名为爱分别？谓缘净妙可意事境所生分别。云何名为非爱分别？谓缘不净妙不可意事境所生分别。云何名为彼俱相违分别？谓缘净妙不净妙可意不可意俱离事境所生分别。
    言色者：谓由所取所显分别，即是色自性分别。如色，如是、所馀亦尔。当知由诸自性安立所摄、名为“差别分别”。为显依於自性分别随逐彼转、名为差别分别故。复说“即於自性分别依处”等。为显执多作一所有分别、名为“总执分别”故。及显外处之事故、说言“舍军”等。由随熏习有漏种子故，名为“有漏”。所以者何？以有取故。为取所依处故。言“数习”者：谓於俱生萨迦耶见中、周遍计度而起执著。由“积聚”时、亦即可明知“宿串习彼邪执”。言“自”者：谓自相续。言“虚妄分别”者：谓增益行相性。言“缘净妙可意事境”者：即缘可意事为境之义。
    此中所说、略有二种：一者、分别自性。二者、分别所依分别所缘事。如是二种无始世来应知展转更互为因。谓过去世分别为因、能生现在分别所依及所缘事。现在分别所依缘事既得生已、复能为因生现在世由彼依缘所起分别。於今分别不了知故、复生当来所依缘事。彼当生故、决定当生依彼缘彼所起分别。
    於此一切杂染品类、由所取及能取差别故，安立二种。或由染污智、及所知境差别、安立如是二种。当说前际不可知故、说为“无始世来”。由更互为果故，即说现法、及以後法。是故说言“过去世分别”等。为显唯以不了知分别为戏论所依之因、非是了知为因故，说言“於今”等。“今”者：谓此世。於分别不了知”者：谓不见真实。由此、复为彼所依缘事生起之因。由彼生故、分别复起。如是即说更互为果。
    云何了知如是分别？谓由四种寻思、四种如实智故。云何名为四种寻思？一者、名寻思。二者、事寻思。三者、自性假立寻思。四者、差别假立寻思。名寻思者：谓诸菩萨於名、唯见名，是名名寻思。事寻思者：谓诸菩萨於事、唯见事，是名事寻思。自性假立寻思者：谓诸菩萨於自性假立、唯见自性假立，是名自性假立寻思。差别假立寻思者：谓诸菩萨於差别假立、唯见差别假立，是名差别假立寻思。此诸菩萨於彼名、事、或离相观，或合相观，依止名事合相观故、通达二种：自性假立、差别假立。
    为显断离如是能令流转生死分别所修方便故、说言“云何了知如是分别”等。谓了知分别、是无分别智所有加行，是故说言“四种寻思”等。此中如事而安立者、名为“寻思”。於所寻思事获得究竟决择者、名为如实智。於名如实思惟、或如理思惟者、名为“名寻思”。当知其馀寻思、亦如是说。言“於名唯见名”者：谓远离事之名。此中即是由慧加行见非彼事自性之义。远离名之事者、谓非彼名自性故。唯见圆成实之事者、名为“事寻思”。唯见自性假立及唯见差别假立者、名为此二寻思。若如是如是寻思者，则见名事相离相。若相离者，当说此事之名於馀不得转故、亦应如是了知随顺转能相。由依此二合相观故，亦复当知自性假立、及差别假立。
    云何名为四如实智？一者、名寻思所引如实智。二者、事寻思所引如实智。三者、自性假立寻思所引如实智。四者、差别假立寻思所引如实智。云何名寻思所引如实智？谓诸菩萨於名寻思唯有名已、即於此名如实了知：谓如是名、为如是义、於事假立，为令世间起想、起见、起(假)言说故。若於一切色等想事、不假建立色等名者，无有能於色等想事起色等想。若无有想，则无有能起增益执。若无有执，则无言说。若能如是如实了知，是名名寻思所引如实智。云何事寻思所引如实智？谓诸菩萨於事寻思唯有事已、观见一切色等想事性离言说，不可言说。若能如是如实了知，是名事寻思所引如实智。云何自性假立寻思所引如实智？谓诸菩萨於自性假立寻思唯有自性假立已、如实通达了知：色等想事中所有自性假立非彼事自性，而似彼事自性显现。又能了知彼事自性犹如变化、影像、响应、光影、水月、 焰火、梦幻、相似显现而非彼体。若能如是如实了知最甚深义所行境界，是名自性假立寻思所引如实智。云何差别假立寻思所引如实智？谓诸菩萨於差别假立寻思唯有差别假立已、如实通达了知色等想事中差别假立不二之义：谓彼诸事非有性、非无性。可言说性不成实故、非有性。离言说性实成立故、非无性。如是由胜义谛故、非有色。於中无有诸色法故。由世俗谛故、非无色。於中说有诸色法故。如有性无性、有色无色，如是有见无见等差别假立门、由如是道理一切皆应了知。若能如是如实了知差别假立不二之义，是名差别假立寻思所引如实智。
    若如是者，当知四寻思即是四智加行。若名事相离者，则能了知如是二种相合所为、是名第一如实智。是故说言由此、如是、於名如实了知。若由极相离故、诸佛菩萨善知此事之名唯即是名远离彼事者，则此当说乃至言说随起名等生起次第。由名以起想为能相故。言起想者：意谓由名及相(即原由)、能表彼事之义。当说如其所想起执著故、说言“起见”。当说如所执著、如是能起言说故，说言“起言说”。此若无者，随应起名之想应不起故，说言“若於一切色等想事”等。若无有想，则於诸事应不能表。表若不成，则於假立亦应不起执著。若无执著则自於义不能定知、亦不能生起他人决智。如是当说无教无闻。若尔，能知安立名之智、名为“名寻思所引如实智”。若彼於事寻思唯有事者，则言说不杂、即不相应。唯见远离言说之事、是名第二智。圆成实及事自性虽实，而非彼之自性。谓能了知观见犹如变化、影像、似彼自性显现，是名第三智。是故说言“彼事自性、犹如变化”等。谓如变化、及影像、似彼行相而变化，如是当知彼事行相亦如影像、以遍计所执为自性。如是影像等一切如应当知。观见遍计所执之自性空寂(即杳离)，是即说名“最甚深义所行境界”。诸法差别者：谓分位差别所摄性。观见差别无二之相、名为第四智。应知自性亦是无二之能相。若如是者，为由显示此彼差别故、及显示别异故。唯於差别假立寻思中说无二能相、为由根本句所说无二性非有非非有言、解此远离有无故，说言“谓彼诸事非有性非无性”等。谓由愚夫遍计所执自性绝不成为实故、说名“非有性非无性”者：谓由无分别智所行境界、现前远离言说性故。如是色等亦非有。以於胜义中色法非有功能成办变坏故。色亦非无，以於世俗说有手等触所触受故。是故说言“说有诸色法故”。如是於“有见”等、亦由此理当知。
    愚夫於此四如实智有所阙故，不现前故，便有八种邪分别转、能生三事、能起一切有情世间及器世间：谓由如是邪分别故起诸杂染。起杂染故、流转生死。於生死中常流转故、恒有无量随逐生死种种生老病死等苦流转不息。
    为显若彼无如实智者，能生分别所有苦戏论故；说言“愚夫於此四如实智有所阙故不现前故便有八种邪分别转”等。为显分别是杂染因故、说之为“邪”。由诸生死以烦恼为根本故，由杂染遍能生起生死。又由生死一向一味苦故，苦生苦转。
    菩萨依此四如实智能正了知八种分别，於现法中正了知故、令当来世戏论所摄所依缘事不复生起。不生起故、於当来世从彼依缘所起分别亦不复生。如是分别、及依缘事、二俱灭故，当知一切戏论皆灭。菩萨如是戏论灭故，能证大乘大般涅槃。
    如是且显分别为根当生诸苦已、今者为显断分别尽苦亦随灭故，说言“菩萨依此”等。由断分别、戏论亦灭故，不住生死。由勤修行成熟佛法及成熟有情种种加行差别故，不住涅槃。如是由大乘无住涅槃故，说名能证大般涅槃。
    於现法中胜真实义所行处智极清净故，普能获得一切自在：谓诸菩萨於种种化获得能化神通自在，於种种变获得能变神通自在，普於一切所知境智皆得自在。若欲久住随其所乐自在能住。若欲终殁，不待害缘、自在能殁。由诸菩萨得如是等无量自在、於诸有情最胜无上。
    所知障净智所行真实者、名为“胜真实义”。若智以此真实为所行境，说名所知障解脱智。此“智极清净”者：当知八地以上。“获得一切自在”者：略说即於外处事、及於内自体。如是於诸外处事、复得二种自在：一者、生起非现有事。如说“於种种化”等。二者、令现有事转变。如说“於种种变”。於内自体、亦有二种：一者、由加持寿故，随其所乐自在能住。如说“若欲久住随其所乐”等。二者、随所欲乐作思惟已、不待害缘得自在命终故，即随意捨寿。如说“若欲终殁不待害缘自在能殁”。此於一切获得自在菩萨、一切有情众中最为尊胜。
    菩萨如是普於一切得自在故，获得五种最上胜利：一者、获得心极寂静。由住最静故。不由烦恼寂静故。二者、能於一切明处无所罣碍，清净鲜白、妙智见转。三者、为利诸有情故流转生死无有厌倦。四者、善入一切如来密意言义。五者、所得大乘胜解不可引夺不从他缘。当知如是五种胜利有五种业：一者、菩萨成就最胜现法乐住，能灭一切为趣菩提精勤加行所生身心种种劳倦。当知是名心极寂静胜利之业。二者、菩萨普能成熟一切佛法。当知是名於诸明处无碍清白、微妙智见胜利之业。三者、菩萨普能成熟一切有情。当知是名流转生死无有厌倦胜利之业。四者、菩萨能正除遣所化有情随所生起一切疑惑，护持如来妙正法眼令得久住。於能隐没如来圣教像似正法、能知能显能正除灭。当知是名善入如来密意言义胜利之业。五者、菩萨能摧一切外道异论精进坚牢正愿无动。当知是名大乘胜解不可引夺不从他缘胜利之业。如是菩萨所有一切菩萨所作、皆为如是五胜利业之所摄受。云何一切菩萨所作？谓自安乐而无杂染，普能成熟一切佛法，普能成熟一切有情，护持如来无上正法，催伏他论、精进勇猛、正愿无动。
    如是获得自在菩萨、如此中说有五种最胜所摄胜利：一者、由於烦恼不极寂静时、亦极寂静故，此住於最胜住所得极寂静、即能生起声闻等所无烦恼寂静胜利。二者、以能得声闻等所无究竟一切明处中所知境智为其胜利。三者、不由诸生死流转及有情颠倒行故，利益一切苦及杂染诸有情而有厌倦。四者、由成就殊胜念俱生智慧故，於善入一切如来所有密意言语具有堪能。五者、由不退转性故，所得胜解不可引夺。虽为一切他论所反，然亦不可引夺、不捨精勤修学。是故说言“不从他缘”。谓不随他言而转。由具如是五胜利故，即能作五胜利业：第一胜利谓由安住殊胜离染现法乐故、心极寂静。由如是离染寂静住故，能作四事：一者、依自利益而说能成熟自相续，是故说言“普能成熟一切佛法”。二者、作他利益即能成熟他相续，是故说言“普能成熟一切有情”。三者、由於密意言句得善巧故，即能护持正法。今当分别此义：谓能断一切有情随所生起一切疑惑、及能令三宝传续不绝。如是即说由於如来所说一切经教作诸听闻、受持相应诸业故，能断正听闻事、正奉受事、及令久住事相违诸障。言“像似正法”等中、“像似正法”者：谓正法影像。如《摄事分》(《瑜伽师地论》卷九十九中)中说。又说此为“能隐没如来圣教”者：谓能障正教而转。由此非是正法且为正法影像故，当说为彼相违障分。能知者：谓能辨别。如是复为他说、名为“能显”。如是知已、即能断彼，名为“能正除灭”。能破他人所说正法相违诸障、是为第四事。由不捨离、不从他缘、不可引夺、加行，乃能成就精进坚牢、及正愿坚固故，为显一切菩萨所作皆堕此五中摄故，说言“所有一切菩萨所作”等。
    当知如是四真实义、初二下劣，第三处中，第四最胜。
    为显安立四种真实为下中上三品故、说言二种“下劣”。以是世间智所行境界故，及非烦恼及所知障能对治分故。“第三处中”、以是无漏故，及能对治烦恼障故。“第四最胜”、以是二障能对治分故。


瑜伽师地论摄决择分所引解深密经慈氏品略解

    瑜伽师地论摄决择分所引解深密经慈氏品略解
    智藏论师造
    韩镜清译藏为汉

    敬礼圣慈氏！

    复次依法假安立、分别解说瑜伽所摄奢摩他毗钵舍那道，当知如解深密经中、
    言“依法假安立分别解说瑜伽所摄奢摩他毗钵舍那道”者：谓由五种因缘故，决择所假安立法、以显瑜伽道：一、由自性故。二、由加行因故。三、由得故。四、由得方便故。五、由不退失故。此中“瑜伽所摄”者：即显奢摩他、毗钵舍那道自性。此言“瑜伽”者：意谓戒蕴。此奢摩他、毗钵舍那道、即以戒蕴所摄定蕴、慧蕴、为其自性。於此分别解说、当知即是自性等门。或“瑜伽”者：即是道理(或正理)。随应当说四道理所摄奢摩他、及毗钵舍那道。言“解深密”者：即由解明甚深密意故，能断烦恼障及所知障坚固结义。言“经”者：是显了无馀说故。
    慈氏菩萨白佛言：世尊！菩萨何依、何住、於大乘中修奢摩他毗钵舍那？佛告慈氏菩萨曰：善男子！当知菩萨法假安立、及不捨无上正等觉愿、为依，为住，於大乘中修奢摩他、毗钵舍那。
    “慈氏菩萨白佛言”者：以此奢摩他毗钵舍那道是傍近大菩提之因故，圣慈氏是傍近大菩提人故，今白佛言。如是已解奢摩他毗钵舍那道自性。由“世尊菩萨何依何住”等言、问加行因。加行因者：依所依、住持、及所缘、显示。言“善男子当知菩萨法假安立及不捨无上正等觉愿为依为住”者：谓以奢摩他毗钵舍那之所依为加行因缘、显示加行因。“法假安立”者：以是所说法聚故。即所依因。“无上正等觉”者：是所证法身故。於中“愿”者：即为住持因。以愿为能引一切大菩提法之前行故。
    世尊！如说四种所缘境事：一、有分别影像所缘境事。二、无分别影像所缘境事。三、事边际所缘境事。四、所作成办所缘境事。於此四中、几是奢摩他所缘境事？几是毗钵舍那所缘境事？几是俱所缘境事？善男子！一是奢摩他所缘境事，谓无分别影像。一是毗钵舍那所缘境事，谓有分别影像。二是俱所缘境事：谓事边际、所作成办。
    今问“世尊如说四种所缘境事”等言、即由所缘显示加行因。言“一有分别影像所缘境事二无分别影像所缘境事三事边际所缘境事四所作成办所缘境事”中、“影像”者：即相似义。此影像谁所有耶？谓心之所有。一切显现、即此心体故。现前对向中所缘者、名为有分别影像。内自所摄者、名为无分别影像。“事”者：谓阿赖耶识。以有依有缘心心所法因事、果事、依彼转故。以能竭尽彼边际故、名为“事边际”。即转依法身之义。“所作成办”者：由能成办自他事故。显於一切所知无著无碍智见转者、名为“所作成办”。言“於此四中”等者：问此四所缘中、何道能缘几所缘境。言“善男子一是奢摩他所缘境事谓无分别影像”者：显奢摩他所缘。以奢摩他是内门转故。即内自所摄。由问“几是毗钵舍那所缘境事”等、今答言“一是毗钵舍那所缘境事谓有分别影像”者：显毗钵舍那所缘。以於所缘境流散为性、取所相故。问言“几是俱所缘境事”、答言“二是俱所缘境事”。云何为二？言“谓事边际所作成办”者：由此二以断、及智、为自性故，说为奢摩他毗钵舍那双运道所缘境。是究竟果故。
    世尊！云何菩萨依此四种奢摩他毗钵舍那所缘境事、能求奢摩他，能善毗钵舍那？善男子！如我为诸菩萨所说法假安立：所谓契经、应颂、记别、讽诵、自说、因缘、譬喻、本事、本生、方广、希法、论议。菩萨於此善听、善受、言善通利、意善寻思、见善通达。即於如所善思惟法、独处空閑作意思惟，复即於此、能思惟心内心相续作意思惟。如是正行多安住故，起身轻安、及心轻安、是名奢摩他。如是、菩萨能求奢摩他。彼由获得身心轻安为所依故，即於如所善思惟法内三摩地所行影像观察、胜解，捨离心(所)相。即於如是三摩地影像所知义中、能正思择、最极思择、周遍寻思、周遍伺察、若忍、若乐、若慧、若见、若观，是名毗钵舍那。如是、菩萨能善毗钵舍那。
    已解奢摩他毗钵舍那道自性、及加行因，今者为显菩萨云何能求奢摩他、及云何能善毗钵舍那故、说言“世尊云何菩萨依此四种奢摩他毗钵舍那所缘境事能求奢摩他能善毗钵舍那”，谓问此二获得。由奢摩他以热恼平息为性故，是菩萨所应求。由毗钵舍那以诸法最极决择为性故，是菩萨所应善。为显此故、说言“善男子如我”等。言“法假安立”者：谓总显即由名身、句身、文身假立、能总安立诸法。“契经”等者：谓差别说。即於此总、别所说契经等中、“善听、善受、言善通利、意善寻思、见善通达”。云何得为奢摩他加行因耶？是故说言“独处空閑”等。“独处”者：谓身空閑故。“空閑”者：谓心空閑故。谓由此心能作意思惟诸法，即以此心成为彼法自性；为显此故、说言“如是正行多安住故”等。“身轻安”者：谓身空閑所生。“心轻安”者：谓心空閑所生。复次由获得如所说能对治法作意思惟、则能抑制修所断烦恼故，名身轻安。由能抑制见所断烦恼故，名“心轻安”。由身无劳倦故，心无热恼故，即此身心轻安、说名奢摩他。言“如是”等者：即能定说菩萨唯由胜解、作意思惟、能求奢摩他，非由此馀。又唯显彼菩萨能善毗钵舍那故、说言“彼由获得身心轻安”等。言“彼”者：即彼菩萨。谓由彼菩萨依住所得身轻安、心轻安、为因缘故。言“如所善思惟法”者：谓无颠倒作意思惟。言“即”者：谓即前所说。言“内”者：谓非为外。“三摩地所行影像”者：即定心所现影像诸法。於此“观察”者：即生起最极思择。“胜解”者：即能决了。於证得位无行相法、与有行相心、和一而转。云何应起观察、胜解耶？是故说言“捨离心(行)相”，以心行相是妄显现故。然三摩地、及慧、非大地法故，由常与心俱转。若无心行相者、云何此二转耶？由奢摩他即是三摩地、毗钵舍那即是慧故、此二若无者，云何能观察心影像诸法耶？此中瑜伽师云：若诸心、若诸三摩地、若诸慧、若诸法所有一切、於证得位非离心有别外境故，亦是如心无有自性。心无自性者：谓心之所有、无有心性。如《般若波罗蜜多经》云：“此心、无心，心性本净。”是故说言“捨离心(行)相”。言“三摩地所行影像”者：谓离心无外。言“如是”者：谓即彼等。言“所知义”者：谓所知无二义。言“能正思择”者：谓即观察。言“最极思择”等者：即是思择最极殊胜之异名。言“忍”者：即决了离言无二义法、心决定无起作性。言“是名毗钵舍那”中、“毗钵舍那”者：谓审知一切具有自能相共能相法故。即於此“见”、说名“毗钵舍那”。言“如是”等者：即能定说唯由如是体性菩萨能善毗钵舍那，非由此馀。
    世尊！若诸菩萨缘心为境内思惟心乃至未得身心轻安所有作意、当名何等？善男子！非奢摩他作意，是随顺奢摩他胜解相应作意。世尊！若诸菩萨乃至未得身心轻安、於如所思所有诸法内三摩地所缘影像作意思惟，如是作意、当名何等？善男子！非毗钵舍那作意，是随顺毗钵舍那胜解相应作意。
    已解奢摩他毗钵舍那获得，为问获得方便、故问言“世尊若诸菩萨缘心为境”等。言“缘心为境”者：显说缘能相为境。言“内”者：谓於非外、作意思惟。“未得身心轻安”者：谓加行位。如是作意、当名何等？说言“非奢摩他作意”。当说此作意、即与随顺奢摩他胜解相应。以是获得奢摩他方便故。言“世尊若诸菩萨乃至未得”等中、言“未得身心轻安”者：谓说身心不堪任故。言“於如所思所有诸法内三摩地所缘影像作意思惟”者：谓未到加行边际故。如是作意、当名何等？说言“非毗钵舍那作意”。以是获得毗钵舍那方便故。
    世尊！奢摩他道、与毗钵舍那道、当言有异？当言无异？善男子！当言非有异、非无异。何故非有异？以毗钵舍那能缘境心、为所缘故。何故非无异？有分别影像为所缘故。世尊！诸毗钵舍那三摩地所行影像、彼与此心当言有异？当言无异？善男子！当言无异。何以故？由彼影像、唯是识故。善男子！我说识所缘、唯识所现故。世尊！若彼所行影像、即与此心无有异者，云何此心还见此心？善男子！此中无有少法能见少法。然即此心如是生时、即有如是影像显现。善男子！如依善莹清净镜面、以质为缘还见本质，而谓我今见於影像、及谓离质别有所行影像显现；如是、此心生时相似有异三摩地所行影像显现。世尊！若诸有情自性而住缘色等心所行影像，彼与此心亦无异耶？善男子！亦无有异。而诸愚夫由颠倒觉於诸影像不能如实知唯是识、作颠倒解。
    此下、为令不退失故、当知多门决择假法。为令以此无分别智为依之三摩地不退失故、决择假法者，即说言“世尊奢摩他道与毗钵舍那道当言有异当言无异”等。此二、何故非有异耶？是故说言“以毗钵舍那所缘境心为所缘故”。奢摩他道与毗钵舍那道非有异。以毗钵舍那能缘境心、为所缘故。由奢摩他道唯以毗钵舍那能缘境心、为所缘故。所缘、及能缘、二者俱以心为自性故，非是有异。由问言“何故非无异”等、为显非无异性故，答言“有分别影像非(藏译及魏译均作“为”。此处传钞误为“非”字。)所缘故”。奢摩他道及毗钵舍那道有异。所以者何？以有分别具有所相为所缘故。此即当作是说：此二俱以心为自性故，是同一性。而由有分别、及无分别故，是相异性。为令证得无分别智不退失故、说言“世尊诸毗钵舍那三摩地所行影像彼与此心当言有异当言无异”。此即是问能缘心与所缘三摩地所行影像、二者为异否耶？答言“当言无异”。又问言“何以故”，为显成立因故、答言“由彼影像唯是识故”。由此当作是说：即唯此心自身现似影像为所缘境、与心非异。为显正理故、说言“我说识所缘唯识所现故”。“所缘”者：谓境界行相即心显现。此亦与了别识非异。俱时可得故(见分与相分同为自体分)。言“若彼所行影像即与此心”等者：谓容有外难：若能分别之所相是能作者、所分别影像是为所作业者，云何此二非是异耶？以於世间能作者、及所作业、现见异故。今为成立实非异性故、说言“善男子此中”等。初言“少法”、即谓能作者。次言“少法”、即谓所作业。若由是故只是一法、别无所有，即由此故、何谓能分别及所分别耶？何为能作者及所作业耶？实则心及心所法中、不显现各各极微故，亦无能作者及所作业言说。若作为和合者，则是世俗故、有所观待故。无力能故。复次、若都无有事具有依自起者，则唯由执著能作者、始能起诸作用。由执著能作者不应理故，则能作者、所作业、以及作用、均不应理。若尔，云何如是所取能取二分识体之心得以显现耶？是故说言：“然即此心如是生时、即有如是影像显现。”由此应作是说：由具有无始时来所取能取言说习气所熏诸识种子、如是诸识生起，即能显现所取能取行相。为显明此义、故说“如依善莹”等喻。由此当作是说：於镜面上虽无影像生起，然由迷乱本质能生起影像、自谓我今见於影像。於此有诸论者亦作是说：依於所依镜面、及本质所相、另有别实影像生起。若如是一切依缘生起、皆非实有者，云何应举此喻为例耶？此中答彼、当作是说：由彼本质及影像行相、离识无别实义故。云何无实义耶？以虽无实义，亦显现有识生起故。犹如过去、未来、及梦境等、虽无有义，然亦观见彼识生起。复次於同一境、依胜解力异了别识可得，是故定知唯即此心现似影像。譬如於河水等同一事中、彼诸傍生则现见自所依处行相：彼诸饿鬼则现见脓等行相。诸人则现见清水行相。诸天则现见以琉璃为质之大地体性。言“如是”等者：谓如本质及与影像二、虽无有异，而显现似异。决定俱时齐显现故。如是即能定说已成立所缘能缘二无异性讫。言“世尊若诸有情自性而住缘色等心”等中、“色等”者：谓青等物。言“心所行影像”者：谓於心上显现。言“自性而住”者：谓本然安住。言“彼”者：谓诸外间事体。“与此心亦无异”者：即依所谓业及烦恼等而知者，即业、烦恼、及馀七所有。此业尚未差别故、若由善不善及不动差别，亦摄三分。今即是问与不善业、及诸烦恼、为异？无异？答言“善男子亦无有异”。若尔，何故现似异耶？是故说言“而诸愚夫由颠倒觉於诸影像不能如实知唯是了别识作颠倒解”。由此当作是说：如彼愚夫未见真实、为眩翳所害故，实无外义、见彼实有。
    世尊！齐何当言菩萨一向修毗钵舍那？善男子！若相续作意、唯思惟心相。世尊！齐何当言菩萨一向修奢摩他？善男子！若相续作意、唯思惟无间心。世尊！齐何当言菩萨奢摩他毗钵舍那和合俱转？善男子！若正思惟心一境性。世尊！云何心(所)相？善男子！谓三摩地所行有分别影像毗钵舍那所缘。世尊！云何无间心？善男子！谓缘彼影像心奢摩他所缘。世尊！云何心一境性？善男子！谓通达三摩地所行影像、唯是其(了别)识，或通达此已、复思惟如性。
    问言“齐何当言菩萨一向修毗钵舍那”、答言“善男子若相续作意唯思惟心(所)相”等。言“无间心”中、“间”者：谓间隔。无有间隔、说名“无间”。即现对所缘义。言“齐何当言菩萨奢摩他毗钵舍那”中、“毗钵舍那”者：谓於所缘、心一境性。“奢摩他”者：谓内自心一境性。为问心之所相故、说言“云何心(所)相”。为显此故、说言“善男子谓三摩地所行有分别影像”等。谓毗钵舍那所缘三摩地所行有分别影像、是名心之所相。以能取所缘种种差别行相故。问言“世尊云何无间心”、答言“善男子谓缘彼影像心”等。谓内自转起缘彼影像之奢摩他所缘。此即说名无间心。以一切所缘皆内自摄故。问言“世尊云何心一境性”、答言“善男子谓通达三摩地所行影像”等。由此当作是说：於三摩地中心所显现诸法、与心非异。以彼诸法自性不得成立故。是故说言通达实际、即唯是了别识。言“通达”者：谓自内证知。言“或通达此已复思惟如性”中、“通达此”者：谓通达唯了别识性。通达此已、复证真如性者：谓唯了别识不留故、复圆满成就心一境性。以心所有真如性唯安住自界体故。
    世尊！毗钵舍那凡有几种？善男子！略有三种：一者、有(所)相毗钵舍那。二者、寻求毗钵舍那。三者、伺察毗钵舍那。云何有(所)相毗钵舍那？谓纯思惟三摩地所行有分别影像毗钵舍那。云何寻求毗钵舍那？谓由慧故，遍於彼彼未善解了一切法中为善了故、作意思惟毗钵舍那。云何伺察毗钵舍那？谓由慧故，遍於彼彼已善解了一切法中为善证得极解脱故、作意思惟毗钵舍那。世尊！是奢摩他凡有几种？善男子！即由随彼无间心故、当知此中亦有三种。复有八种：谓初静虑、乃至非想非非想处、各有一种奢摩他故。复有四种：谓慈、悲、喜、捨四无(能)量中各有一种奢摩他故。
    为问毗钵舍那故、说言“世尊毗钵舍那凡有几种”。为答此问故、说言“略有三种”。应思此三云何、是故说言“一者有(所)相毗钵舍那二者寻求毗钵舍那三者伺察毗钵舍那”。“有(所)相”者：谓闻所生。“寻求”者：谓思所生。“伺察”者：谓修所生。复次依彼诸所说所缘清净、道清净、无垢清净、自性清净四种清净中、由所缘清净所显者：是有所相。由道清净所显者：是寻求。由无垢清净所显、及由自性清净所显者：是伺察。复次於彼诸所说观待道理、作用道理、证成道理、法尔道理四种道理中、具有观待道理之能相及依作用道理之原由而转者：是所相生起。由证成道理生起寻求者、是寻求生起。由法尔道理伺察法性者、是伺察生起。问言“云何有(所)相毗钵舍那”、答言“谓纯思惟三摩地所行有分别影像毗钵舍那”。由此、当作是说：若毗钵舍那纯思惟彼所闻等有寻有伺三摩地所缘诸法清净所相之影像，是名所相生起。於问“云何寻求毗钵舍那”中、答言“谓由慧故遍於彼彼”等。言“遍於彼彼”者：谓遍於彼心影像自性等。言“谓由慧故遍於彼彼未善解了”中、“慧”者：谓道清净。即由此慧於彼未善缘得。缘於何等耶？故说言“法”。言“一切”者：即心中影像性。菩萨为极善解了、当所应作故，如是作意思惟之菩萨毗钵舍那、是名寻求。於问“云何伺察毗钵舍那”中、答言“谓由慧故遍於彼彼”等。言“遍於彼彼”者：谓遍於彼唯了别识性所显法中。言“由慧故”者：谓由出世间慧故。即遍於彼一切极善决了极善伺察所修习法中、即於无垢清净、及自性清净已善解脱所知境中、所生此智，由已断烦恼障得心解脱故、名无垢清净；由已断所知障得慧解脱故、名自性清净。由此极善圆满证得如实安乐故。如是作意思惟之毗钵舍那、是名伺察。於问“世尊是奢摩他凡有几种”中、答言“善男子即由随彼 无间心故”等。谓从此等至心无间所生毗钵舍那、说名无间心。言“当知此中亦有三种”者：谓依所相、寻求及伺察生起。由有三种毗钵舍那故、当知奢摩他亦有三种。由在内转起故、及微细故、世尊未说其能相。言“复有八种”等者：谓显示差别。即由静虑、无色差别、於内所摄亦有八种差别，故今说奢摩他亦有八种。言“复有四种”者：谓慈无量、悲无量、喜无量及捨无量。由心内转起故，由以害心等热恼平息为性故，今说此四、名奢摩他。
    世尊！如说依法奢摩他、毗钵舍那，复说不依法奢摩他、毗钵舍那；云何名依法？云何复名不依法？善男子！若随所受所思法(所)相、而於其义得奢摩他毗钵舍那，名依法。若不待於所受所思所有法(所)相，但依止他教诫教授、而於其义得奢摩他毗钵舍那；谓观青瘀、及脓烂等、或一切行皆是无常、或诸行苦、或一切法皆无有我、或复涅槃毕竟寂静，如是等类奢摩他毗钵舍那、名不依法。由依止法得奢摩他毗钵舍那故、我施设随法行菩萨是利根性。由不依法得奢摩他毗钵舍那故、我施设随信行菩萨是钝根性。
    又复为问奢摩他及毗钵舍那二者依法不依法差别故、说言“世尊如说依法奢摩他毗钵舍那”等。言随所受所思契经等法之所相中、“法(所)相”者：谓句、文等。言“而於其义”者：谓於义之原由。由此、当作是说：随顺所受所思契经等法所相已、而於其义得奢摩他及毗钵舍那，是名依法。以於法胜解、能随顺义故。言“不待於所受所思所有法(所)相”等者：谓未受契经等法。言“他”者：谓依他为缘、而非依自为缘力。言“教诫教授”者：谓当令晓悟所有言音、名为教授。若尔，从他听闻、亦唯依法。以随顺他所说法故！不尔、非由受持契经等法故而转，但由信故、待他缘故转。由於诸法无决择故、非是依法。言“谓观青瘀”等中、亦由信故，於他所论不复思择：若修习不净等奢摩他、及毗钵舍那者，由是加行所随顺故、非是依法。言“由依止法得奢摩他毗钵舍那故我施设”等者：谓此应作是说：利根随顺所闻所受诸法菩萨、由自慧力依法生起奢摩他毗钵舍那而修习故，如是菩萨後不逆转。言“由不依法得奢摩他”等者：谓此应作是说：钝根菩萨无有力能闻、受契经等法，但由於信、待他为缘而转；由是钝根故、彼可由他所引而转动故、非得坚固。
    世尊！如说缘别法奢摩他毗钵舍那、复说缘总法奢摩他毗钵舍那，云何名缘别法奢摩他毗钵舍那？云何复名缘总法奢摩他毗钵舍那？善男子！若诸菩萨缘於各别契经等法、於如所受所思惟法修奢摩他毗钵舍那，是名缘别法奢摩他毗钵舍那。若诸菩萨即缘一切契经等法集为一团、一积、一分、一聚、作意思惟，此一切法随顺真如、趣向真如、临入真如、随顺菩提、随顺涅槃、随顺转依、及趣向彼、若临入彼，此一切法、宣说无量无数善法。如是思惟修奢摩他毗钵舍那、是名缘总法奢摩他毗钵舍那。世尊！如说缘小总法奢摩他毗钵舍那、复说缘大总法奢摩他毗钵舍那、又说缘无量总法奢摩他毗钵舍那，云何名缘小总法奢摩他毗钵舍那？云何名缘大总法奢摩他毗钵舍那？云何复名缘无量总法奢摩他毗钵舍那？善男子！若缘各别契经乃至各别论议为一团等、作意思惟，当知是名缘小总法奢摩他毗钵舍那。若缘乃至所受所思契经等法为一团等、作意思惟，非缘各别、当知是名缘大总法奢摩他毗钵舍那。若缘无量如来法教、无量法句文字、无量後後慧所(应作“辩”是传抄误)照了、为一团等、作意思惟，非缘乃至所受所思、当知是名缘无量总法奢摩他毗钵舍那。世尊！菩萨齐何名得缘总法奢摩他毗钵舍那？善男子！由五缘故、当知名得：一者、於思惟时刹那刹那融消一切麤重所依。二者、离种种想得乐法乐。三者、解了十方无差别(行)相无量法光。四者、所作成满相应净分无分别(行)相恒现在前。五者、为令法身得成满故摄受後後转胜妙因。世尊！此缘总法奢摩他毗钵舍那、当知从何名为通达？从何名得？善男子！从初极喜地、名为通达。从第三发光地、乃名为得。善男子！初业菩萨亦於是中随学作意、虽未可 叹，不应懈废。世尊！是奢摩他毗钵舍那、云何名有寻有伺三摩地？云何名无寻唯伺三摩地？云何名无寻无伺三摩地？善男子！於如所取寻伺法(所)相、若有麤显领受观察诸奢摩他毗钵舍那，是名有寻有伺三摩地。若於彼(所)相虽无麤显领受观察，而有微细彼光明念领受观察诸奢摩他毗钵舍那、是名无寻唯伺三摩地。若即於彼一切法(所)相、都无作意领受观察诸奢摩他毗钵舍那，是名无寻无伺三摩地。复次、善男子！若有寻求奢摩他毗钵舍那、是名有寻有伺三摩地。若有伺察奢摩他毗钵舍那、是名无寻唯伺三摩地。若缘总法奢摩他毗钵舍那、是名无寻无伺三摩地。
    为问缘别法及缘总法差别故、说言“世尊如说缘别法奢摩他毗钵舍那”等。言“於如所受所思惟法”者：此即显示於彼以空性等为行相受持思惟契经等法、修习奢摩他毗钵舍那，说名缘别法奢摩他毗钵舍那。言“缘於各别契经等法”者：即以差别安立契经等法为所缘之义。言“若诸菩萨即缘一切契经等法”等中、言“此一切法”者：即前所说契经等。言“随顺真如”者：谓归服真如。言“趣向真如”者：谓崇尚真如。言“临入真如”者：即已悟入真如之义。由此等、言应如是说：此一切法即显示真如一味。言“真如”者：即本性清净法界之义。言“随顺菩提”等中、“菩提”者：谓出世间无分别智。言“随顺转依”等中、“依”者：谓一切佛陀法之所依。由地及波罗蜜多之力转得。“转依”者：即说名法身。言“此一切法宣说无量无数善法”者：即彼一切契经等法集为一处。言“善法”者：於证知分位、即以涅槃为自性之胜义善法。於言教分位、即以道为自性之善法。言“无量”者：谓无能量度、以无漏法界无分限故。言“无数”者：即前无能量、以超越数算故。言“宣说”者：谓以准确言说能诠表如是无漏法故。言“是名缘总法奢摩他毗钵舍那”者：谓缘总摄法奢摩他毗钵舍那。为问诸缘总法小、大、及无量差别故，说言“世尊如说缘小总法奢摩他毗钵舍那”等。言“善男子若缘各别契经”等者：谓应作是说：於随一所受契经等法初、中、後分，集为一团作意思惟奢摩他毗钵舍那，当知是名缘小总法。以非缘一切法为境故。“若缘乃至所受所思”等者：谓於彼一切契经等法各别集为一类、作意思惟，当知是名缘大总法奢摩他毗钵舍那。以缘契经等中一切法为境故。言“若缘无量如来法教”等者：谓应作是说：由是一切所缘如来教故，能实使一切处一切时一切所调伏众生所有意乐、皆欢喜满足而转，故说无能量、无能量法句、文字及无能量後後慧及辩才所照了、亦复如是。言“为一团”者：即由诸法之法自性不可得故，即能遍一味总缘奢摩他毗钵舍那、当知是名缘无量总法之义。言“世尊菩萨齐何名得”等者：谓请问得彼之因缘。言“一者於思惟时刹那刹那融消一切麤重所依”中、“麤重”者：有二种：一者、贪等烦恼麤重。二者、以见为行相之烦恼麤重。“麤重所依”者：即是阿赖耶识。此缘总法奢摩他毗钵舍那能对治此二麤重故，说名能消灭麤重所依。言“二者离种种想得乐法乐”者：谓由远离麤重之障故，由身心轻安获得乐彼远离种种想之法乐。言“三者解了十方无差别(行)相无量法光”者：谓极善照了无量法故。言“四者所作成满相应净分无分别(行)相恒现在前”者：谓由清除以补特伽罗及法为行相之见故，是一切智性能圆满自他利益因故，名为成满所为。尔时彼净分、即是证知分位，任运恒遍生起随顺彼净分之所相，即诸无分别所相自然现前。言“五者为令法身得成满故摄受後後转胜妙因”者：谓於初地、名证法身。於三地中、名获得。於十地中、名为圆满。於如来地、名为圆成。已至究竟故。言“因”者：谓由修习地及波罗蜜多故，能得出离。言“後後转胜妙”者：谓前证知、後获得，与前获得、後圆满，及以前圆满、後圆成，後後诸法、益转胜妙。复次为问此二差别故、说言“世尊是奢摩他毗钵舍那”等。言“有寻有伺三摩地”中、谓心麤性名为寻，心细性名为伺。言“於如所取”等中、言“(所)相”者：谓如所受持所寻伺契经等法所相可得。即此随顺麤显领受之伺察所有奢摩他毗钵舍那、是名有寻有伺三摩地。言“若於彼(所)相”等中、由言“彼”者：即取如所受持所寻伺契经等法之所相，此即当说以於此中由无有寻故，无麤显所相。若奢摩他毗钵舍那随顺微细领受唯有显现彼所相梗概忆念之伺察，是名无寻唯伺三摩地。言“若即於彼一切法(所)相”等中、“若即於彼一切法(所)相都无作意”者：谓此当说心相续一律故、寻伺寂静故、无有所受持契经等法所相，唯有任运领受诸法之作意而伺察故，即此奢摩他毗钵舍那、名为无寻无伺三摩地。言“若有寻求”等者：谓此当说若於有寻有伺地中、寻求诸法世俗及胜义谛所生奢摩他毗钵舍那，是名有寻有伺三摩地。言“若有伺察奢摩他毗钵舍那是名无寻唯伺三摩地”者：谓於契经等法细伺察故。言“若缘总法奢摩他毗钵舍那是名无寻无伺三摩地”者：谓由缘一切法真如遍一味性、任运而转故。
    世尊！云何止相(即原由)？云何举相(即原由)？云何捨相(即原由)？善男子！若心掉举或恐掉举时、诸可厌法作意及彼无间心作意，是名止相(即原由)。若心沈没或恐沈没时、诸可欣法作意及彼心(行)相作意，是名举相(即原由)。若於一向止道、或於一向观道、或於双运转道、(应有“非”字传抄漏)二随烦恼所染污时、诸无功用作意及心任运转中所有作意，是名捨相(即原由)。
    言“世尊云何止相(即原由)”等者：为问止、举、捨相(即原由)故。言“善男子若心掉举”等中、“掉举”者：谓不寂静。言“恐掉举”者：谓流散意乐。言“诸可厌法”者：谓苦集行相。言“彼无间心”者：谓心不缘诸境。言“若心沈没”等中、“心沈没”者：谓由惛沈及睡眠所坏。言“恐沈没”者：谓随顺沈没。言“诸可欣法”者：谓灭道行相。言“彼心(所)相”者：即以一切能随顺善法为所缘之心所相义。已说止相(即原由)及举相(即原由)，为显捨相(即原由)故、说言“若於一向止道或於一向观道或於双运转道”。言“非二随烦恼所染污时”者：谓显三种道差别。(依魏译及此略解增“非”字)即於不为掉举恶作惛沈及睡眠所坏道中、心任运转时无功用作意，是名捨相(即原由)。
    世尊！修奢摩他毗钵舍那诸菩萨众知法、知义，云何知法？云何知义？善男子！彼诸菩萨由五种(行)相了知於法：一者、知名。二者、知句。三者、知文。四者、知别。五者、知总。云何为名？谓於一切染净法中所立自性(应有“差别”二字)想假施设。云何为句？谓即於彼名聚集中、能随宣说诸染净义依、持、建立。云何为文？谓即彼二所依止字。云何於彼各别了知？谓由各别所缘作意。云何於彼总合了知？谓由总合所缘作意。如是一切、总略为一，名为知法。如是、名为菩萨知法。善男子！彼诸菩萨由十种(行)相了知於义：一者、知尽所有性。二者、知如所有性。三者、知能取义。四者、知所取义。五者、知建立义。六者、知受用义。七者、知颠倒义。八者、知无倒义。九者、知杂染义。十者、知清净义。善男子！尽所有性者：谓诸杂染清净法中所有一切品别边际、是名此中尽所有性。如五数蕴、六数内处、六数外处、如是一切。如所有性者：谓即一切染净法中所有真如、是名此中如所有性。此复七种：一者、流转真如。谓一切行无先後性。二者、(能)相真如。谓一切法补特伽罗无我性、及法无我性。三者、了别真如。谓一切行唯是(了别)识性。四者、安立真如。谓我所说诸苦圣谛。五者、邪行真如。谓我所说诸集圣谛。六者、清净真如。谓我所说诸灭圣谛。七者、正行真如。谓我所说诸道圣谛。当知此中由流转真如、安立真如、邪行真如故，一切有情平等平等。由(所)相真如、了别真如故，一切诸法平等平等。由清净真如故，一切声闻菩提、独觉菩提、阿耨多罗三藐三菩提、平等平等。由正行真如故，听闻正法缘总境界胜奢摩他毗钵舍那所摄受慧、平等平等。能取义者：谓内五色处、若心、意、识及诸心法。所取义者：谓外六处。又能取义亦所取义。建立义者：谓器世界。於中可得建立一切诸有情界：谓一村田、若百村田、若千村田、若百千村田，或一大地至海边际、此百、此千、若此百千，或一赡部洲、此百、此千、若此百千，或一四大洲、此百、此千、若此百千，或一小千世界、此百、此千、若此百千，或一中千世界、此百、此千、若此百千，或一三千大千世界、此百、此千、若此百千，或此拘胝、此百拘胝、此千拘胝、此百千拘胝，或此无数、此百无数、此千无数、此百千无数，或三千大千世界无数百千微尘量等、於十方面无量无数诸器世界。受用义者：谓我所说诸有情类为受用故、摄受资具。颠倒义者：谓即於彼能取等义：无常计常想倒、心倒、见倒，苦计为乐，不净计净，无我计我想倒、心倒、见倒。无倒义者：与上相违。能对治彼、应知其(行)相。杂染义者：谓三界中三种杂染：一者、烦恼杂染。二者、业杂染。三者、生杂染。清净义者：谓即如是三种杂染所有离繫菩提分法。善男子！如是十种、当知普摄一切诸义。复次、善男子！彼诸菩萨由能了知五种义故、名为知义。何等五义？一者、遍知事。二者、遍知义。三者、遍知因。四者、得遍知果。五者、於此觉了。善男子！遍知事者：当知即是一切所知：谓或诸蕴、或诸内处、或诸外处、如是一切。遍知义者：乃至所有品类差别(所)应知境。或世俗故、或胜义故、或功德故、或过失故、缘故、世故、或生、或住、或坏(所)相故、或如病等故、或苦、集等故、或真如、实际、法界等故。或广、略故。或一向记故、或分别记故、或反问记故、或置记故。或隐密故、或显了故。如是等类、当知一切名遍知义。言遍知因者：当知即是能取前二菩提分法：谓诸念住、或正断等。得遍知果者：谓贪恚癡断毗奈耶、及贪恚癡一切永断诸沙门果、及我所说声闻如来若共不共世出世间所有功德於彼作证。於此觉了者：谓即於此作证法中诸解脱智、广为他说、宣扬开示。善男子！如是五义、当知普摄一切诸义。复次、善男子！彼诸菩萨由能了知四种义故、名为知义。何等四义？一者、心执受义。二者、领纳义。三者、了别义。四者、杂染清净义。善男子！如是四义、当知普摄一切诸义。复次、善男子！彼诸菩萨由能了知三种义故、名为知义。何等三义？一者、文义。二者、义义。三者、界义。善男子！言文义者：谓名身等。义义者：当知复有十种：一者、真实(能)相。二者、遍知(能)相。三者、永断(能)相。四者、作证(能)相。五者、修习(能)相。六者、即彼真实(能)相等品类差别(能)相。七者、所依能依相属(能)相。八者、即遍知等障碍法(能)相。九者、即彼随顺法(能)相。十者、不遍知等及遍知等过患功德(能)相。言界义者：谓五种界：一者、器世界。二者、有情界。三者、法界。四者、所调伏界。五者、调伏加行界。善男子！如是三义、当知普摄一切诸义。
    言“世尊修奢摩他毗钵舍那诸菩萨众知法知义云何知法云何知义”者：谓问法、义、自性、差别、由法是所依、义是能依故，世尊先说“善男子彼菩萨由五种(行)相了知於法”等、以告慈氏所依诸法差别。又法自性有二种别：一者、所说法。二者、所证法。由所说法是所证法根本故，及所说法又有名、句、文、别、总五自性故，说言“一者知名”等。言“云何为名谓於一切染净法中所立自性差别想假施设”(汉译本“自性”下、无有“差别”二字)中、“染”者：谓贪等。“净”者：谓信等。即於彼等说名为“贪”、说名为“信”者、是自性想假施设。若说“此贪是应知”、或说“是应断”者、则为差别想假施设。如是若说“此信是应修”、或说“是应习”者、亦为差别想假施设。如是、即名。言“云何为句谓即於彼名聚集中能随宣说诸染净义依持建立”者：谓如说言“当断欲、色、无色界贪”、即名聚集，宣示净义。聚集者、亦应如是说：谓若深信无诸有情而业果更互相属，如是即是善。言“云何为文谓即彼二所依止字”者：即名句所依为文之义。言“云何於彼各别了知谓由各别所缘作意”者：谓此当说能於名句文殊胜安布契经等法聚、各别受持。言“云何於彼总合了知谓由总合所缘作意”者：即说能於一切总合契经等法集为一聚而总受持。如修奢摩他毗钵舍那诸菩萨众所了知法、如是此上已说，今为显示由几种(行)相了知於义故、广说“善男子彼诸菩萨由十种相了知於义一者知尽所有性”等。言“善男子尽所有性者谓诸杂染清净法中所有品别边际是名此中尽所有性”中、“杂染”者：谓贪等。“清净”者：谓信等。即尽彼杂染及以清净所有一切数量品别边际、是名尽所有性。言“如”等者：谓诸蕴中、由五蕴可摄尽染净诸蕴无有增减故。由内六处、显示受者，由外六处、显示受用。言“如是一切”者：谓亦等取根等五数所摄。言“尽所有性”者：谓由彼尽其所有诸法故，即此所可有杂染及清净体性、说名尽所有性。言“如所有性者谓即一切染净法中所有真如是名此中如所有性”者：谓此应作是说：於观察一切染净诸法分位中可有如实无倒有性、是名如所有性。言“此复七种”者：谓复显差别。言“一者流转真如”中、谓烦恼业及生三者相续轮转者、名为流转。言“真如”者：谓即此行相、非馀，即显无颠倒自性。言“谓一切行无先後性”者：即显无有前际、及无後际。言“二者(所)相真如谓一切法补特伽罗无我性及法无我性”中、“一切法”者：谓有为、及无为。且於一切有为法中，一一极微无有补特伽罗我，一切心心所法亦无补特伽罗我。於一切无为法中、虚空择灭及非择灭皆无补特伽罗我，是故一切法非有所相、皆是补特伽罗无我性。言“三者了别真如谓一切行唯是(了别)识性”者：谓一切内事、外事、皆为内识所显故。言“四者安立真如谓我所说诸苦圣谛”中、“安立”者：谓於无我法中、安立世等。彼一切法、圣说谛实是苦。由所对治故。言“五者邪行真如谓我所说诸集圣谛”中、“邪行”者：谓以於无我法中我愚等为自性故，是惑引苦及生苦之因。言“六者清净真如谓我所说诸灭圣谛”者：谓此以顿灭一切虚妄分别为性故，名为清净。言“七者正行真如谓我所说诸道圣谛”中、“正行”者：谓是邪行对治故、即能息灭我愚等清净道。言“当知此中”等者：谓显彼诸真如殊胜道理。广说“由流转真如”等者：应说一切有情由能增长萨迦耶见熏习故、平等平等。言“由(所)相真如了别真如故一切诸法平等平等”者：谓一切法以补特伽罗无我为能相故、及是唯识所显故。言“由清净真如故”等者：显三种菩提、由清净真如故、平等平等、以彼等共同以灭为性故。若彼皆平等者，何因缘故唯佛陀解脱以法身为能相而遍与作有情利益而非声闻独觉所有解脱耶？谓佛陀解脱以先愿力故、示现种种，非声闻等解脱。犹如所缬衣及未缬衣、虽同入染器，然由缬力、诸所缬衣便有异杂染色可得、非诸未缬。如是虽彼同入涅槃染器，然佛涅槃由愿力故、唯现种种；非声闻等所有涅槃。是故今说彼等清净同性、乃依共有解脱(专就从烦恼障解脱而言，而不及其烦恼习气。参看《瑜伽师地论》卷五十八末。)非依法身。言“由正行真如故”等者，当说由能缘总所闻法奢摩他及毗钵舍那所摄慧平等平等，以慧能对治一切无明故。由正行真如平等平等同缘如所有性。依能取之义故、经说“能取义者谓五色处”等。“五色”者：即眼等五根以是色蕴所摄故。“若心意识及诸心法”、亦唯依能取之义说。“心”者：谓阿赖耶识。“意”者：谓染污意。“识”者：谓转识。“心法”者：谓受等。此诸一切、名为能取，以具有所缘为行相故。已说能取义，今依所取义故、经说“所取义者”等。言“六外处”者：谓诸色、声、香、味、触、法、是名所取。为显一切法是意识所取故、经说“又能取义亦所取义”。显所取义已、为显建立义故，经中广说“建立义者”等，言“谓一村田若百村田”等者：谓是生起无量世界因。已说建立义，为显受用义故、经说“受用义者”等。言“为受用故”者：谓男女承侍等受用故。言“资具”者：谓衣等。以诸各别了知於义菩萨、亦应须广分别一切故。已说受用义，次後为显颠倒义故、经说“颠倒义者”等。言“谓即於彼能取等义”者：谓即於前所说义。言“颠倒”者：谓诸谛相违见、即於无常等为性能取及所取诸缘起法中、增益常等，是名想倒。由想心二倒能等起见倒故、正见能断彼等。已说颠倒义，为显无倒义故、经说“无倒义者”等。言“与上相违能对治彼应知其(行)相”者：谓於能取等义诸无常法、见为无常，於苦为自性违圣诸法、见为苦，於不净自性诸法、见为非净，及於依缘而起於无我诸法、见为无我。由得对治能离见倒故、想心二倒亦随而断。已说无倒义，次後为显杂染义故、经说“杂染义者谓三界中三种杂染”等。为显何体所繫、经说“三界中”言。为显云何三种、经复说言“一者烦恼杂染二者业杂染三者生杂染”。谓於十二有支中无明、爱、取、是烦恼杂染，行、与有、是业杂染，识、名色、六处、触、受、生、老死、是生杂染。如是已说杂染义，为显清净义故、经说“清净义者谓即如是三种杂染所有离繫菩提分法”。当知即是念住等。言“善男子如是十种当知普摄一切诸义”者：谓诸菩萨由尽所有性等十行相能各别了知於义故，名为知义。复次为显五义差别故、经说“复次善男子彼诸菩萨由能了知五种义故名为知义”。问言：“何等五义？”答言：“一者、遍知事。二者、遍知义。三者、遍知因。四者、得遍知果。五者、於此觉了。”由此五种能遍摄故。言“善男子遍知事者当知即是一切所知谓或诸蕴”等中、以由蕴等能摄一切遍知事故。言“遍知义者乃至所有品类差别(所)应知境”者：谓乃至尽其所有品类差别应遍知、及如其所有应遍知、说名遍知义。广说“或世俗故”中、“或世俗故或胜义故”者：谓诸佛世尊依於二谛宣说法故。言“过失”者：谓说杂染过失故。言“功德”者：谓说清净功德故。言“缘”者：谓诸杂染及清净法、唯由自因而生，非由大自在天等。言“世”者：谓彼诸法堕在过去、未来、现在、三世中。言“或生或住或坏(所)相故”者：谓遍知义等由有为行相众缘所显故。言“或如病等故”者：谓於诸苦。言“或苦集等故”者：谓於声闻乘中。言“或真如”等者：谓於大乘中。言“或广略故”者：谓彼诸义或由略故、或由广故、宣说显示。若应记彼诸所问，亦由“一向记”等作诸答记；谓如有问言：“一切有情、皆当死耶？”则应一向记云：“当死。”“分别记”者：谓如有问言：“一切死者、皆当复生耶？”则应分别记云：“若彼有情是染污者、当再得生，若诸无染、不复生起。”“反问记”者：谓如有问言：“诸人为殊胜？抑为下劣耶？”则应反问彼等：“观待何者而问？”若观待恶趣而问者，则应答言：“彼等为胜。”若观待诸天而问者，则应答言：“彼等为劣。”如是即应反问而记。言“置记”者：谓如有问：“诸蕴与我为一为异？”如是则应置记，以我体实无故。言“隐密”者：谓於未成熟有情说甚深法故。言“显了”者：谓与上隐密相违故。言“如是等类”者：当知所馀假说补特伽罗等亦应遍知义。言“所有品类差别”者：即依世俗等行相故说。言“所应知”者：当知於声闻乘中依苦谛等故说。於大乘中、依真如等故说。言“言遍知因者当知即是能取前二”者：谓由缘蕴等遍知事、及其尽所有性如所有性遍知义、为境界故，即此念住等菩提分法能取、名为遍知。以智为自性故。说遍知已、为显得遍知果故、经说“得遍知果者”等。言“谓贪恚癡断毗奈耶”者：谓由自与俱有身、受、心、法、念住等故，能调伏贪等。言“一切永断”者：谓总束並断。言“诸沙门果”者：谓预流等四果。言“声闻如来若共不共世”者：谓静虑、无相等。言“出世间”者：谓尽、无生智等。言“共”者：谓无诤、愿智等。“於彼作证”者：即是得遍知果。说得遍知果已，为显於彼得遍知果觉了故、经说“於此觉了者”等。言“谓即於此作证法中”者：谓即无间所说法中。言“解脱智”者：谓自证智。言“广为他说宣扬开示”者：即自亲作证与如来共所有之功德、能令他相续解了义。经说“善男子如是五义当知普摄一切诸义”已、又由说“复次善男子彼诸菩萨”等、为显如由彼五行相能别别了知一切义，如是所说“由能了知四种义故名为知义”亦复尔故。问言“何等四义”、答言“一者心执受义二者领纳义三者了别义四者杂染清净义”等。“心执受义”者：谓阿赖耶识习气。以是因性故。“领纳义”者：谓即由此心生起我愚、我见、我慢、我爱、及领纳故。“了别义”者：谓缘外间一切转识。如是显示由唯了别识性变现所依、能依、及所缘种种差异事。“杂染清净义”者：谓即於此心等之一切心心所法所依、能依、及所缘等行相、未通达，或已通达。言“善男子如是四义当知普摄一切诸义”者：显总能摄一切义已。次说“复次善男子”等，即显示“彼诸菩萨由能了知三种义故名为知义”。言“一者文义二者义义三者界义”中、“文义”者：谓所依。“义义”者：谓能依。“界义”者：即二俱义。言“义义者当知复有十种”中、“真实(能)相”者：谓由所取性故。“遍知(能)相”者：谓由能取性故。“永断(能)相”者：谓由远离性故。“作证(能)相”者：谓由证得性故。“修习(能)相”者：谓由不退失道理故。“即彼真实(能)相等品类差别(行)相”者：谓由所说境真实、及显现真实等行相差别故。言“所依能依相属(能)相”中、“所依”者：谓真实等法。“能依”者：谓义。“即遍知等障碍法(能)相”者：谓障等。“即彼随顺法(能)相”者：谓善闻等。“不遍知等过患”者：谓能坏自他义利。“遍知等功德”者：谓能成满自他义利。言“言界义者谓五种界”中、“器世界”者：谓器世间所摄。以此是诸菩萨所应严净故。“有情界”者：谓是所应成熟故。“法界”者：谓是所应证知故。“所调伏界”者：谓是适可成熟器故。“调伏加行界”者：谓是善说事故。言“善男子如是三义当知普摄一切诸义”者：当知即是了义非了义无馀所摄故。
    世尊！若闻所成慧了知其义、若思所成慧了知其义、若奢摩他毗钵舍那修所成慧了知其义，此何差别？善男子！闻所成慧依止於文、但如其说、未善意趣、未现在前、随顺解脱、未能领受成解脱义。思所成慧亦依於文、不唯如说、亦善意趣、未现在前、转顺解脱、未能领受成解脱义。若诸菩萨修所成慧亦依於文、亦不依文、亦如其说、亦不如说、能善意趣、所知事同分三摩地所行影像现前、极顺解脱、已能领受成解脱义。善男子！是名三种知义差别。
    言“世尊若闻所成慧了知其义”等者：即问闻所成慧、思所成慧、及修所成慧、有何差别。言“善男子闻所成慧依止於文”中、“闻所成慧”者：谓唯依於文而起、非依於义。但如其说、未善意趣而能取者：以於甚深法未善审思故。“未现在前”者：以未现前亲证故。言“随顺解脱”者：谓能作解脱因。以由展转果能别别了知义故。非能解脱。言“思所成慧”等中、“思所成慧”者：谓依道理思惟所成。此慧亦依於文、不唯如说、亦善意趣而能取义者：谓已串习於闻故。“未现在前转顺解脱”者：谓是解脱缘性故。“未能领受成解脱义”者：谓未现前亲证解脱故。言“若诸菩萨修所成慧”中、“修所成慧”者：谓决择诸法所生。此慧亦依於文、亦不依文、而能取者：谓极串习故。亦如其说、能善意趣、而能取者：谓闻熏习已成熟故。言“所知事同分”者：谓与由尽彼种类而如实所应知事为同分。此体云何？说言“三摩地所行影像”。以非依闻思之言说所行境界、而别别了知故。“现前”者：谓内自证故。言“极顺解脱”者：谓逼近彼故。“已能领受成解脱义”者：谓已亲证故。言“是名三种知义差别”者：谓闻所成、思所成、及修所成慧三种。
    世尊！修奢摩他毗钵舍那诸菩萨众知法、知义、云何为智？云何为见？善男子！我无量门宣说智见二种差别。今当为汝略说其(行)相。若缘总法修奢摩他毗钵舍那所有妙慧、是名为智。若缘别法修奢摩他毗钵舍那所有妙慧、是名为见。
    於广说“世尊修奢摩他毗钵舍那诸菩萨众”等中、言“若缘总法修奢摩他毗钵舍那所有妙慧是名为智”者：谓非种种差别故。言“若缘别法修奢摩他毗钵舍那所有妙慧是名为见”者：谓是种种差别故。
    世尊！修奢摩他毗钵舍那诸菩萨众由何作意、何等、云何除遣诸(所)相？善男子！由真如作意除遣法(所)相及与义(所)相。若於其名及名自性无所得时、亦不观彼所依之(所)相，如是除遣，如於其名、於句、於文、於一切义、当知亦尔。乃至於界及界自性无所得时、亦不观彼所依之(所)相，如是除遣。世尊！诸所了知真如义(所)相、此真如(所)相亦可遣不？善男子！於所了知真如义中、都无有(所)相，亦无所得，当何所遣？善男子！我所了知真如义时能伏一切法义之(所)相，非此了达馀所能伏。世尊！如世尊说浊水器喻、不净镜喻、挠泉池喻、不任观察自面影(所)相。若堪任者，与上相违。如是若有不善修心，则不堪任如实观察所有真如。若善修心，堪任观察，此说何等能观察心，依何真如、而作是说？善男子！此说三种能观察心：谓闻所成能观察心、若思所成能观察心、若修所成能观察心。依了别真如作如是说。
    言“世尊修奢摩他毗钵舍那诸菩萨众”等中、“由何作意何等云何除遣诸(所)相”者：显三种问：谓了知法义诸菩萨众由何作意？所遣何(所)相？云何除遣？言“由真如作意”者：即於无二作意思惟之义。言“除遣法(所)相及与义(所)相”者：谓二种所相：即能除遣法之所相及与义之所相。言“(所)相”者：即所缘之义。为显云何除遣、说言“若於其名及名自性无所得时”等。由法之所相以名、句、文为自性故。亦不由彼所依观法。若如名法所依，如是句法之所相、以及文法之所相、亦除遣时、亦不随观。言“於一切义当知亦尔”者：谓於所说十种、或於五种、或於四种、或於三种亦不随观。言“乃至於界及界自性无所得时”者：谓若能除遣所说五界自性时、亦不随观。言“亦不观彼所依之(所)相”者：谓义所依之所相。由义所依即是法故，彼之所相若能除遣时、亦不随观，是故亦遣其义。即谓由真如作意是无二性故，由修习名、句、文法之所相及能取等所有一切义之所相真如中、以无二为行相故，即不随观彼等所相之义。言“世尊诸所了知真如义(之所)相”中，内自证知真如即一切行相智体。彼之所缘、即无有事体。如《般若波罗蜜多经》中说：“善现！一切行相智体所缘、即无有事体，行相寂静，增上缘即念，无有能相。”言“善男子我所了知真如义时能伏一切法义之(所)相”者：谓由一切法之所相、义之所相、即是虚妄分别故，由内自证知真如之义能对治彼故、即由此能伏彼之所相。言“非此了达馀所能伏”者：谓由见此、能对治一切所相故，所缘、及行相、不可分离故，非馀能伏。於广说“世尊如世尊说浊水器喻”等中、言“此说何等能观察心依何真如而作是说”者：谓有三种观察、及七种真如，故作是问。言“善男子此说三种能观察心”等者：谓当作是说：於闻所成能观察心、若思所成能观察心、若修所成能观察心中。依观察及了别真如是无二故，即依此意趣作如是说之义。
    世尊！如是了知法义菩萨为遣诸(所)相勤修加行、有几种(所)相难可除遣？谁能除遣？善男子！有十种(所)相、空能除遣。何等为十？一者、了知法义故，有种种文字(所)相。此由一切法空能正除遣。二者、了知安立真如义故，有生灭住异性相续随转(所)相。此由(所)相空、及无先後空、能正除遣。三者、了知能取义故，有顾恋身(所)相、及我慢(所)相。此由内空、及无所得空、能正除遣。四者、了知所取义故，有顾恋财(所)相。此由外空能正除遣。五者、了知受用义男女承事、资具相应故，有内安乐(所)相、外净妙(所)相。此由内外空、及本性空、能正除遣。六者、了知建立义故，有无量(所)相。此由大空能正除遣。七者、了知无色故，有内寂静解脱(所)相。此由有为空能正除遣。八者、了知(能)相真如义故，有补特伽罗无我(所)相、法无我(能)相、若唯(了别)识(能)相、及胜义(能)相。此由毕竟空、无性空、无性自性空、及胜义空、能正除遣。九者、了知清净真如义故，有无为(所)相、无变异(所)相。此由无为空、无变异空、能正除遣。十者、即於彼(所)相对治空性作意思惟故，有空性(所)相。此由空空能正除遣。世尊！除遣如是十种(所)相时、除遣何等？从何等(所)相而得解脱？善男子！除遣三摩地所行影像(所)相，从杂染缚(所)相而得解脱、彼亦除遣。善男子！当知就胜、说如是空治如是所相，非不一一治一切(所)相。譬如无明非不能生乃至老死诸杂染法，就胜、但说能生於行。由是诸行亲近缘故。此中道理、当知亦尔。世尊！此中何等空、是总空性(行)相，若诸菩萨了知是已、无有失坏於空性(行)相、离增上慢？尔时、世尊 叹慈氏菩萨曰：善哉善哉！善男子！汝今乃能请问如来如是深义、令诸菩萨於空性相无有失坏！何以故？善男子！若诸菩萨於空性(行)相有失坏者、便为失坏一切大乘！是故汝应谛听谛听、当为汝说总空性(行)相！善男子！若於依他起(能)相、及圆成实(能)相中、一切品类杂染清净遍计所执(能)相毕竟远离性，及於此中都无所得，如是、名为於大乘中总空性(能)相。
    今问世尊如是了知法义菩萨为遣诸所相、为伏一切法义之所相勤修加行、有几种所相难可除遣？谁能除遣？答言有“十种(所)相”等。言“一者了知法义故有种种文字(所)相此由一切法空能正除遣”者：谓离一切法空性外、无别所说种种文句所相之法故。言“二者了知安立真如义故有生灭住异性相续随转(所)相此由(所)相空及无先後空能正除遣”中、“住”者：谓堕在三世时诸行生、住、老、无常之能相。又此由所相无故、能相空。亦由所相无故、所相之能相亦空。由所相、及能相、远离一异故。如有颂云：“若能相所相异者，所相能相则俱无。若一，则无二事体。如是汝应如实说！”“无先後”者：谓前际後际无。於前际後际无中、无如实安立故。言“三者了知能取义故有顾恋身(所)相及我慢(所)相此由内空及无所得空能正除遣”中、“能取”者：谓眼等、及诸心心所法。若於此中、以我执及我所执之所相显现为补特伽罗，即此、由内空性及无所得空性能令空寂。以由彼自性不可得故。言“四者了知所取义故有顾恋财(所)相此由外空能正除遣”中、“所取”者：谓现似色等外境。彼等於一一极微、或和合中、皆空无有。虽以现似显色及形色境界为自性，而能作彼自性、则不应理故。言“五者了知受用义男女承事资具相应故有内安乐(所)相外净妙(所)相此由内外空及本性空能正除遣”中、“内安乐(所)相”者：谓邪受胜解。“外净妙(所)相”者：谓於男身女身邪胜解。此二相如梦境等邪胜解、亦是空寂。此内外二胜解之自性、亦空。由本来无生故。言“六者了知建立义故有无量(所)相此由大空能正除遣”者：谓所生成无量世界、如与虚空界相似，由大空性能令空寂故。言“七者了知无色故有内寂静解脱(所)相此由有为空能正除遣”者：谓随有一切有为都是空寂。由依藉因缘而生起故。言“八者了知(能)相真如义故有补特伽罗无我(所)相法无我(所)相若唯了别识(所)相及胜义(所)相此由毕竟空无性空无性自性空及胜义空能正除遣”者：谓若补特伽罗以无我为所相，由毕竟空性能空。由若实有补特伽罗者，则理亦应有补特伽罗可灭无故。若法以无我为所相，则由无性空性能空。由若实有诸法者，则理亦应有诸法可灭无故。若以唯了别识为所相者，则由无性自性空性能空。谓以迷乱为自性之了别识、唯是唯以无事体为自性。由两端都不成就故。若以胜义为所相者，由胜义空性能空。由所遮止、及能遮止、二非胜义故。所遮止无故、能遮止亦从来无实能破斥。是故如是离能证空性外、都无任何别胜义故。言“九者了知清净真如义故有无为(所)相无变异(所)相此由无为空无变异空能正除遣”中、“清净真如”者：谓灭谛。由此既是无为、无变异，如是所取无为及无变异二所相、由无为空性及无变异空性能正除遣。言“十者即於彼(所)相对治空性作意思惟故有空性(所)相此由空空能正除遣”者：谓若由空性智能正除遣一切所相者，即此亦空故。於广说“世尊除遣如是十种(所)相时”等中、“除遣三摩地所行影像(所)相”者：谓是能对治故。“杂染缚(所)相”者：谓是所对治分故。言“善男子当知就胜说如是空”等中、“非不一一治一切(所)相”者：即彼一切均缘清净为境界之义。言“世尊此中何等空是总空性(行)相”等者：为令不退失故、请求假说。由空性是诸菩萨不退失因、及增上慢能对治故。彼诸菩萨若能了知彼能相，则於大乘、不复退失。言“善哉善哉”等中、於空性(能)相有失坏者即於空性之能相不了知之义。言“便为失坏一切大乘”者：谓以空性宣扬故。言“是故汝应谛听谛听”等中、“依他起(能)相”者：谓凭藉因缘。“圆成实(能)相”者：谓无二相。言“一切品类杂染清净遍计所执(能)相毕竟远离性”者：谓若诸法凭因藉缘而起，即此等、为依他起能相。此由生无自性性故、是为空性。最极清净本性清净法，是圆成实能相。此由胜义空性、故空。若於依他起能相中、分别计执为杂染，及於圆成实能相中、分别计执为清净，如是遍计所执能相、由能相空性故空。言“於此中都无所得”者：谓於依他起自性中、遍计所执自性都不可得。由杂染自性、及清净自性、毕竟不成就故。由空性圆满至极成就性故。即是圆成实自性、法尔既非是一、又非是异，犹如所相及能相。言“如是名为於大乘中总空性能相”者：谓由世俗谛及胜义谛所摄三自性空故、是为总空性之能相。
    世尊！此奢摩他毗钵舍那、能摄几种胜三摩地？善男子！如我所说无量声闻、菩萨、如来、有无量种胜三摩地，当知一切皆此所摄。世尊！此奢摩他毗钵舍那、以何为因？善男子！清净尸罗、清净闻思所成正见、以为其因。世尊！此奢摩他毗钵舍那、以何为果？善男子！善清净心、善清净慧、以为其果。复次、善男子！一切声闻、及如来等、所有世间及出世间一切善法，当知皆是此奢摩他钵舍那所得之果。
    言“世尊此奢摩他毗钵舍那能摄几种胜三摩地”中、由请问言“世尊此奢摩他毗钵舍那以何为因”故，今答言“清净尸罗以为其因”者：谓尸罗清净时、能入等至。言“清净闻思所成正见以为其因”者：谓等至定中所有闻所成见、及思所成见、即是清净。已知奢摩他毗钵舍那因，为请问果故、说言“世尊此奢摩他毗钵舍那以何为果”。言“善清净心善清净慧以为其果”者：谓当作是说：“果”者：即是心解脱、及慧解脱。又由广说“复次善男子”等、决择奢摩他及毗钵舍那之果。
    世尊！此奢摩他毗钵舍那、能作何业？善男子！此能解脱二缚为业：所谓(所)相缚、及麤重缚。
    已显其果，为请问业故、说言“能作何业”。答言：“善男子此能解脱二缚为业”中、此二种缚为何等耶？故经复言：“所谓(所)相缚及麤重缚”。由依所取可染著等境界所相、能生起贪等烦恼，名为所相缚。於诸蕴中执著我、及我所事，名为麤重缚。从此二缚能得解脱、即是奢摩他及毗钵舍那之业。
    世尊！如佛所说五种繫中、几是奢摩他障？几是毗钵舍那障？几是俱障？善男子！顾恋身财、是奢摩他障。於诸圣教、不得随欲，是毗钵舍那障。乐相杂住、於少喜足，当知俱障。由第一故、不能造修。由第二故、所修加行不到究竟。世尊！於五盖中、几是奢摩他障？几是毗钵舍那障？几是俱障？善男子！掉举、恶作、是奢摩他障。惛沈、睡眠、疑、是毗钵舍那障。贪欲、瞋恚、当知俱障。
    言“世尊如佛所说五种繫中”等中、“顾恋身财”者：谓於诸内处、外处、贪著不捨。言“诸圣教”者：谓所听闻善正法教。言“乐相杂住”者：谓身不清閑。言“於少喜足”者：谓唯由世间静虑。言“由第一故不能造修”者：谓由身不清閑故、不能造修奢摩他及毗钵舍那。言“由第二故所修加行不到究竟”者：谓由於少喜足故、所修加行不到究竟。言“世尊於五盖中”等中、所谓“掉举恶作”中、“掉举”者：谓根不寂静。“恶作”者：谓恶所作事。即於未作善业、已作不善业、心生追悔。“惛沈”者：谓身心无堪任性。“睡眠”者：谓诸沈酣。“疑”者：谓於宝、谛、业果、迷乱不决。“贪欲”者：谓於五欲功德耽著。“瞋恚”者：谓於有情恚恨。
    世尊！齐何名得奢摩他道圆满清净？善男子！乃至所有惛沈、睡眠、正善除遣，齐是、名得奢摩他道圆满清净。世尊！齐何名得毗钵舍那道圆满清净？善男子！乃至所有掉举、恶作、正善除遣。齐是名得毗钵舍那道圆满清净。
    言“世尊齐何名得奢摩他道圆满清净”中、惛沈及睡眠者能令内沦没故。掉举、及恶作者、能令外散乱故。
    世尊！若诸菩萨於奢摩他毗钵舍那现在前时、应知几种心散动法？善男子！应知五种：一者、作意散动。二者、外心散动。三者、内心散动。四者、(所)相散动。五者、麤重散动。善男子！若诸菩萨捨於大乘相应作意、堕在声闻独觉相应诸作意中，当知是名作意散动。若於其外五种妙欲、诸杂乱、(所)相所有、寻思、(藏译有“烦恼”二字)随烦恼中、及於其外所缘境中、纵心流散，当知是名外心散动。若由惛沈及以睡眠、或由沈没、或由爱味三摩钵底、或由随一三摩钵底诸随烦恼之所染污，当知是名内心散动。若依外(所)相、於内等持所行诸(所)相作意思惟，名(所)相散动。若内作意为缘生起所有诸受、由麤重身计我起慢，当知是名麤重散动。
    以此奢摩他及毗钵舍那能摄一切三摩地故，而能障三摩地法者、即是心散动；是故此心散动为所应知、及所应断。为明此故、经中问言：“世尊若诸菩萨於奢摩他毗钵舍那现在前时应知几种心散动法。”言“一者作意散动二者外心散动”等者：谓当说已正趣入大乘菩萨於下劣乘作意散乱等、能障出世间无分别智所依三摩地故，是所应断。言“爱味三摩钵底”者：谓诸爱味静虑、无色、及三摩钵底者、能令生起长寿天中诸生，如是则能失坏有情利益事故。言“若依外(所)相”等者：谓当作是说：於因位中、若依所取爱及非爱所有外所相、住所居处思惟内心起所相，以此是无所相三摩地所对治分故，是所应知并所应断。言“若内作意为缘”等者：谓当说具有麤重所依身、是一切烦恼所依处故，能令散动。言“内作意为缘生起所有诸受”者：谓当说萨迦耶见相应之作意为缘所生有漏诸受、能随顺诸有故，及能违一切圣道故，名为麤重散动。
    世尊！此奢摩他毗钵舍那从初菩萨地乃至如来地、能对治何障？善男子！此奢摩他毗钵舍那於初地中对治恶趣烦恼、业、生杂染障。第二地中对治微细误犯现行障。第三地中对治欲贪障。第四地中对治定爱及法爱障。第五地中对治生死涅槃一向背趣障。第六地中对治(所)相多现行障。第七地中对治细(所)相现行障。第八地中对治於无(所)相作功用、及於有(所)相不得自在障。第九地中对治於一切种善巧言辞不得自在障。第十地中对治不得圆满法身证得障。善男子！此奢摩他毗钵舍那、於如来地对治极微细最极微细烦恼障及所知障。由能永害如是障故，究竟证得无著无碍一切智、见。依於所作成满所缘、建立最极清净法身。
    由奢摩他毗钵舍那、以三摩地及慧为自性故，为显一切地中均有故，经中问言：“世尊此奢摩他毗钵舍那从初菩萨地乃至如来地能对治何障。”言“善男子此奢摩他毗钵舍那於初地中对治恶趣烦恼业生杂染障”者：谓由能得补特伽罗见及法见对治智故。言“第二地中对治微细误犯现行障”者：谓由清净尸罗故。言“第三地中对治欲贪障”者：谓得不退静虑及三摩钵底故。言“第四地中对治定爱及法爱障”者：谓多住顺菩提分法故，及已灭种种契经等法所有慢故。言“第五地中对治生死涅槃一向背趣障”者：谓由修习四圣谛时、杂染清净之所依不可得故。言“第六地中对治(所)相多现行障”者：谓由奢摩他毗钵舍那行者多住缘起真如、则不观见杂染清净所相黑分白分真如故。言“第七地中对治细(所)相现行障”者：谓由随逐同一道法得无所相住故。言“第八地中对治於无(所)相作功用及於有(所)相不得自在障”者：谓安住无功用无所相修故，及严净佛陀国土故。言“第九地中对治於一切种善巧言辞不得自在障”者：谓圆满成就无碍辩解、及成熟有情事故，及有成熟一切种言辞威力(或威德)故。言“第十地中对治不得圆满法身证得障”者：谓三摩地门、及陀罗尼门、极清净故。言“於如来地对治极微细最极微细烦恼障及所知障”者：谓由无量三摩地门及陀罗尼门所充遍故，已得灌顶为佛体之菩萨所有极微细最极微细烦恼所知二障习气、唯佛能断故。言“由能永害如是障故究竟证得无著无碍一切智见”者：谓於一切所知不倾斜故、名为无著。若於是处、声闻等智有碍，即於是处、无有碍故；获得无碍慧及见。言“依於所作成满所缘”者：谓已得究竟自利他利故。言“清净法身”者：谓烦恼所知二障毕竟断故。言“建立最极清净法身”者：谓转一切所依故。
    世尊！云何菩萨依奢摩他毗钵舍那勤修行故、证得阿耨多罗三藐三菩提？善男子！若诸菩萨已得奢摩他毗钵舍那，依七真如、於如所闻所思法中由胜定心於善审定於善思量於善安立之真如性中内正思惟。彼於真如正思惟故，心於一切细(所)相现行尚能棄捨、何況麤(所)相！善男子！言细(所)相者：谓心所执受(之所)相、或领纳(之所)相、或了别(之所)相、或杂染清净(之所)相、或内(所)相、或外(所)相、或内外(所)相、或谓我当修行一切利有情(所)相、或正智(所)相、或真如(所)相、或苦集灭道(所)相、或有为(所)相、或无为(所)相、或有常(所)相、或无常(所)相、或苦有变异性(所)相、或苦无变异性(所)相、或有为异(能)相(所)相、或有为同(能)相(所)相、或知一切是一切已有一切(所)相、或补特伽罗无我(所)相、或法无我(所)相、於彼现行、心能棄捨。彼既多住如是行故，於时时间从其一切繫、盖、散动、善修治心。从是以後、於七真如有七各别自内所证通达智生，名为见道。由得此故，名入菩萨正性离生、生如来家、证得初地、又能受用此地胜德、彼於先时由得奢摩他毗钵舍那故、已得二种所缘：谓有分别影像所缘、及无分别影像所缘。彼於今时得见道故、更证得事边际所缘。复於後後一切地中、进趣修道。即於如是三种所缘作意思惟、譬如有人以其细楔出於麤楔，如是菩萨依此以楔出楔方便遣内(所)相故、一切随顺杂染分(所)相皆悉除遣。(所)相除遣故、麤重亦遣。永害一切(所)相、麤重故，渐次於彼後後地中如鍊金法陶鍊其心、乃至证得阿耨多罗三藐三菩提、又得所作成满所缘。善男子！如是菩萨於内止观正修行故、证得阿耨多罗三藐三菩提。
    为请问得方便故、经言“世尊云何菩萨依奢摩他毗钵舍那勤修行故”等。由奢摩他毗钵舍那是声闻菩提共有能作因故，今乃问言“云何证得阿耨多罗三藐三菩提”。言“善男子若诸菩萨”等中、“依七真如”者：谓依七种真如：一者、流转真如。二者、所相真如。三者、了别真如。四者、安立真如。五者、邪行真如。六者、清净真如。七者、正行真如。言“於如所闻所思法中”者：谓於诸奢摩他毗钵舍那、及七种真如所缘法中。於彼诸法、何心能正思惟耶？是故经言“由胜定心”。若於彼诸法由胜定心能缘时、以心变起影像故，彼等便与心真如相违。由所言“善审定”“善思量”及“善安立”等、显说於此真如宜内正思惟。言“性”者：谓即此真如。言“彼於真如正思惟故”中、“彼”者：谓菩萨。言“心於一切细(所)相现行尚能棄捨”者：谓当说由於真如作意思惟能对治一切所相故，如是思惟菩萨一切细所相尚不现前、況诸麤所相能起现行！诸细所相者：谓所说“心所执受(之所)相”、乃至所说“法无我(所)相”。言“既多住”者：谓於真如修习思惟时、数数多住。言“如是行”者：谓为除遣一切所相故、行於真如。言“於时时间”者：谓当说或此是奢摩他义、而非毗钵舍那义，或於此时是毗钵舍那位、而非奢摩他位，或於此时是双运转道。如是安住随所有位菩萨从其一切繫、盖、散动、善修治心故，当何所生起耶？答言：“於七真如、有七各别自内所证通达智生。”以七种真如总摄一切法故。由七种自内证智、即是菩萨见道故，经言“名为见道”。言“由得此故”等中、“正性离生”者：谓唯创观真实。言“又能受用此地胜德”者：即能领受所说一切初地菩萨所有胜德义。言“彼於先时”者：谓诸菩萨未得见道以前位，即於胜解行地中。已得有分别影像所缘、及无分别影像所缘，说言“已得二种所缘”。言“彼於今时得见道故更证得事边际所缘”者：谓由证得遍行义法界故，杂染清净所依事不可得故，及由已至所证边际故，此事边际、即是所证法身。谓住见道菩萨能得双运道所缘以法身为自性、以事边际为境界。言“复於後後一切地中进趣修道”者：谓第二地等中。言“即於如是三种所缘作意思惟”者：谓有分别影像、无分别影像、及事边际。如是於此三种极微细所相内自作意思惟时、“譬如有人以其细楔出於麤楔，如是菩萨依此以楔出楔方便遣内(所)相故、一切随顺杂染分(所)相皆悉除遣。(所)相除遣故、麤重亦遣”。此中贪等过失、即是诸所相。诸见、即诸麤重。言“永害一切(所)相麤重故渐次於彼後後地中如鍊金法陶鍊其心”者：谓譬如鍊金师由後後陶鍊诸业、陶鍊其金，更令明净转增，无复有馀土垢等物所蔽；如是、由後後诸地所有修道能令一切客尘垢染尽远离故，心堪任性、转更明净。由如是道理故、“乃至证得阿耨多罗三藐三菩提、又得所作成满所缘”。此中“所作成满”者：谓由随行自他利益事故，获得无著无碍智、见。
    世尊！云何修行引发菩萨广大威德(或威力)？善男子！若诸菩萨善知六处，便能引发菩萨所有广大威德：一者、善知心生。二者、善知心住。三者、善知心出。四者、善知心增。五者、善知心减。六者、善知方便。云何善知心生？谓如实知十六行心生起差别、是名善知心生。十六行心生起差别者：一者、不可觉知坚住器识生。谓阿陀那识。二者、种种行相所缘识生。谓顿取一切色等境界分别意识，及顿取内外境界觉受，或顿於一念、瞬息、须臾、现入多定、见多佛土、见多如来分别意识。三者、小(所)相所缘识生。谓欲界繫识。四者、大(所)相所缘识生。谓色界繫识。五者、无量(所)相所缘识生。谓空识无边处繫识。六者、微细(所)相所缘识生。谓无所有处繫识。七者、边际(所)相所缘识生。谓非想非非想处繫识。八者、无(所)相识生。谓出世识、及缘灭识。九者、苦俱行识生。谓那落迦识。十者、杂受俱行识生。谓欲行识。十一、喜俱行识生。谓初二静虑识。十二、乐俱行识生。谓第三静虑识。十三、不苦不乐俱行识生。谓从第四静虑、乃至非想非非想处识。十四、染污俱行识生。谓诸烦恼及随烦恼相应识。十五、善俱行识生。谓信等相应识。十六、无记俱行识生。谓彼俱不相应识。云何善知心住？谓如实知了别真如。云何善知心出？谓如实知出二种缚：所谓(所)相缚、及麤重缚。此能善知、应令其心从如是出。云何善知心增？谓如实知能治(所)相缚麤重缚心彼增长时、彼积集时、亦得增长，亦得积集，名善知增。云何善知心减？谓如实知彼所对治(所)相及麤重所杂染心彼衰退时、彼损减时、此亦衰退，此亦损减，名善知减。云何善知加行？谓如实知解脱、胜处、及与遍处、或修，或遣。善男子！如是菩萨於诸菩萨广大威德或已引发、或当引发、或现引发。
    问言“世尊云何修行”等、答言“善男子若诸菩萨善知六处便能引发菩萨所有广大威德”等。谓当说由诸菩萨善知心生、心住、心出、心增、心减、及方便、能引发菩萨所有广大威德。显示能引发菩萨所有广大威德者、即依心生等故。问言“云何善知心生”，答言“谓如实知十六行心生起差别是名善知心生”。言“一者不可觉知坚住识”中、“坚住识”者：谓一切种子阿赖耶识。由此种子即一切杂染及清净品法之习气、是所熏习故，名为坚住。由诸转识易转动故、唯为习气之能熏，而非所熏习气，以彼等是善等自性故。“器识”者：谓所依。由此坚住了别识、及器了别识、二者行相、及所缘、不分明故，名为不可觉知。此心生起者、谓不可觉知坚住识及器识心生。若诸菩萨於此善知晓者，由能除遣总缘一切法阿赖耶识所有一切障及麤重故、便能引发菩萨所有广大威德。言“二者种种行相所缘识”等中、由顿取色等境界故，即是了别种种差别所缘。由有力能计度及随念故、名为“分别”。以能知一切转识为自体故、名为“意识”。“菩萨於此善知”之言、应知於此一切皆当随应说。言“顿取内外境界觉受”中、“外境界”者：谓色等法。“内境界”者：谓所缘等。於彼一切一时能取者、即具有分别意识。於此识生起能善知者、亦如前说。於广说“於一念瞬息须臾”等中、谓诸菩萨由修习奢摩他毗钵舍那故，或时意识於一刹那现入多定。以三摩地是於内转起故。或时於一刹那观见诸方所住众多佛陀土、并观见众多如来、亦应问即由此意识观见耶？以似外显现诸色，应是眼识所缘境界故。由一切转识皆是意识所缘境界故，即此具有种种差别分别意识於彼彼所依处转起时、便得彼彼诸名。譬如即於思业、立身业语业名。所以者何？谓即此福行、非福行、及不动行之思、当知即名身业语业。如是即此奢摩他毗钵舍那最极清净意识於一刹那能见眼识所取众多佛土、及众多世尊如来，应知如是菩萨、名为善知种种差别心生。言“三者小(所)相所缘识生”者：谓亦唯依心生而说。言“谓欲界繫识”者：谓由欲界繫心生是非定地故、名为小所相所缘。言“四者大(所)相所缘识生谓色界繫识”者：谓由色界繫心生是极定地故、名为大所相所缘。言“五者无量(所)相所缘识生谓空识无边处繫识”者：谓由空无边处想或识无边处想而入定、或生、其心生起者，即是空无边处繫及识无边处繫故、名为无量所缘。言“六者微细(所)相所缘识生谓无所有处繫识”者：谓由萨迦耶见相应心起无所有处想缘微细为境、其心生起者，是名微细所相所缘识。言“七者边际(所)相所缘识生谓非想非非想处繫识”者：谓由是界所依处、及世界、所有三摩钵底边际故，即名边际所缘所相了别识心生起。言“八者无(所)相识生谓出世识及缘灭识”者：谓由出世间心生起者、能对治一切所相故，名为无所相识。缘灭心生、亦复如是。言“九者苦俱行识生谓那落迦识”者：谓那落迦有情心生起者、无安乐受间杂故，名为苦俱行。言“十者杂受俱行识生谓欲行识”者：即乐、苦、及捨受、相杂心生起之义。以欲界中具足种种业异熟故。言“十一喜俱行识生谓初二静虑识”者：谓由初及第二二种静虑中、有离生喜受相应心生起故。言“十二乐俱行识生谓第三静虑识”者：谓由第三静虑中有内等净所生安乐心所有法故。言“十三不苦不乐俱行识生谓从第四静虑乃至非想非非想处识”者：谓由第四静虑以上远离八种过患故、捨受相应心生起。八种过患者：谓寻、伺、入息、出息、乐、苦、喜，及忧。言“十四染污俱行识生谓诸烦恼及随烦恼相应识”者：谓贪等为烦恼，忿等为随烦恼。言“十五善俱行识生谓信等相应识”者：即於宝、谛、及业果中、深信等相应心生起之义。言“十六无记俱行识生谓彼俱不相应识”者：即异熟生、威仪路、工巧处及能变化心生起之义。如是已说善知心生、复说“云何善知心住”等。即由问起善知心住。言“谓如实知了别真如”者：谓当说诸菩萨善知诸行唯了别识、名为善知心住。由善知心住时、便能引发菩萨所有广大威德。云何名为了别真如耶？谓唯了别识为此一切之体性。以远离於义故。若梦境等心住、应为唯了别识性者，则眼识等诸了别识、及眼根等诸有色了别、云何应是唯了别识耶？谓一切了别、即具有所相之见、虽无有义，而似二性显现。是故眼了别识等即以色等为所相、以彼之识为能见，乃至以身识为能见故。若意了别者、具有识以眼为最初、法为最後、一切诸了别识为所相、以意识之了别故、为具有能见、以所相与能见者为颠倒等即是杂染所依处。若不尔者，於本无义中、应无容义颠倒。此若无者，烦恼及所知二障一切杂染、亦应无有。此若无者，应成无清净过。当知由理及教、了别真如即是真际。已说心住，复由所言“云何善知心出”等、显示心出。谓由善知心出菩萨於贪等烦恼所相縛、及萨迦耶见等烦恼麤重縛、能如实知此心能出彼縛故，便能引发菩萨所有广大威德(或威力)。已说心出，由所言“云何善知心增”等、显示心增。言“谓如实知能治(所)相縛麤重縛心彼增长时彼积集时亦得增长亦得积集名善知增”者：谓能对治麤重縛奢摩他毗钵舍那双运道转起之所相增时、亦如实知其心增长，名为善知心增。已说心增，由所言“云何善知心减”等、显示心减。言“谓如实知彼所对治(所)相及麤重所杂染心彼衰退时彼损减时此亦衰退此亦损减名善知减”中、“所对治”者：即盖、障及散乱相应心之义。已说心减，由所言“云何善知加行”等、显示心加行。言“谓如实知解脱胜处及与遍处或修或遣”者：谓若菩萨能修解脱、胜处、及与遍处，即是清净心所有加行。言“善男子如是菩萨”等者：谓诸善知如是六处菩萨、由是即总结言：“於诸菩萨广大威德或已引发，或当引发，或现引发。”
    世尊！如世尊说於无馀依涅槃界中、一切诸受无馀永灭，何等诸受、於此永灭？善男子！以要言之，有二种受无馀永灭。何等为二？一者、所依麤重受。二者、彼果境界受。所依麤重受、当知有四种：一者、有色所依受。二者、无色所依受。三者、果已成满麤重受。四者、果未成满麤重受。果已成满受者：谓现在受果。果未成满受者：谓未来因受。彼果境界受、亦有四种：一者、依持受。二者、资具受。三者、受用受。四者、顾恋受。於有馀依涅槃界中、果未成满受一切已(应改正，魏译藏译均作“未”)灭，领彼对治明触生受、领受共有。或复彼果已成满受、又二种受一切已灭，唯现领受明触生受。於无馀依涅槃界中、般涅槃时，此亦永灭。是故说言於无馀依涅槃界中，一切诸受无馀永灭。
    於广说“如世尊说於无馀依涅槃界中一切诸受无馀永灭”等中、言“善男子以要言之有二种受无馀永灭何等为二一者所依麤重受二者彼果境界受所依麤重受当知有四种一者有色所依受”者：谓转色蕴依故，即得土、身、相好、随好无量言音及不见顶相受。言“二者无色所依受”者：谓以非色四蕴转依为能相。此中由转受蕴依故，即得安住广大无量无罪妙乐受。若转想蕴依时，即得於一切名句文身宣说自在受。由转行蕴依故，即得变化摄御徒众及开发白法聚受。由转识蕴依故，即得大圆镜智、平等性智、妙观察智、成所作智受。言“果已成满受者谓现在受”者：谓即此有色所依、无色所依诸受、於一刹那中现起。言“果未成满受者谓未来因受”者：谓即前二受未来果法。言“彼果境界受亦有四种”中、四者何耶？“一者依持受”者：谓诸如来圆满成就不共显、形、量等、广大宫殿依持。“二者资具受”者：谓显现超越诸人天之种种无量资具。“三者受用受”者：谓由受用及变化二身、能令自他领受大乘法乐。“四者顾恋受”者：谓彼果境界受所有诸因、众缘、未尽遇合。言“於有馀涅槃界中”者：谓所依受、及彼果境界受、於如来有馀涅槃界中亦有。言“果未成满”者：谓是未来所有因法。言“领彼对治明触生受”者：谓由染污及非染污无明已永断故。言“一切未(“未”字、汉译作“已”字，应改正。)灭”者：谓由获得明触所生所依受故、则能生起彼所对治染污及非染污无明触所生受由自分别所摄持非共有受生起之种子永灭。复由获得明触所生彼果境界受故，则生起他分别所摄持共有受之种子、於一切所缘中、障未灭故。言“於无馀依涅槃界中般涅槃时此亦永灭”者：谓若如来明触所生所依受及境界受现在前时、亦已令彼得永灭。以能生起彼受、无受之种子、阿赖耶身已灭尽故。言“是故”等者：谓由此总结。若诸如来於无馀依涅槃界中、般涅槃者，云何能尽生死际成办一切他利事耶？谓由宿愿力故、如来虽般涅槃，而能成办所有利有情事。以是如来种种逰戏故。
    尔时世尊说是语已、告慈氏菩萨曰：善哉善哉！善男子！汝今善能依止圆满最极清净妙瑜伽道、请问如来！汝於瑜伽已得决定最极善巧，吾已为汝宣说圆满最极清净妙瑜伽道。所有一切过去未来正等觉者已说、当说、皆亦如是。诸善男子、若善女人、皆应依此勇猛精进当正修学！尔时世尊欲重宣此义、而说颂曰：
    於法假立瑜伽中、　　　若行放逸，失大义。
    依止此法、及瑜伽、　　若正修行，得大觉。
    见有所得、求免难，　　若谓此见为得法，
    慈氏彼去瑜伽远；　　　譬如大地、与虚空。
    利生坚固、而不作，　　悟已、勤修利有情。
    智者作此、穷劫量，　　便得最上离染喜。
    若人为欲、而说法，　　彼名捨欲、还取欲。
    愚癡得法无价宝、　　　反更逰行而乞丐。
    於诤、諠杂、戏论著、　应捨、发起上精进。
    为度诸天、及世间、　　於此瑜伽汝当学！
    尔时慈氏菩萨复白佛言：世尊！於是解深密法门中、当何名此教？我当云何奉持？佛告慈氏：此名瑜伽了义之教。於此瑜伽了义之教、汝当奉持！说此瑜伽了义教时、於大会中有六百千众生发阿耨多罗三藐三菩提心；三百千声闻远尘、离垢，於诸法中得法眼净；一百五十千声闻诸漏永尽心得解脱；七十五千菩萨获得广大瑜伽作意。


略显瑜伽师修习义

    略显瑜伽师修习义

    龙友作颂
    智月释义
    印堪布智铠译师智军译梵为藏
    韩镜清译藏为汉

    小序

    智月论师与胜友、最胜子，俱为护法之弟子，十大论师之一也。其著述除默默收入《成唯识论》之中以外、另有二部能见於今之《丹珠尔》中，可谓珍贵难得！
    此部中间以非常非断遣除二边导入唯了别识中道深义，简便易观，由此入手勤修久习无分别智即可证十地真如，何其捷便！
    据云颂文乃龙友所作。则龙友岂以中观而与唯了别识相水火耶？
    韩镜清

    略显瑜伽师修习义
    龙友①作颂
    智月②释义
    印堪布智铠译师智军译梵为藏
    韩镜清译藏为汉

    敬礼青年曼殊师利！

    如所说之智慧者：不能由诸常见及断见获得。所以者何？若分别其为实有者，由如是故、则当堕为执唯常边。若分别其为实无者，若如是者，亦当堕断见边。由如是故，由如是诸见、即不能得此智体。由此智体具有中道所成本性故。由如是故、说云当勤行中道故。如颂云：
    “由中道所成　　无分别智慧、
     非由诸常见　　断见能获得。”
    又若思择此中道者，即是唯了别识性。唯了别识性者：谓主要表明缘起事体。由唯错乱依他起、显现为所取能取性故。若如其显现、如是实有者，则成常边。若任何无所有者，则成为断边。由如是故、应许假立之事为有。是故说颂云：
    “又所说中道、　由道理观察，
     除唯了别外、　　馀遍非所许。”
    问：若尔、如何《穷源同族经》说如是言：“阿难陀！说实有者、便成为常。说实无者、便成为断。由如是故、如来显示中道法？”
    答：此无有过。虽为遮补特伽罗为主宰故说，然亦非能以其他为主宰。又此不能使其他为主宰者、亦由能除遣补特伽罗故，薄伽梵如是说。
    如是成立唯了别识性为中道已、即取此说颂云：
    “希生等觉之　　无分别智故、
     当恒常加行　　修唯有了别。”
    若有希欲圆证无上正等菩提佛陀体，即由彼等为圆满成办无分别智故、当恒常加行修习唯有了别识性：谓此一切唯有了别。如是观见生起、谓了别识显现。即是若於一切中不见事体之自性者，则既无所取、亦无能取，如是亦不正随观见唯了别识③。是故由远离所取能取分别故，无分别智当任运生起。是故说言当恒常加行修习。由此即是胜益故，是故显示当勤准备。
    具有如是精勤修习慧者、由十地渐次破坏分别故，观见无分别体性。所有所取与能取体性亦以分别是无二为体性，於此所分别既无、能分别亦无④。谓由於此一切无有之上、即增益故，即能决定说此一切都如梦境⑤。是故说云：
    “分别、无分别为体，　及二、以无二为性。
     如是一切如梦境⑤，　於此无所、能分别。”
    此当作是说：除成为颠倒外，极微细法亦无。
    因此即当显示唯应能断离应尽灭坏颠倒。颂云：
    “由所有事体　　无增、亦无减。”
    即此能成立如是颂云：
    “此中都无所排遣，　亦都无有所安立，
     於如实性、如实见，　唯如实见能解脱⑥。”
    是故说言：
    “诸法本来自体性，　唯见真如⑦故解脱。”

        注　　释
    ①龙友(梵文为Nāgamitra，藏译为Kluhi-bshes-geno)据多罗那他《印度佛教史》乃与陈那同时，为佛护之师。另有《悟入三身门颂》，智月解之为《三身论》，均极重要。
    ②智月(梵文为Jānacandra，藏译为Yes-shesvzla-bao)据多罗那他《印度佛教史》为提婆波罗王(Deva-pāla)时人。据《成唯识论述记》卷一为解释世亲《唯识三十颂》十大论师之一，传为护法弟子。此书乃智月不可多得之著作。
    ③《大般若经》第二会《胜军品》第八，《频伽藏》四百○九卷四○页上一○至一八行：“以一切法自性皆空，能取所取俱不可得故。”
    ④《大般若经》第二会《胜军品》第八继云：“於一切法皆不取相，亦不思惟无相诸法，以相无相法皆不可得故。”
    ⑤《成唯识论》二卷五页下四行：“然似法相从缘生故，是如幻有。所执实法、妄计度故，决定非有。”
    ⑥《佛地经论》三卷十页上三行：“由似境现、分明照了。名无障碍、不执、不计、说名无相，亦无分别。妙用难测、名不思议(指真实无漏心品)。”
    ⑦《成唯识论》二卷四页下一行：“真如亦是假施设名。遮拨为无，故说为有。遮执为有，故说为空。勿谓虚幻，故说为实。理非妄倒，故名真如。不同馀宗离色心等有实常法，名曰真如。”


入瑜伽论

    入瑜伽论

    陈那菩萨造
    印度堪布达磨室利跋多罗
    及译师贤宝译梵为藏並校定
    韩镜清译藏为汉

    小序

    多知陈那为因明大师，由此论亦可知其为瑜伽行者，并亦以唯识观为证真如唯一善巧方便，符合慈氏法门修行要领。今并揭示其理趣之所由来，合《显扬圣教论》中第九《成瑜伽品》刊行之，以利悟解而善修习。
    镜清识
    一九八九年八月二日

     〔一〕《入瑜伽论》

    敬礼童身曼殊室利！

    既闻广论又确解，　　　　胜义真如、具净信，
    安坐柔适座垫间、　　　　具慧当勤修瑜伽：
    所取、能取、二、非二、　所谓自我、及他身、
    涅槃、生死众分别、　　　毕竟捐棄，意等至。
    观见无馀所知境、　　　　犹如幻化、寻香城。
    彼以真如金刚智、　　　　极善剖析身幻轮：
    一切行相极美妙、　　　　离初终分、无分别。
    如同无垢光照耀、　　　　定破黑暗，等虚空，
    唯自显现内体性、　　　　观见自心本无生。
    由彼、成为观见此，　　　彼则当见亦如是。
    具无所缘心体性、　　　　乃说真如及实际。
    如是渐次修学故、　　　　当得灭除名言智。
    此中如实触加行、　　　　任运可得五神通。
    与此相应瑜伽师、　　　　能作无量众生利。
    圆满此行瑜伽师、　　　　极长久时当安住。
    身如金刚无破坏，　　　　不为烦恼魔等动。
    所谓智度诸瑜伽、　　　　即可常与彼等俱。
    虚空藏等诸等持、　　　　一切诸定当圆满。
    唯悟入我论瑜伽、　　　　由正加行积众善。
    唯愿一切诸众生、　　　　速得一切智中智！

    〔二〕《显扬圣教论·成瑜伽品》第九
    复次前说菩萨於此位中先修因力等，云何名为先修因力耶？颂曰：
    般若度瑜伽，　　等至无分别，
    一切、一切种、　无有分别故。
    论曰：依止三摩钵底(梵为Samaptti,藏为Som-par-hjng-pa.)发起般若波罗蜜多瑜伽胜行，即此正慧能到彼岸、是大菩提最胜方便，故名瑜伽。此所依止等至无有分别。於一切法及一切种(行相)无分别故。
    云何一切及一切种(行相)？颂曰：
    一切、一切种，　　　　三相、与三轮：
    谓名相(及能)、染净、　及俱非二种。
    论曰：“一切”者：谓三轮：一、所知境。二、能知智。三、能知者。“一切种”者：谓三相：一、名(及能)相。二、染净。三、俱非。“名”者：谓假立等十二种名①。〔注〕“(能)相”者：谓自(能)相、共(能)相。“染”者：谓染污法。“净”者：谓诸善法。“俱非”者：谓无覆无记法。
    复次、如是所说无分别者、於何等法说无分别耶？颂曰：
    於法、及法空、　无二种戏论，
    无分别无穷；　　此上、非应理。
    论曰：法与法空、俱无二分别、二种戏论故，名无分别。云何为二？谓有、及无。何以故？色非是有。遍计所执(能)相无故。亦非是无。彼假所依事有故。色空亦非有。遍计所执(能)相无所显故。亦非是无。诸法无我有所显故。如於色、色空(性)，如是於馀一切法、及一切法空(性)、当知亦尔。非离法及法空(性)外、更有馀境是可得者。是故但说二无分别。非无分别更无分别、有无穷过。此上更无所知境故。
    复次、颂曰：
    若都无所取，　无慧、亦无度、
    俱成取离言。　为顺、非无用。
    论曰：此若无有二种分别，即无有取。都无取故、慧体尚无，況到彼岸！是故必有离言(能)相取。由此取故、慧到彼岸二俱成就。所以者何？由此圣慧虽不取如所言(所)相性，而取离言能相性故。问：若此圣慧不取如言(所)相性者，宣说正法应无所用！答：不然，为随顺故。所以者何？为欲随顺离言能相取、是故如来宣说正法。

        註　　释
    ①亦见《显扬圣教论》〈摄净义品〉，《瑜伽师地论》卷八十一有文相同，但译名有异。今注明其下，其文云：
    名身者：谓共了增语。此复略有十二种：一、假名(“假立名”)，二、实名(“实事名”)。三、总名(“同类相应名”)。四、别名(“异类相应名”)。五、随义名(“随德名”)。六、戏论名(“假说名”)。七、易名(“同所了名”)。八、难名(“非同所了名”)。九、显名。十、隐名(“不显名”)。十一、略名。十二、广名。假名者：谓於内诸蕴立我、有情、命者等名。於外诸色立瓶、衣、车乘等名。实名者：谓於眼等、色等、立根、义等名。总名者：谓有情、色、受、大种等名。别名：谓佛友、德友、青、黄等名。随义名者：谓质碍、故名色。领纳、故名受。能照、能烧、故名为日，如是等名。戏论名者：如呼贫名富。如是等类不观於义施设彼名。易名者：谓共所知想。难名者：谓翻於彼。显名者：谓其义易晓。隐名者：谓其义难晓，如达罗弭茶明咒。略者：谓一字名。广者：谓多字名。


正理滴点论(滴点即精要义)

上一页 目录 全文完

正理滴点论(滴点即精要义)

    正理滴点论(滴点即精要义)

    法称著
    班祇达利他贤及西藏译师具觉慧等译梵为藏
    韩镜清译藏为汉

    叙言

    敬礼儒童相曼殊室利！
    如实智者：由是具有以成就一切众生利益事业为先行故、显示此智。(此为造论所为。)如实智者、有二种：一、现量。二、比量。

    现量品第一
    此中现量者：谓远离分别、及不错乱。
    分别者：谓适与言说(指表义名言。)相杂显现。即远离此、不由眩㧐、迅速旋转、乘船、患病等生起错乱之智，即现量。此有四种：一、根智。二、自境无间具有能俱起境由根智等无间缘能生起之意识。(《成唯识论》说开导依时五识不能作意识等无间缘。)三、一切心心所法自证分。四、修习如实义最胜边际所生瑜伽智。(指证见道前位定心。)彼之境界即自能相。若义邻近及不邻近、於智上显现差异，即此、为自能相。即此、为胜义有。事体能相者、谓唯能作义之能相故。
    其馀为共能相。此为比量境界。
    唯此现量智为能量果，唯以了知义为自性故。与义相似性、为彼能量。(陈那等以相分为行相。)由此增上力、能成就义之了知故。

    自悟比量品第二
    比量有二种：一、自悟比量。二、悟他比量。
    此中依自悟所比知之三律中标志而知。此中安立能量果、亦与现量同。
    三律中标志者：谓决定：一、所比知中必有性。二、同品中定有性。三、异品中遍无性。
    “所比知”者：此中谓具有所欲知其差别之能有法。“同品”者：谓与所成立法之总项为义相同。“异品”者：谓非同品。即与彼义异、与彼义相违、及彼义为无有。
    此三律者、谓唯具有三种标志：一、无所缘。二、自性。三、果法。
    此中“无所缘”者、喻如说言：於某所立宗之差别中、无有瓶。谓如说依成为所缘之可觉知、不可得故。成为所缘之可觉知者：谓其他所缘缘具足性、及具有差别自性。若既有自性、又有其他所缘缘等者，唯当为现量。
    “自性”者：谓自唯已成为有，即是所成立法之成立因。喻如说言：“此为树。由是沉香木故。”
    “果法”者：谓如说言：“此处有火。由有眕故。”
    此中：一为事体之能成立，一为遮遣之成立因。
    若与自性有连属者，则由义能悟义。若与彼不相连属者，於此中无有决定不错乱故。
    於所成立之义中、其与标志相连属者、亦直接为所成立义之自性故，及由所成立义所生起故。非彼之自性、及非彼所生起者、即以与彼无有相连属为自性故。此彼之我自体、及由彼生起二者、亦唯是自性及果法，唯由此二、能成就事体。
    能立遮遣、亦唯依如上所说无所缘。若有事体者，则此无所缘、不可能有故。不尔，由处所、时间、及自性远隔离义、诸不成为所缘之可觉知中、虽与自现量相违，然亦无能决定事体为无有故。不愚昧回忆诸行能成立者、若违反其过去及现在现量者，则无有事体之语言转起。由决定无有唯即如是之事体故。
    此随其所应构成之差别、有十一种：
    一、自性不可得。喻如说言：“此处无眕。由依成为所缘之可觉知不可得故。”
    二、果法不可得。喻如说言：“此处无有眕之生起因功能、对碍等。由无眕故。”
    三、能周遍不可得。喻如说言：“此处无有沉香木。由无树故。”
    四、自性相违可得。喻如说言：“无有冷触。由此处有火故。”
    五、相违果法可得。喻如说言：“无有冷触。由此处有眕故。”
    六、相违周遍可得。喻如说言：“事体已生起、决定不成为灭。由观待他因故。”(此成立因不如理。即非大乘极成。由说诸行灭不待因故。)
    七、果法相违可得。喻如说言：“冷之生起因功能、对碍等无有。由此处有火故。”
    八、能周遍相违可得。喻如说言：“无有霜触。由此处有火故。”
    九、生起因不可得。喻如说言：“无有眕。由此处无有火故。”
    十、生起因相违可得。喻如说言：“无有所谓毛竖等差别。由邻近能炽热之差别故。”
    十一、违反生起因之果法可得。喻如说言：“无有具有能说毛竖等差别之人。由於此方有眕故。”
    虽由有他义及由遮止等随应构成不同，但由间接为门，此果法不可得等一切十种不可得随应构成、均当为自性不可得内部所摄。
    由当了知我自体亦依惯习观见、随应构成而如是辨别故，於自悟比量中、亦显示其差别。
    於一切此等不可得能成立为无有之言语中、亦由自性相违等可得、及生起因等不可得故，所有解说为遮止者、亦当知均为依所缘之所觉知为可得及不可得。由於其他中相违反、及生起因与果法有无、不成就故。远隔离境界不可得之现量、及比量所有能相、即是疑惑之生起因。虽违反能量，亦不成就为无义故。

    悟他比量品第三
    悟他比量者：谓说三律人中之标志。由於生起因假立为果法故。由随应构成之差别故、此有二种：一、具有同法性。二、具有异法性。除随应构成差别外、此二差别实为无有。
    此中具有同法性者：谓若诸成为所缘之可觉知、都不可得者，即此、成就为以无有为语言之境界：喻如说言：“犹如有某人观见兔角等。即於差别所立宗中成为所缘之可觉知、瓶为不可得。”如是自性之成立因随应构成者：谓若诸为有者，即此一切无为常。喻如说言：“犹如瓶等。”即纯自净性之随应构成。言“若诸具有生起，即此为无常”者：即由成为自性之法差别故、说为自性随应构成。此言“若有所作即此无常”者：即由能作为差别上之差别故。由当成就自性故。以观待其他之能作为自性、说为“所作”。由勤勇无间所生、及由缘之差别故具有差异性等时、亦如是应知。说言“有”、或“具有生起”、或“所作”等声、能显示宗所有法。
    彼诸一切能成立法者：谓由其如能成立自体性故，当了知唯能成就所成立法与能成立法单纯相随逐。实则由即此为彼之自性故。及由自性即是成立因故。若既成就此而不成就彼者，则彼之自体性为无故、由亦能有错乱故。
    以果法为成立因之随应构成者：谓若处、有眕，即此处有火。喻如说言：“如？房等、此处亦有眕。”此亦唯於能成就生起因事体及果法事体中、於生起因法为所成立时、当说果法为成立因。
    具有异法性之随应构成者：谓既若彼为有、且成为所缘之可觉知者，即唯此、成为可得。喻如说言：“若犹如青等之差别者、则於此处成为所缘之可觉知；瓶如是不可得。”即不可得随应构成。若无有无常性、或为有、或具有生起、或无有所作性者；则说“声为有、具有生起、或所作”者：即由自性随应构成。於若无有火则眕不生起性中、说“此处有眕”者即是以果法为成立因之随应构成。若依义推度者，由同法故、亦於随应构成中了知异法性：谓此若无者，则所成立、无有成立因之随行故。如是由异法故、亦了知随行：谓此若无者，即是若无所成立者，则不成就成立因为无有故。若无有自性相连属者，则由其一相违反故、其他亦非决定相违反。此亦为一切之二行相：即是说为彼之自性、及依彼生起。因此、由说相违反故，当显示相连属。由如是故，由相违反语句、亦唯摄相连属。若诸显示相连属，即此、亦说为“随行”。由如是故，既可以随行为门、又可以违反为门。谓由说一语句亦当显示於同品与异品中、有标志与无标志故。若如是者，则无有决定由二语句显示随应构成。於不可得中、亦若彼为有而成为所缘之可觉知者，即此、若如是显示唯当成为所缘不可得者；则了知为所谓“如是为无”故、即成就随行。於此二随应构成中、亦无决定显示所立宗。此中於具有同法性随应构成内、若成为所缘之可觉知是可得者，即此、於显示既以无有之语言为境界、且於此上成为所缘之可觉知、瓶不可得时，势必当说“於此无瓶”。如是亦具有同法性随应构成内、若诸既有以有之语言为境界又成为所缘之所知，即此、唯当成为可得者；则於此上由说此如是之瓶不可得故、势必当说此处无有以有之语言为境界。
    当显示如何者为所立宗？谓当显示唯自所有性、题性、随许、及不排除者、为宗。言“自所有性”者：谓唯许为所成立。言“唯自所有性”者：虽唯许为所成立，然亦非应为能成立。喻如於“声是无常”为所成立时、由成立因“眼所取性”不成就为声故、若是所成立者，彼於此中由唯说能成立性故、不许唯是所成立性。
    言“题性”者：谓於尔时由论辩故、始说为所成立。因此、若即使依某论典说为能成立者，然亦由能作此论典故、於此有法中虽许众多法，然於尔时当显示说：由此论辩、若法许为能成立，即此、亦是所成立；而另一、非是。
    言“随许”者：谓若於是义由诤论故，安置为能成立、即许为能成立。彼者虽未明说成语句，然亦是所成立。由彼乃诤论之所依故。喻如说言：“眼等能作他益，是合成故。如卧具及坐垫等之支分。”此中虽不说自益，然自益性、是所成立。因此、当显示：非唯言宣者是所成立。
    言“不排除”者：谓虽具有彼诸能相，然由显示於所有许为能成立之义中，若诸由现量、比量、极成、及自语句所排除者，即此、非是宗故。此中由现量所排除者：喻如说言：“瓶是常。”由极成所排除者：喻如说言：“怀兔非月。”
    由自语句所排除者：喻如说言：“比量非是能量。”即是排除四种似宗。
    若如是者，已成就及未成就亦许为能成立性、尔时由论辩题性不许为能成立、唯是言宣以及与排除相反者、为所成立。以即此为自性、论辩之所随许、及不排除者、为宗。若如是者，即是显示无罪过所立宗之能相。
    依此所说“悟他比量者谓说三律中标志”、若三律中缺说其一者，则亦为似能成立。虽已言宣，然若於所了解和能了解二者之间不成就、或生起疑惑者、亦尔。若与有法相连属之一律不成就、或生起疑惑者，则成为不成就之似成立因。喻如成立“声无常”时、“如眼所取性”於二者中间不成就。成立“诸树木有心”时。“剥去一切皮便死”。即於敌论者方不成就，此即以识、根、及寿灭、为能相中、许是死故。此亦於诸树木、不能有故。
    於能成立乐等为无思量时、具有生起或无常性者，数论敌方不成就为於论辩题性。如是若於题性、及彼之所依、生起疑惑者，亦即不成就。喻如於所成立火中、却以疑为风等事体之大种所和成。喻如说言：“此山谷中有孔雀。由出孔雀鸣声故。”时、彼並不知鸣处。
    若有法不成就者，亦即为不成就。喻如成立“我住在一切处时、即是於一切处可得之功德性”。
    如是若於异品中所无有之一律不成就者，则亦是不决定之似成立因。喻如成立“声是常性”等之法时、“所量性”等法者或於一切同品和异品中、或於一品中为有。如是即於此一律中生起疑惑者、亦唯不决定：喻如“於成立某一许为言说之人”“非是一切智”、或成立“具有贪著等”者时、言说等之法。与异品相违反时、即生起疑惑。如是说言：“一切智者言说不可得。”如是所谓不可得之行相、由不显现似境界性、是疑惑之生起因故。因此、与非一切智相违反时、与言语等相违反即当成为疑惑。言语性与一切智性二者中间、无有相违反故。虽不观见，然而说言：“若为一切智，即此、非言语。”如是之相违反、即不成就。由生起疑惑故。
    诸事体之相违反、有二种：一、生起因无不具足而生时、若有异者，即无有故；即相违反。如冷触及热触。二、唯以展转互相抵销而住为能相，如有与无。此二种相违反、亦於言语性和一切智体中不能有故。由不相违反则为有故、虽尚不可得，然非了知为无。贪著等、与语句等、亦不成就为生起因事体与果法事体故，由与其馀义非生起因相违反故、非是与语句等相违反。如是与语句等相违反时、即是与疑惑相应之不决定故。
    成就二律之颠倒者、即是相违过。何者为二耶？一、同品中有。二、异品中无。
    所作性、及勤勇无间所发性、成立常性，亦是相违似成立因过。由此二之同品中无、及异品中有故，成为颠倒。此二能颠倒成立所成立故，即是诸相违成立因过。
    由能损害随许故、亦非第三相违成立因耶？喻如说言：“眼等亦能为他益性。由是和合故。此如卧具及座垫等支分。”彼许、“非和合”能为他益。由能颠倒成立故、即是相违成立因过。此何故不说耶？唯此二内部所摄故。由此能颠倒成立所成立故、与此二无有差异。於所随许及言宣二者中、与所成立性全无差别。
    离二律外、即无有一可成就，而於另一中生起疑惑、即是不决定。喻如说言：“由言语故。或远离贪著等、或是一切智。”
    此中相违反者、既为不成就，而於随行中者、即生起疑惑。
    由一切智及远离贪著、是远隔离故，此中於有语句等或无有语句起疑惑故。即於此律中若生疑惑者，即不决定。喻如说言：“灵活身躯即具有我。由具有命根等故。”约具有我或无有我、若於此中除命根等住在五蕴以外、别无所有。由我住、与我断等、能摄一切故。从此二者住在另一中、亦不决定。於成立具有我或无有我时、命根等不成就故。因此、具有与灵活身躯相连属之命根等、不成就与一切具有我与无有我相违反性故，即与此二不相远离。由於一我亦不成就故、此中无有随行。此具有我与无有我之随行、及相违反、无有决定二俱无有。由随行及相违反两者唯以互相简别为性故，由决定无一、另一无可决定无疑为有故。即由此故，於随行及相违反中、为怀疑之不决定。由於所成立及另一中、无有决定故。若尔，即除此等三律以外、每一律、或每二律、即为不成就，或生起疑惑；随其所应、即为三种似成立因：即不成就、相违反、及不决定。若具有不错乱相违反、亦解说为怀疑之生起因者，则於此中不复说彼。由於比量境界中、不能有故。说果法、或自性、或无所缘之能相时、不能有具有不错乱相违反，且无其他具有不错乱。由如是故，因其由不观见事体之力而悟入故、乃是依於以教为依之比量。於观察彼义时、具有不错乱相违反者、即解说为能成立过失。诸能作论典者由於诸义错乱、能有颠倒显示为自性故。如其事体如是安立，於自体、果法、及无所缘等中、不能有故。
    此中喻者：谓若有遍住一切处所、诸具有与己相连属、及单独相连属者，即此、为遍住一切。喻如虚空等。总共亦遍一切处具有与己相连属、及俱时一齐相连属。
    唯以具有与彼连相属之自性为其具有随转自性者、即为於彼之处所存在之自体性。
    若於是处、彼为无者，即说此处、其体性非能周遍。即是自性成立因随应构成。第二随应构成者亦为若有於彼处、成为可得之所缘不可得者，即此、於是处为无。喻如说言：“今於某处、无瓶。”对此许纳、乃至遮遣等中、亦说为所缘之可觉知总不可得。
    由此不可得、与彼自性由已成立为更互相违反之义故，於其一中、能生起疑惑。唯由此所说成立因中三种能相能了知义故、成立以所谓喻为支分，另外都无所有。因此、此成因离如是以外不说为彼之能相，由义可知故。
    成立因者：谓当无差别解说为同品性中定有、及一切异品中遍无之规律时，亦差别解说当知显示为果法、及自性二种之生起、及唯彼所有随转。由此亦能显示故、若处有眕，即此处有火；而若处无火，亦无有眕。喻如？房、及其他处所。若於是处、有所作性，即於此处、有无常性；而若无无常性，则所作性亦不得有。当解说言：“喻如瓶、及虚空等。”若不尔者，则不能显示作如是说之行相：谓同品及异品中、为有与无等。
    果法之标志者：谓决定为彼之果法性、或自性之标志者、即由自性所周遍；为彼之规律者、仅只如此而已故。诸喻之过失、亦由此排除。喻如说言：“声是常、由不具有形体故。如业、极微、及瓶。”如是即无有所成立及能成立二法。如是亦於所成立法中生起疑惑等，喻如说言：“此具有贪著等，由言语故，即具有贪著等。如大路上人。”及如说言：“此人具有死法，由具有贪著等故。如大路上人。”
及如说言：“此非一切智人，由具有贪著等故。如大路上人。”
    无有随行及不善显示随行者：喻如说言：“若彼言语，即此、具有贪著等。如有欲人。”及如说言：“声是无常。所作性故。如瓶。”
    如是随行颠倒者、谓如说言：“若无常者，即此、为所作。”即是由同法故。由异法故，亦说“如极微、业、及虚空”。如是即具有与所成立等不相违反等。
    如是与所成立相违反时、生起疑惑等者：喻如说言：“黄赤仙人等、非是一切智或可崇信者。由唯无有显示一切智成为远离贪著之标志、歧出之能量智故。”
    此中异法喻者：谓若有是一切智、或远离贪著，即由此显示星象智等。喻如毗湿奴天、及遍入天等。依异法喻与所成立法“非是一切智体”及“非是可崇信者”二俱相违反时、即生起疑惑。
    与能成立相违反时生起疑惑者：谓喻如说言：“由三明之婆罗门当不取任何人许说之语句。由具有贪著等故。”此中异法喻者：谓若是诸所应取语句者，即此、不“具有贪著等”。喻如“乔答摩等能作诸法论典”。能成立法“具有贪欲等”与乔答摩相违反，即生起疑惑。
    与二相违反生起疑惑者：喻如说言：“黄赤仙人也具有普摄遍受、及性悭悋故。非远离贪著。”此中异法喻者：谓若有远离贪著，即此、无有普遍摄受、及悭悋。喻如毗湿奴天。所成立法、及能成立法、“远离贪欲性”、及“普遍摄受、悭悋”、与毗湿奴天相违反时，即生起疑惑。
    无有相违者：谓喻如说言：“非远离贪著。由言语故。”若彼无有“不远离贪著性”，即此、非是言语。说言：“喻如石块。”若由石块虽与二者相违反，然不成就、与所说一切远离贪著、非言语、周遍相违反故，即是无有相违。
    不善显示相违者：谓说声者所作之无常之异法言：“喻如虚空。”
    颠倒相违反者：谓喻如说言：“若非所作，即此、为常。”
    因此诸似喻不能显示同品性中定有、及一切异品中遍无性等成立因相之共能相，或差别能相。是故依义增上力、当知排除彼等。
    揭示欠缺性等者：谓能破斥等。若诸揭示先前能成立之缘不具足等，即举发此等、为能破斥。由此於外论成就所许义时、能遮止故。
    相似能破斥等者：谓似能破斥、举发非实过失等者、即似能破斥。

因明用词新译五例(为避免串解)
梵 | 藏 | 旧译 | 新译 | 备注
Hetu | Rgyu | 因 | 生起因 | 为简别“成立因”。
Phala | Hbras-bu | 果 | 果法 | 顺从於生起因而言。
Hetu | Gtan-tshigs | 因 | 成立因 | 为简别“生起因”、实由果法而逆知生起因。今从杂集论译例、或译为“成立因”“信解因”。
Liga | Rtags | 相 | 标志 | 标别有或无。
Vishi | Tshul | 相 | 律、规律 | 成立一义必由三律决定。

上一页 目录 全文完